Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 580646 - dev-ml/core_profiler-113.33.00 : (.text+<snip>): undefined reference to `makedev'
Summary: dev-ml/core_profiler-113.33.00 : (.text+<snip>): undefined reference to `make...
Status: RESOLVED DUPLICATE of bug 627946
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Team for the ML programming language family
URL:
Whiteboard: ~arch only
Keywords:
Depends on:
Blocks: glibc-sysmacros
  Show dependency tree
 
Reported: 2016-04-20 14:56 UTC by Toralf Förster
Modified: 2018-04-27 22:44 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
dev-ml:core_profiler-113.33.00:20160420-144651.log (dev-ml:core_profiler-113.33.00:20160420-144651.log,39.59 KB, text/plain)
2016-04-20 14:56 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,398.62 KB, text/plain)
2016-04-20 14:56 UTC, Toralf Förster
Details
environment (environment,82.36 KB, text/plain)
2016-04-20 14:56 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2016-04-20 14:56:38 UTC
This bug report feeds bug #575232 (sys-libs/glibc-2.23.r1 breakage).
00:00:25 134  (0   ) offline_tool/bin/dump_metrics.native            ONbP--iL /
00:00:25 134  (0   ) offline_tool/bin/dump_metrics.native            ONbP--iL /
00:00:25 134  (0   ) offline_tool/bin/dump_metrics.native            ONbP--iL -
00:00:25 134  (0   ) offline_tool/bin/dump_metrics.native            ONbP--iL -
00:00:25 134  (0   ) offline_tool/bin/dump_metrics.native            ONbP--iL -
00:00:25 134  (0   ) offline_tool/bin/dump_metrics.native            ONbP--iL \
00:00:25 134  (0   ) offline_tool/bin/dump_metrics.native            ONbP--iL \
00:00:26 134  (0   ) offline_tool/bin/dump_metrics.native            ONbP--iL |
00:00:26 134  (0   ) offline_tool/bin/dump_metrics.native            ONbP--iL |
00:00:26 134  (0   ) offline_tool/bin/dump_metrics.native            ONbP--iL |
00:00:26 134  (0   ) offline_tool/bin/dump_metrics.native            ONbP--iL /
00:00:26 134  (0   ) offline_tool/bin/dump_metrics.native            ONbP--iL /
00:00:26 134  (0   ) offline_tool/bin/dump_metrics.native            ONbP--iL -
[K+ /usr/bin/ocamlfind ocamlopt -linkpkg -thread -linkpkg -package variantslib -package typerep -package textutils -package sexplib -package re2 -package ppx_inline_test.runtime-lib -package ppx_expect.collector -package ppx_bench.runtime-lib -package ppx_assert.runtime-lib -package fieldslib -package core_extended -package core -package bin_prot disabled_lib/core_profiler_disabled.cmxa src/core_profiler.cmxa offline_tool/lib/core_profiler_offline_tool.cmxa offline_tool/bin/dump_metrics.cmx -o offline_tool/bin/dump_metrics.native
/usr/lib64/ocaml/core/libcore_stubs.a(unix_stubs.o): In function `unix_mknod_stub':
(.text+0xf8a): undefined reference to `makedev'
/usr/lib64/ocaml/core/libcore_stubs.a(unix_stubs.o): In function `unix_mknod_stub':


$ cat emerge-info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-13.0-unstable_20160412-150430) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------

  make.conf: USE="mmx sse sse2 pax_kernel -cdinstall -oci8 -bindist aes-ni alsa compat csc -curl egl extraengine -fortran -gles2 gnomecanvas gtkstyle haptic help icu javascript -javaxml -jpeg kerberos llvm mod mssql multitarget mysqli objc offensive openexr plasma postgres postproc scrypt server spice sse4_1 sse4_2 system-llvm szip tcl -vaapi vdpau xinetd xmlreader xmp xvfb -zip"

  -----------------------------------------------------------------
Portage 2.2.28 (python 3.4.3-final-0, default/linux/amd64/13.0, gcc-5.3.0, glibc-2.23-r1, 4.4.7-hardened x86_64)
=================================================================
System uname: Linux-4.4.7-hardened-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16157888 total,   1391608 free
KiB Swap:   16777212 total,  16715032 free
Timestamp of repository gentoo: Wed, 20 Apr 2016 13:04:02 +0000
sh bash 4.3_p42-r2
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
ccache version 3.2.5 [disabled]
app-shells/bash:          4.3_p42-r2::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.22.1::gentoo
dev-lang/python:          2.7.11-r2::gentoo, 3.3.5-r7::gentoo, 3.4.3-r7::gentoo, 3.5.1-r2::gentoo
dev-util/ccache:          3.2.5::gentoo
dev-util/cmake:           3.5.2::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.20.5::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.9.6-r4::gentoo, 1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo, 5.3.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.de.gentoo.org/gentoo-portage/
    priority: 1

local
    location: /usr/local/portage
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/omega.conf /usr/lib64/fax /usr/share/config /usr/share/easy-rsa /usr/share/gnupg/qualified.txt /var/rancid/.cloginrc /var/spool/fax/etc /var/yp/Makefile"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/games/angband/gamedata/ /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/apache2-php7.0/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cgi-php7.0/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/php/cli-php7.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose-conflicts --color=n --nospinner --tree --quiet-build --accept-properties=-interactive --accept-restrict=-fetch"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="acl aes-ni alsa amd64 berkdb bzip2 cli compat cracklib crypt csc cxx dri egl extraengine gdbm gnomecanvas gtkstyle haptic help iconv icu ipv6 javascript kerberos llvm mmx mmxext mod modules mssql multilib multitarget mysqli ncurses nls nptl objc offensive openexr openmp pam pax_kernel pcre plasma postgres postproc readline scrypt seccomp server session spice sse sse2 sse4_1 sse4_2 ssl system-llvm szip tcl tcpd unicode vdpau xattr xinetd xmlreader xmp xvfb zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_GB" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2016-04-20 14:56:43 UTC
Created attachment 431370 [details]
dev-ml:core_profiler-113.33.00:20160420-144651.log
Comment 2 Toralf Förster gentoo-dev 2016-04-20 14:56:46 UTC
Created attachment 431372 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2016-04-20 14:56:48 UTC
Created attachment 431374 [details]
environment
Comment 4 Andreas K. Hüttel gentoo-dev 2017-10-20 20:22:54 UTC
Ping - this is now blocking glibc-2.25 stabilization.
Comment 5 Alexis Ballier gentoo-dev 2017-10-23 12:04:33 UTC
(In reply to Andreas K. Hüttel from comment #4)
> Ping - this is now blocking glibc-2.25 stabilization.

it is not as it is ~arch only package; plus this has already been fixed and _profiler is not the culpit

*** This bug has been marked as a duplicate of bug 627946 ***