Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 580616 - dev-libs/libffi-3.2.1: stabilize
Summary: dev-libs/libffi-3.2.1: stabilize
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: PPC64 Linux
: Normal enhancement (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks:
 
Reported: 2016-04-20 09:54 UTC by Leno Hou
Modified: 2017-01-17 14:28 UTC (History)
1 user (show)

See Also:
Package list:
dev-libs/libffi-3.2.1
Runtime testing required: ---
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leno Hou 2016-04-20 09:54:18 UTC
When building libffi-3.0.13 on ppc64le, it's failed due to abi-v2 problem. 
And version >=>=dev-libs/libffi-3.2.1 fixs the abi-v2 problem.

Also can see details in github PRs in here 
https://github.com/ffi/ffi/issues/413

So we need to stable to libffi-3.2.1. Thanks

Reproducible: Always
Comment 1 Leno Hou 2016-04-22 02:39:47 UTC
Yes, build failed with ppc64le. ppc64le must run in abiv2 but the libffi-3.0.13 code wrote in abiv1. Sorry for can't attach the build log due to loss. 

Also can see details in github PRs in here 
https://github.com/ffi/ffi/issues/413
Comment 2 Markus Meier gentoo-dev 2016-05-01 06:49:50 UTC
arm stable
Comment 3 Agostino Sarubbo gentoo-dev 2016-05-13 08:49:55 UTC
amd64 stable
Comment 4 Matt Turner gentoo-dev 2016-05-25 06:32:13 UTC
alpha stable
Comment 5 Jeroen Roovers gentoo-dev 2016-05-25 07:44:25 UTC
Stable for HPPA PPC64.
Comment 6 Agostino Sarubbo gentoo-dev 2016-06-25 20:17:31 UTC
x86 stable
Comment 7 Agostino Sarubbo gentoo-dev 2016-07-06 09:25:15 UTC
ppc stable
Comment 8 Agostino Sarubbo gentoo-dev 2016-12-28 08:43:09 UTC
Dear Maintainer (or who is mainly involved in this stable request),

This is an auto-generated message that will move the current component to the new component Stabilization.
To ensure that the stabilization will proceed correctly, please fill the fields "Atoms to stabilize" and "Runtime testing required" as described here:
https://archives.gentoo.org/gentoo-dev/message/4b2ef0e9aa7588224b8ae799c5fe31fa
Comment 9 Agostino Sarubbo gentoo-dev 2017-01-11 10:41:01 UTC
sparc stable
Comment 10 Agostino Sarubbo gentoo-dev 2017-01-17 14:28:46 UTC
ia64 stable. Closing.