Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 576548 - media-sound/qjackctl should not depend on X11 (needed for running natively on Wayland)
Summary: media-sound/qjackctl should not depend on X11 (needed for running natively on...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Professional Audio Applications Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-05 21:35 UTC by Yaroslav Isakov
Modified: 2016-03-06 17:22 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yaroslav Isakov 2016-03-05 21:35:18 UTC
qjackctl right now is building with hard dependency on X11, for uniqueness checking. Because of this dep, it cannot be started natively on Wayland using "-platform wayland". This could be easily disabled by adding
$(use_enable X xunique)
into the ebuild.The re-emerging qjackctl with USE="-X" fixes segfault in qjackctl.

Also, it seems that it depends on X11:
AC_CHECK_LIB(m, main)
AC_CHECK_LIB(X11, main)
AC_CHECK_LIB(Xext, main)
....
# Some recent distros (eg. fedora, debian) require this.
ac_libs="$ac_libs -lX11"
This should be also optional, I think, or it should be reflected in the RDEPEND/DEPEND section, at least.