Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 57619 - /usr/bin/sensors -s makes computer start beeping
Summary: /usr/bin/sensors -s makes computer start beeping
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Tim Yamin (RETIRED)
Depends on:
Reported: 2004-07-19 11:22 UTC by Paolo Pedroni
Modified: 2004-07-20 10:22 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

Here is my /etc/sensors.conf file (sensors.conf,63.33 KB, text/plain)
2004-07-19 11:25 UTC, Paolo Pedroni

Note You need to log in before you can comment on or make changes to this bug.
Description Paolo Pedroni 2004-07-19 11:22:48 UTC
With kernel 2.6.7-gentoo-r11 (and all the 2.6 kernels I tried before) after loading all the correct i2c modules at startup, when the /etc/init.d/lm_sensors script launches /usr/bin/sensors with the "-s" option, the computer speaker starts a long continuous loud beep that cannot be stopped even though all the sensor values are in their right interval

Reproducible: Always
Steps to Reproduce:
1. modprobe i2c-dev
2. modprobe i2c-nforce2
3. modprobe i2c-isa
4. modprobe eeprom
5. modprobe it87
6. /usr/bin/sensors -s
Actual Results:  
Computer speaker starts beeping and cannot be stopped 

Expected Results:  
Just setup all the sensors 

'emerge info' output: 
Portage 2.0.50-r9 (default-x86-2004.0, gcc-3.3.3, glibc-, 
System uname: 2.6.7-gentoo-r11 i686 AMD Athlon(tm) XP 3200+ 
Gentoo Base System version 1.4.16 
ccache version 2.3 [enabled] 
Autoconf: sys-devel/autoconf-2.59-r3 
Automake: sys-devel/automake-1.8.3 
CFLAGS="-march=athlon-xp -O3 -pipe -fomit-frame-pointer" 
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control" 
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d" 
CXXFLAGS="-march=athlon-xp -O3 -pipe -fomit-frame-pointer" 
FEATURES="autoaddcvs ccache sandbox" 
USE="3dnow X Xaw3d aalib acpi alsa arts avi berkdb bindist cdr crypt cups curl 
dga divx4linux doc dvd encode esd evo foomaticdb gb gd gdbm gif gnome gpm gtk 
gtk2 gtkhtml imlib ipv6 java joystick jpeg kde libg++ libwww mad maildir mbox 
mikmod mmx motif mozilla mpeg ncurses nls oggvorbis opengl oss pam pdflib perl 
png python qt quicktime readline scanner sdl slang spell sse ssl svga tcltk 
tcpd tetex threads tiff truetype unicode usb videos wmf x86 xml2 xmms xosd xv 
xvid zlib"
Comment 1 Paolo Pedroni 2004-07-19 11:25:32 UTC
Created attachment 35761 [details]
Here is my /etc/sensors.conf file

This is my sensors.conf file. It worked perfectly when I was running Mandrake
Linux 9.2
Comment 2 Tim Yamin (RETIRED) gentoo-dev 2004-07-20 04:13:17 UTC
What lm-sensors version are you using?
Comment 3 Paolo Pedroni 2004-07-20 10:20:06 UTC
lm-sensors-2.8.7, but it was the same with 2.8.6 as well.
Comment 4 Tim Yamin (RETIRED) gentoo-dev 2004-07-20 10:22:43 UTC
Hm; you really should file a bug with the lm-sensors people at since this isn't a Gentoo specific issue AFAIK and thus we can't do anything about it. If you find that it is a Gentoo specific issue though, then please feel free to reopen this bug. Thanks!