Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 57614 - kde-?/kionjb (new package)
Summary: kde-?/kionjb (new package)
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Lowest enhancement (vote)
Assignee: Default Assignee for New Packages
URL: http://sourceforge.net/projects/kionjb/
Whiteboard:
Keywords: EBUILD, REVIEWED
Depends on:
Blocks:
 
Reported: 2004-07-19 10:23 UTC by Joe Kappus
Modified: 2007-06-18 21:08 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
kionjb-0.2.3a.ebuild (kionjb-0.2.3a.ebuild,411 bytes, text/plain)
2005-05-07 10:38 UTC, Jeff Davidson
Details
kionjb-0.2.4OOPS ignore (kionjb-0.2.4.ebuild,777 bytes, text/plain)
2005-09-03 08:24 UTC, Chris Gagnon
Details
kionjb-0.2.4.ebuild (kionjb-0.2.4.ebuild,654 bytes, patch)
2005-09-03 08:33 UTC, Chris Gagnon
Details | Diff
kionjb-0.2.4.ebuild (kionjb-0.2.4.ebuild,625 bytes, text/plain)
2005-09-15 19:37 UTC, Joe Kappus
Details
kionjb-0.2.4.ebuild (kionjb-0.2.4.ebuild,536 bytes, text/plain)
2005-09-15 21:54 UTC, Joe Kappus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joe Kappus 2004-07-19 10:24:08 UTC
this is very useful to have, since gnomad requirs gnome libs, and many would like to use their gnomad's on kde.  I would write an ebuild.. but i suck at doing it so i'm gonna ask if someone else can.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Jeremy Huddleston (RETIRED) gentoo-dev 2004-07-22 01:46:50 UTC
Check out http://www.gentoo.org/doc/en/gentoo-howto.xml for information on how to write ebuilds to submit to us.
Comment 2 Joe Kappus 2004-09-29 21:22:15 UTC
Writing the ebuild has not been the problem.  Its just that it won't compile without some stuff done to it. Like for instance the configure script doesn't detect qt, but there is an overrride, i don't know how to do all that, thats why i brought this request here without a written ebuild.
Comment 3 Jeff Davidson 2005-05-07 10:37:42 UTC
Configure script detected qt here, did a short test with some binary pkgs I found.  Problem is that I don't have KDE installed, and the build fails like this:

/usr/lib/gcc/i686-pc-linux-gnu/3.4.3-20050110/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lkio

Don't know what I'd have to do to fix this, but hopefully some KDE user will test the ebuild and touch it up if need be.

-Jeff
Comment 4 Jeff Davidson 2005-05-07 10:38:28 UTC
Created attachment 58286 [details]
kionjb-0.2.3a.ebuild
Comment 5 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-05-08 10:45:26 UTC
Maybe KDE herd wants to take care of this as it's more a kde thing than sound?
Comment 6 Chris Gagnon 2005-09-03 08:24:44 UTC
Created attachment 67561 [details]
kionjb-0.2.4OOPS ignore

ebuild for kionjb-0.2.4

I used a direct link to the file instead of the standard $(PV) but that can be
fixed easy enough

It compiles on my computer
Comment 7 Chris Gagnon 2005-09-03 08:33:52 UTC
Created attachment 67562 [details, diff]
kionjb-0.2.4.ebuild

I used a direct link to the source download instead of the standard $(PV)

It compiles on my computer.
Comment 9 Joe Kappus 2005-09-15 19:34:28 UTC
Dammit all, why did you have to return?  I was enjoying not doing anything with
this bug, but in any case, I'm still not happy it was closed so I fixed the damn
thing.  Next time just ask, even though I can't stand you and wish you to burn
alive, I still would have fixed it.

Comment 10 Joe Kappus 2005-09-15 19:37:40 UTC
Created attachment 68552 [details]
kionjb-0.2.4.ebuild

Better ebuild then the last.  Though probably not up to ciaranm's standards of
bitchfulness.  Someone obsolete the old one, since I can't (which is asinine
since I filed the bug report in the first place)
Comment 11 Ciaran McCreesh 2005-09-15 19:51:48 UTC
Please fix the following and reopen:

* http://dev.gentoo.org/~ciaranm/docs/mw-faq/redundant.txt (src_compile)
* You don't have doc listed in IUSE, but you use it in src_install. But then,
the doc use flag isn't for small stuff like READMEs anyway, so just drop the
useq doc && part.
* http://dev.gentoo.org/~ciaranm/docs/mw-faq/hardcoded.txt
* You should use mirror://sourceforge/
Comment 12 Joe Kappus 2005-09-15 21:49:48 UTC
Good job catching me missing the whole SRC_URI line.. I had skipped over it
earlier. Also, the useq doc stuff I usually see ommited from IUSE whether its
right or not, so I threw it in for the hell of it.

But now you're just pissing me off.  If you're going to make requests from me,
then you should respect the requests that I have made to you.

1. DO NOT CLOSE THE BUG UNLESS YOU WANT TO HEAR ME RANT.  It means I have to
file two comments, one to reopen the bug, and the other to place an attachment.
 This is redundant and useless, I could have handled the request much more
efficiently if you had decided to just reply with a comment and not close the bug

2. I asked you to obsolete the earlier patch, I can't obsolete it because not
even the reporter can obsolete an attachment if it was sent by another person. 
But I do know a gentoo dev can.
Comment 13 Joe Kappus 2005-09-15 21:54:04 UTC
Created attachment 68555 [details]
kionjb-0.2.4.ebuild

This should be up to par, unless ciaranm missed something on the last one.
Don't even think of closing it again for such a small reason.
Comment 14 Jakub Moc (RETIRED) gentoo-dev 2005-09-16 03:04:51 UTC
(In reply to comment #12)
> 1. DO NOT CLOSE THE BUG UNLESS YOU WANT TO HEAR ME RANT.  It means I have to
> file two comments, one to reopen the bug, and the other to place an attachment.
>  This is redundant and useless, I could have handled the request much more
> efficiently if you had decided to just reply with a comment and not close the bug

http://dev.gentoo.org/~ciaranm/docs/mw-faq/wontfix.txt

And no, this is not redundant. It makes it possible for us to track the bug. 

> 2. I asked you to obsolete the earlier patch, I can't obsolete it because not
> even the reporter can obsolete an attachment if it was sent by another person. 
> But I do know a gentoo dev can.

Done.

Ranting does not help, please don't do this. Thanks for fixing the ebuild.
Comment 15 Ciaran McCreesh 2005-09-16 11:50:24 UTC
Much as I'd like to reclose this and demand that you remove the blank line in
src_install, I'm not really that petty. AFAICS this one's fine for REVIEWED now,
thanks.
Comment 16 David Grant 2007-03-16 22:15:47 UTC
I could add this to sunrise. But can someone with a Nomad confirm that this thing actually compiles, installs, and works?
Comment 17 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2007-04-02 18:14:59 UTC
(In reply to comment #16)
> I could add this to sunrise. But can someone with a Nomad confirm that this
> thing actually compiles, installs, and works?
> 

David,

before you take this to sunrise, you might want to check the open bugs on this package:

http://sourceforge.net/tracker/?group_id=33401&atid=408242
Comment 18 Wulf Krueger (RETIRED) gentoo-dev 2007-06-18 21:08:33 UTC
The ebuild still has quite a few problems (e. g. it's missing a dep on id3lib which shows the author never tested it), the project itself is dead (no release for two years, no CVS activity either), it would need quite a few patches to even compile - no, we don't need this.