Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 574874 - net-p2p/tribler: version bump and readd
Summary: net-p2p/tribler: version bump and readd
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Default Assignee for New Packages
URL:
Whiteboard: Pending removal: 2018-04-13
Keywords: PMASKED
: 631576 (view as bug list)
Depends on: 640888
Blocks: 587112 611638 613892
  Show dependency tree
 
Reported: 2016-02-16 10:39 UTC by Perfect Gentleman
Modified: 2018-10-08 12:23 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
New ebuild for tribler v6.5.2 (tribler-6.5.2.ebuild,1.88 KB, text/plain)
2016-10-11 09:39 UTC, Toffanin
Details
Patch to fix desktop menu (tribler-fix-desktop.patch,404 bytes, patch)
2016-10-11 09:40 UTC, Toffanin
Details | Diff
Patch to adhere to the XDG standard (tribler-xdg.patch,448 bytes, patch)
2016-10-11 09:41 UTC, Toffanin
Details | Diff
New tribler-6.5.2.ebuild (tribler-6.5.2.ebuild,1.89 KB, text/plain)
2017-06-12 23:47 UTC, Jess Haas
Details
Fixed tribler-6.5.2.ebuild (tribler-6.5.2.ebuild,1.91 KB, text/plain)
2017-06-13 04:53 UTC, Jess Haas
Details
tribler-7.0.2.ebuild (tribler-7.0.2.ebuild,2.13 KB, text/plain)
2018-04-10 19:22 UTC, Jess Haas
Details
tribler-fix-desktop.patch (tribler-fix-desktop.patch,322 bytes, patch)
2018-04-10 19:23 UTC, Jess Haas
Details | Diff
tribler-xdg.patch (tribler-xdg.patch,430 bytes, patch)
2018-04-10 19:23 UTC, Jess Haas
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Perfect Gentleman 2016-02-16 10:39:44 UTC
https://github.com/Tribler/tribler/releases/tag/v6.5.0
Comment 1 Anthony Basile gentoo-dev 2016-02-17 11:50:55 UTC
I'm probably going to just drop this package.  The code base is very hard to work with.  If you want to suggest an ebuild okay, but I'm not going to spend any time on this.
Comment 2 Jonas Stein gentoo-dev 2016-06-27 18:11:08 UTC
just for the record:
https://github.com/Tribler/tribler/releases/tag/v6.5.2

Upstream could clean the source package on github from unnecessary files...
Comment 3 Anthony Basile gentoo-dev 2016-06-27 20:36:41 UTC
(In reply to Jonas Stein from comment #2)
> just for the record:
> https://github.com/Tribler/tribler/releases/tag/v6.5.2
> 
> Upstream could clean the source package on github from unnecessary files...

I'm not sure what you mean.  I've wasted a lot of time on this poorly coded packages and really don't want to waste more.  If you want to suggest a working ebuild I'll consider it.
Comment 4 Toffanin 2016-10-11 09:39:27 UTC
Created attachment 449832 [details]
New ebuild for tribler v6.5.2
Comment 5 Toffanin 2016-10-11 09:40:18 UTC
Created attachment 449834 [details, diff]
Patch to fix desktop menu
Comment 6 Toffanin 2016-10-11 09:41:36 UTC
Created attachment 449838 [details, diff]
Patch to adhere to the XDG standard
Comment 7 Toffanin 2016-10-11 09:49:43 UTC
The old ebuilds actually present in the Portage's tree don't work any more because Tribler requires python2 dependencies that the ebuilds do not honour; fixing those old ebuilds is just a waste of time (IMHO), so I suggest to remove them (or hard mask them) and keep my new ebuild only.

So far I tested Tribler v6.5.2 for a few weeks, and used only a few of its features, and it seems to work correctly. However, more testing is required for the advanced features.
Comment 8 Pacho Ramos gentoo-dev 2016-11-15 16:17:48 UTC
this is also needed to stop relying on obsolete python eclasses
Comment 9 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2017-03-26 13:03:55 UTC
@blueness, I presume you wouldn't mind a proxied maintainer taking this over?

@Toffanin, would you be interested in maintaining this package via the proxy-maint project? If yes, would you consider submitting a pull request with your ebuild and adding yourself + proxy-maint project at [1]?

[1]:https://github.com/gentoo/gentoo/pulls
Comment 10 Anthony Basile gentoo-dev 2017-03-26 16:48:59 UTC
(In reply to Michał Górny from comment #9)
> @blueness, I presume you wouldn't mind a proxied maintainer taking this over?
> 
> @Toffanin, would you be interested in maintaining this package via the
> proxy-maint project? If yes, would you consider submitting a pull request
> with your ebuild and adding yourself + proxy-maint project at [1]?
> 
> [1]:https://github.com/gentoo/gentoo/pulls

not at all, i've resisted updating it because it had lots of problems and was hoping that usptream would clean up their act.

@toffanin, please submit a pull request and i'll take care of it from there.  please also note bug #613892
Comment 11 Jess Haas 2017-06-12 23:47:25 UTC
Created attachment 476216 [details]
New tribler-6.5.2.ebuild

net-libs/rb_libtorrent moved to libtorrent-rasterbar
Updated ebuild attached
Comment 12 Jess Haas 2017-06-13 04:53:12 UTC
Created attachment 476230 [details]
Fixed tribler-6.5.2.ebuild

dev-libs/libsodium dependency was missing as well so I added it. It is working for me now.
Comment 13 Anthony Basile gentoo-dev 2017-06-13 12:18:40 UTC
(In reply to Jess Haas from comment #12)
> Created attachment 476230 [details]
> Fixed tribler-6.5.2.ebuild
> 
> dev-libs/libsodium dependency was missing as well so I added it. It is
> working for me now.

you need to give me the patches
Comment 14 Anthony Basile gentoo-dev 2017-06-15 11:43:22 UTC
(In reply to Anthony Basile from comment #13)
> (In reply to Jess Haas from comment #12)
> > Created attachment 476230 [details]
> > Fixed tribler-6.5.2.ebuild
> > 
> > dev-libs/libsodium dependency was missing as well so I added it. It is
> > working for me now.
> 
> you need to give me the patches

ping.  i need your patches to put this on the tree.
Comment 15 Pacho Ramos gentoo-dev 2018-02-15 10:35:48 UTC
*** Bug 631576 has been marked as a duplicate of this bug. ***
Comment 16 Jess Haas 2018-04-10 19:22:09 UTC
Created attachment 527116 [details]
tribler-7.0.2.ebuild

Version is up to 7.0.2 Here is an updated ebuild for it. This requires dev-python/meliae-0.4.0 I just submitted a new ebuild for that in Bug 408217.
Comment 17 Jess Haas 2018-04-10 19:23:05 UTC
Created attachment 527118 [details, diff]
tribler-fix-desktop.patch

New patch updated for 7.0.2
Comment 18 Jess Haas 2018-04-10 19:23:31 UTC
Created attachment 527120 [details, diff]
tribler-xdg.patch

New patch updated for 7.0.2
Comment 19 Pacho Ramos gentoo-dev 2018-04-29 18:10:15 UTC
removed
Comment 20 Jess Haas 2018-04-29 18:20:17 UTC
Why is this being removed? I provided a working ebuild for the current version....
Comment 21 Pacho Ramos gentoo-dev 2018-04-29 18:44:12 UTC
Sorry for the communication issue... I had lots of bugs at the same time and...

The removal is because it needs some more work... The main blocker is that for adding the new package that it needs as a dependency we need that package to have a maintainer. Anyway, if you send all to proxy maintainers, you could proxy maintain both packages
https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers

But for this ebuild:
1. It should use eapi6 if possible
2. I am not sure about if it solves bug 640888
3. fdo-mime eclass is deprecated in favor of xdg.eclass
4. Inherit the full eutils.eclass only to call menu entries functions is a bit overkill: you have desktop.eclass for that. They are exactly providing the same functions and, in the future, all will need to inherit desktop.eclass directly for that

What I recommend you to get this solved faster:
- I would open a github pull request adding the new package that is needed by this and the updated ebuild and metadata with you as new maintainer.
- You can also add a link to the PR to "See also:" field here in the bug

I guess they (proxy-maint maintainers) will reply to you soon, please remember to provide one commit per file: one for the new package, other for adding the new version of tribler...

Thanks
Comment 22 Jess Haas 2018-04-29 18:56:49 UTC
Not sure if I will have time to deal with it myself for the next couple months as work is going to keep me mosyly away from the computer. If anyone else wants to step up feel free. If not I will try to find the time at some point.
Comment 23 Virgil Dupras gentoo-dev 2018-10-08 12:23:38 UTC
Removed from the tree in April.