Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 574612 - app-crypt/gnupg-2.1.11-r1 : * ERROR: app-crypt/gnupg-2.1.11-r1::gentoo failed (test phase):
Summary: app-crypt/gnupg-2.1.11-r1 : * ERROR: app-crypt/gnupg-2.1.11-r1::gentoo faile...
Status: RESOLVED DUPLICATE of bug 573398
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Crypto team [DISABLED]
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-13 09:20 UTC by Toralf Förster
Modified: 2016-02-13 16:25 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
app-crypt:gnupg-2.1.11-r1:20160212-225144.log (app-crypt:gnupg-2.1.11-r1:20160212-225144.log,177.12 KB, text/plain)
2016-02-13 09:20 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,666.04 KB, text/plain)
2016-02-13 09:20 UTC, Toralf Förster
Details
environment (environment,95.22 KB, text/plain)
2016-02-13 09:20 UTC, Toralf Förster
Details
tar -cvjpf tests.tbz2 tests/ (tests.tbz2,910.89 KB, application/x-bzip-compressed-tar)
2016-02-13 16:25 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2016-02-13 09:20:26 UTC
make: *** [check-recursive] Error 1
 * ERROR: app-crypt/gnupg-2.1.11-r1::gentoo failed (test phase):
 *   Make check failed. See above for details.
 * 
 * Call stack:
 *            ebuild.sh, line  133:  Called src_test


$ cat ./info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-kde-unstable_20160121-220131) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------

  make.conf: USE="mmx sse sse2 pax_kernel -cdinstall -oci8 bindist aes-ni apache apache2 bzip2 -cdda -compat corefonts ecc extraengine fontconfig gif -gnomecanvas gnutls gtk -help hpn ipv6 isag jadetex llvm mod modplug mysqli nscd nss policykit postscript pwquality qt3support rendering source sqlite swscale szip -tcl ufed v4l video vpx wma wxwidgets x264 xa xinetd xvfb icu qt5 pcre16"

  -----------------------------------------------------------------
  Portage 2.2.27 (python 2.7.11-final-0, default/linux/amd64/13.0/desktop/kde, gcc-5.3.0, glibc-2.22-r1, 4.3.5-hardened-r2 x86_64)
=================================================================
System uname: Linux-4.3.5-hardened-r2-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16164680 total,   3343120 free
KiB Swap:   16777212 total,  16704996 free
Timestamp of repository gentoo: Fri, 12 Feb 2016 22:02:39 +0000
sh bash 4.3_p42-r2
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p42-r2::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.22.1::gentoo
dev-lang/python:          2.7.11-r2::gentoo, 3.3.5-r7::gentoo, 3.4.3-r7::gentoo, 3.5.1-r2::gentoo
dev-util/cmake:           3.4.3::gentoo
dev-util/pkgconfig:       0.29::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.20.4::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r1::gentoo
sys-devel/automake:       1.9.6-r4::gentoo, 1.10.3-r2::gentoo, 1.11.6-r2::gentoo, 1.12.6-r1::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r1::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.2.4-r1::gentoo, 4.9.3::gentoo, 5.3.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r1::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.de.gentoo.org/gentoo-portage/
    priority: 1

local
    location: /usr/local/portage
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/entropy /etc/stunnel/stunnel.conf /opt/openfire/resources/security/ /usr/lib64/fax /usr/lib64/tomoyo/conf /usr/share/config /usr/share/easy-rsa /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.3/conf /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb /var/lib/i2pd/certificates /var/spool/fax/etc /var/yp/Makefile"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose-conflicts --deep --color=n --nospinner --tree --quiet-build --accept-properties=-interactive --accept-restrict=-fetch"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi aes-ni alsa amd64 apache apache2 berkdb bindist bluetooth branding bzip2 cairo cdr cli consolekit corefonts cracklib crypt cups cxx dbus declarative dri dts dvd dvdr ecc emboss encode exif extraengine fam firefox flac fontconfig fortran gdbm gif glamor gnutls gpm gtk hpn iconv icu ipv6 isag jadetex jpeg kde kipi lcms ldap libnotify llvm mad mmx mmxext mng mod modplug modules mp3 mp4 mpeg multilib mysqli ncurses nls nptl nscd nss ogg opengl openmp pam pango pax_kernel pcre pcre16 pdf phonon plasma png policykit postscript ppds pwquality qt3support qt4 qt5 readline rendering sdl seccomp semantic-desktop session source spell sqlite sse sse2 ssl startup-notification svg swscale szip tcpd tiff truetype udev udisks ufed unicode upower usb v4l video vorbis vpx wma wxwidgets x264 xa xattr xcb xcomposite xinerama xinetd xml xscreensaver xv xvfb xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_GB" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2016-02-13 09:20:28 UTC
Created attachment 425368 [details]
app-crypt:gnupg-2.1.11-r1:20160212-225144.log
Comment 2 Toralf Förster gentoo-dev 2016-02-13 09:20:31 UTC
Created attachment 425370 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2016-02-13 09:20:34 UTC
Created attachment 425372 [details]
environment
Comment 4 Kristian Fiskerstrand gentoo-dev Security 2016-02-13 09:45:46 UTC

*** This bug has been marked as a duplicate of bug 573398 ***
Comment 5 Kristian Fiskerstrand gentoo-dev Security 2016-02-13 09:52:09 UTC
Could you please upload the test log for failing gpgtar?
Comment 6 Toralf Förster gentoo-dev 2016-02-13 15:07:59 UTC
(In reply to Kristian Fiskerstrand from comment #5)
now it works fine at the same chroot image :-(
Comment 7 Kristian Fiskerstrand gentoo-dev Security 2016-02-13 15:17:15 UTC
(In reply to Toralf Förster from comment #6)
> (In reply to Kristian Fiskerstrand from comment #5)
> now it works fine at the same chroot image :-(

That is consistent with debian's observations c.f http://lists.gnupg.org/pipermail/gnupg-devel/2016-January/030744.html
Comment 8 Toralf Förster gentoo-dev 2016-02-13 16:16:07 UTC
ms-magpie / # cat /var/tmp/portage/app-crypt/gnupg-2.1.11-r1/work/gnupg-2.1.11/tests/openpgp/gpgtar.test.log  
Test: gpgtar.test
GNUPGHOME=/var/tmp/portage/app-crypt/gnupg-2.1.11-r1/work/gnupg-2.1.11/tests/openpgp
gpgtar: gpg2: gpg: encrypted with 1024-bit ELG key, ID B27907AA, created 2003-12-31
gpgtar: gpg2:       "Test two (no pp) <two@example.com>"
gpgtar: gpg2: gpg: encrypted with 1024-bit ELG key, ID B27907AA, created 2003-12-31
gpgtar: gpg2:       "Test two (no pp) <two@example.com>"
gpgtar: gpg2: gpg: encrypted with 1024-bit ELG key, ID B27907AA, created 2003-12-31
gpgtar: gpg2:       "Test two (no pp) <two@example.com>"
gpgtar: gpg2: gpg: Signature made Sat Feb 13 17:14:29 2016 CET using RSA key ID ECABF51D
gpgtar: gpg2: gpg: Good signature from "Test three (no pp) <three@example.com>" [unknown]
gpgtar: gpg2: gpg: WARNING: Using untrusted key!
gpgtar: gpg2: gpg: encrypted with 1024-bit ELG key, ID B27907AA, created 2003-12-31
gpgtar: gpg2:       "Test two (no pp) <two@example.com>"
gpgtar: gpg2: gpg: Signature made Sat Feb 13 17:14:29 2016 CET using RSA key ID ECABF51D
gpgtar: gpg2: gpg: Good signature from "Test three (no pp) <three@example.com>" [unknown]
gpgtar: gpg2: gpg: WARNING: Using untrusted key!
gpgtar: gpg2: gpg: Signature made Sat Feb 13 17:14:29 2016 CET using RSA key ID ECABF51D
gpgtar: gpg2: gpg: Good signature from "Test three (no pp) <three@example.com>" [unknown]
gpgtar: gpg2: gpg: WARNING: Using untrusted key!
gpgtar: gpg2: gpg: Signature made Sat Feb 13 17:14:29 2016 CET using RSA key ID ECABF51D
gpgtar: gpg2: gpg: Good signature from "Test three (no pp) <three@example.com>" [unknown]
gpgtar: gpg2: gpg: WARNING: Using untrusted key!
gpgtar: gpg2: gpg: AES encrypted data
gpgtar: gpg2: gpg: encrypted with 1 passphrase
gpgtar: gpg2: gpg: AES encrypted data
gpgtar: gpg2: gpg: encrypted with 1 passphrase
gpg: WARNING: unsafe permissions on homedir '/var/tmp/portage/app-crypt/gnupg-2.1.11-r1/work/gnupg-2.1.11/tests/openpgp'
gpgtar: gpg2: gpg: IDEA encrypted data
gpgtar: gpg2: gpg: encrypted with 1 passphrase
gpgtar: gpg2: gpg: WARNING: message was not integrity protected
gpgtar: gpg2: gpg: IDEA encrypted data
gpgtar: gpg2: gpg: encrypted with 1 passphrase
gpgtar: gpg2: gpg: WARNING: message was not integrity protected
gpgtar: gpg2: gpg: encrypted with 1 passphrase
gpgtar: gpg2: gpg: encrypted with 1024-bit ELG key, ID B27907AA, created 2003-12-31
gpgtar: gpg2:       "Test two (no pp) <two@example.com>"
gpgtar: gpg2: gpg: Signature made Sat Feb 13 17:14:31 2016 CET using RSA key ID ECABF51D
gpgtar: gpg2: gpg: Good signature from "Test three (no pp) <three@example.com>" [unknown]
gpgtar: gpg2: gpg: WARNING: Using untrusted key!
gpgtar: error reading '[?]': premature EOF (size of last record: 0)
Comment 9 Toralf Förster gentoo-dev 2016-02-13 16:25:33 UTC
Created attachment 425414 [details]
tar -cvjpf tests.tbz2  tests/

enjoy ;)