Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 574268 (CVE-2015-7511) - <dev-libs/libgcrypt-{1.5.4-r2,1.5.4-r101,1.6.5}: Side channel attack
Summary: <dev-libs/libgcrypt-{1.5.4-r2,1.5.4-r101,1.6.5}: Side channel attack
Status: RESOLVED FIXED
Alias: CVE-2015-7511
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Security
URL: http://www.cs.tau.ac.IL/~tromer/ecdh/
Whiteboard: A4 [glsa]
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-09 15:42 UTC by Kristian Fiskerstrand
Modified: 2016-10-10 11:06 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kristian Fiskerstrand gentoo-dev Security 2016-02-09 15:42:11 UTC
The GNU project is pleased to announce the availability of Libgcrypt
version 1.6.5.  This is a security fix release to mitigate a new side
channel attack.

Libgcrypt is a general purpose library of cryptographic building blocks.
It does not provide any implementation of OpenPGP or other protocols.
Thorough understanding of applied cryptography is required for proper
use Libgcrypt.


Noteworthy changes in version 1.6.5
===================================

 * Mitigate side-channel attack on ECDH with Weierstrass curves
   [CVE-2015-7511].  See http://www.cs.tau.ac.IL/~tromer/ecdh/ for
   details.

 * Fix build problem on Solaris.
Comment 1 Kristian Fiskerstrand gentoo-dev Security 2016-02-09 15:42:44 UTC
ebuild in process
Comment 2 Kristian Fiskerstrand gentoo-dev Security 2016-02-09 18:23:53 UTC
Arches, please stabilize:
=dev-libs/libgcrypt-1.6.5
Stable targets: alpha amd64 arm hppa ia64 ppc ppc64 sparc x86
Comment 3 Kristian Fiskerstrand gentoo-dev Security 2016-02-10 22:58:52 UTC
Backported fix to 1.5 branch added, 

arches, please also stabilize:
=dev-libs/libgcrypt-1.5.4-r2
Stable targets: alpha amd64 arm hppa ia64 ppc ppc64 sparc x86
Comment 4 Agostino Sarubbo gentoo-dev 2016-02-11 12:27:54 UTC
amd64 stable
Comment 5 Jeroen Roovers gentoo-dev 2016-02-12 07:24:35 UTC
Stable for HPPA PPC64.
Comment 6 Agostino Sarubbo gentoo-dev 2016-03-15 17:01:02 UTC
x86 stable
Comment 7 Tobias Klausmann gentoo-dev 2016-03-16 09:20:41 UTC
Stable on alpha.
Comment 8 Agostino Sarubbo gentoo-dev 2016-03-16 14:10:29 UTC
ppc stable
Comment 9 Agostino Sarubbo gentoo-dev 2016-03-19 12:30:02 UTC
sparc stable
Comment 10 Agostino Sarubbo gentoo-dev 2016-03-20 12:26:08 UTC
ia64 stable
Comment 11 SpanKY gentoo-dev 2016-06-08 18:45:34 UTC
seems like 1.6.5 didn't actually have sparc/x86 marked stable, so i did that now, and all the remaining arches
Comment 12 GLSAMaker/CVETool Bot gentoo-dev 2016-10-10 11:06:19 UTC
This issue was resolved and addressed in
 GLSA 201610-04 at https://security.gentoo.org/glsa/201610-04
by GLSA coordinator Kristian Fiskerstrand (K_F).