Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 574088 - media-video/ffmpeg-2.8.6 fails to build under distcc
Summary: media-video/ffmpeg-2.8.6 fails to build under distcc
Status: RESOLVED DUPLICATE of bug 581732
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-07 12:26 UTC by WGH
Modified: 2019-08-22 13:51 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info '=media-video/ffmpeg-2.8.6::gentoo' (emerge_info.log,7.87 KB, text/plain)
2016-02-07 12:26 UTC, WGH
Details
/var/tmp/portage/media-video/ffmpeg-2.8.6/temp/build.log (build.log,121.10 KB, text/plain)
2016-02-07 12:28 UTC, WGH
Details

Note You need to log in before you can comment on or make changes to this bug.
Description WGH 2016-02-07 12:26:04 UTC
Created attachment 424832 [details]
emerge --info '=media-video/ffmpeg-2.8.6::gentoo'

* ERROR: media-video/ffmpeg-2.8.6::gentoo failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=media-video/ffmpeg-2.8.6::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-video/ffmpeg-2.8.6::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-video/ffmpeg-2.8.6/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-video/ffmpeg-2.8.6/temp/environment'.
 * Working directory: '/var/tmp/portage/media-video/ffmpeg-2.8.6/work/ffmpeg-2.8.6-abi_x86_32.x86'
 * S: '/var/tmp/portage/media-video/ffmpeg-2.8.6/work/ffmpeg-2.8.6'
__________Warning: 4 pump-mode compilation(s) failed on server, but succeeded locally.
__________Distcc-pump was demoted to plain mode.  See the Distcc Discrepancy Symptoms section in the include_server(1) man page.

More details will be attached.
Comment 1 WGH 2016-02-07 12:28:39 UTC
Created attachment 424834 [details]
/var/tmp/portage/media-video/ffmpeg-2.8.6/temp/build.log
Comment 2 WGH 2016-02-07 12:29:23 UTC
[ebuild     U ] media-video/ffmpeg-2.8.6 [2.8.5] USE="X aac amr bzip2 encode faac gpl gsm hardcoded-tables iconv jpeg2k libass libcaca libv4l mp3 network openal openssl postproc pulseaudio sdl speex theora threads truetype v4l vaapi vorbis vpx x264 zlib -aacplus -alsa (-altivec) -amrenc (-armv5te) (-armv6) (-armv6t2) (-armvfp) -bluray -bs2b -cdio -celt -cpudetection -debug -doc -examples -fdk -flite -fontconfig -frei0r -fribidi -gme -gnutls -iec61883 -ieee1394 -jack -ladspa -libressl -librtmp -libsoxr -lzma (-mipsdspr1) (-mipsdspr2) (-mipsfpu) -modplug (-neon) -opengl -opus -oss -pic -quvi -samba -schroedinger -snappy -ssh -static-libs {-test} -twolame -vdpau -wavpack -webp -x265 -xcb -xvid -zvbi" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="avx avx2 fma3 mmx mmxext sse sse2 sse3 sse4_1 sse4_2 ssse3 -3dnow -3dnowext -fma4 -xop" FFTOOLS="aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart sidxindex trasher"
Comment 3 Alexis Ballier gentoo-dev 2016-02-09 12:45:51 UTC
does 2.8.5 fail the same way ?
what if you remove '-fstack-protector' from your cflags ?
does gcc 5.3 fail too ?


btw, proper error is not distcc, it's:
In file included from /var/tmp/portage/media-video/ffmpeg-2.8.6/work/ffmpeg-2.8.6/libpostproc/postprocess.c:549:0:
/var/tmp/portage/media-video/ffmpeg-2.8.6/work/ffmpeg-2.8.6/libpostproc/postprocess_template.c: In function ‘dering_SSE2’:
/var/tmp/portage/media-video/ffmpeg-2.8.6/work/ffmpeg-2.8.6/libpostproc/postprocess_template.c:1097:5: error: ‘asm’ operand has impossible constraints
     __asm__ volatile(
     ^
Comment 4 WGH 2016-02-09 13:49:06 UTC
It does build without distcc.

Most likely it's caused by distcc-pump (see bug 574102 where I encountered the same issue with pypy). 
I'll test building ffmpeg with distcc and without distcc-pump tonight.
Comment 5 Alexis Ballier gentoo-dev 2019-08-22 13:51:20 UTC

*** This bug has been marked as a duplicate of bug 581732 ***