Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 572726 - python-3.5.1 fails to install due to errors compiling PythonLauncher
Summary: python-3.5.1 fails to install due to errors compiling PythonLauncher
Status: RESOLVED FIXED
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Prefix Support (show other bugs)
Hardware: All Other
: Normal blocker (vote)
Assignee: Gentoo Prefix
URL: https://forums.developer.apple.com/th...
Whiteboard:
Keywords:
: 573640 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-01-23 21:38 UTC by *
Modified: 2020-07-29 06:07 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.bz2 (build.log.bz2,63.21 KB, application/x-bzip2)
2016-01-23 21:40 UTC, *
Details

Note You need to log in before you can comment on or make changes to this bug.
Description * 2016-01-23 21:38:39 UTC
My system is OS X El Capitan (10.11.3).
I'm using the latest bootstrap-prefix.sh (as I write, less than 24 hrs old).
It fails in stage3 while installing python-3.5.1.

fatal error: too many errors emitted, stopping now [-ferror-limit=]
20 errors generated.
Makefile:55: recipe for target 'FileSettings.o' failed
make[1]: *** [FileSettings.o] Error 1
make[1]: Leaving directory '/opt/gentoo/tmp/var/tmp/portage/dev-lang/python-3.5.1/work/x86_64-apple-darwin15/Mac/PythonLauncher'
Makefile:165: recipe for target 'install_PythonLauncher' failed
make: *** [install_PythonLauncher] Error 2
make: Leaving directory '/opt/gentoo/tmp/var/tmp/portage/dev-lang/python-3.5.1/work/x86_64-apple-darwin15/Mac'
 * ERROR: dev-lang/python-3.5.1::gentoo_prefix failed (install phase):
 *   emake failed
 *


Reproducible: Always

Steps to Reproduce:
./bootstrap-prefix.sh
Actual Results:  
The bootstrap fails due to the above, during stage3.

Expected Results:  
A successful bootstrap.

Portage 2.2.20-prefix (python 2.7.3-final-0, prefix/darwin/macos/10.11/x64, clang-3.4.2, unavailable, 15.3.0 x86_64)
=================================================================
System uname: Darwin-15.3.0-x86_64-i386-64bit
Timestamp of repository gentoo_prefix: Fri, 22 Jan 2016 21:12:20 +0000
sh bash 4.3_p39
app-shells/bash: 4.3_p39::gentoo_prefix
Repositories:

gentoo_prefix
    location: /opt/gentoo/tmp/usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.prefix.bitzolder.nl/gentoo-portage-prefix
    priority: -1000
    aliases: gentoo

ACCEPT_KEYWORDS="~x64-macos"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-apple-darwin15"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-apple-darwin15"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/gentoo-release /etc/terminfo"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/opt/gentoo/tmp/usr/portage/distfiles"
FCFLAGS=""
FEATURES="assume-digests binpkg-logs case-insensitive-fs collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles force-prefix merge-sync news nostrip parallel-fetch preserve-libs protect-owned sfperms strict unknown-features-warn unmerge-logs unmerge-orphans unprivileged userfetch userpriv usersandbox usersync"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-dead_strip_dylibs"
MAKEOPTS="-j5"
PKGDIR="/opt/gentoo/tmp/usr/portage/packages"
PORTAGE_CONFIGROOT="/opt/gentoo/tmp/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/opt/gentoo/tmp/var/tmp"
USE="aqua coreaudio cracklib cxx ipv6 mmx mmxext modules ncurses nls objc objc++ prefix prefix-guest readline sse sse2 ssl unicode x64-macos xattr zlib" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="Darwin" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse" KERNEL="Darwin" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4 python3_5" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 * 2016-01-23 21:40:57 UTC
Created attachment 423730 [details]
build.log.bz2
Comment 2 Fabian Groffen gentoo-dev 2016-01-24 10:03:46 UTC
currently bootstrapping on 10.11 to try and debug
Comment 3 Fabian Groffen gentoo-dev 2016-01-24 10:38:48 UTC
real error:

python$EXE ../../Tools/scripts/h2py.py -i '(u_long)' /usr/include/netinet/in.h
dyld: Library not loaded: /Volumes/Scratch/Gentoo/bootstrap64-20160124/usr/lib/l
ibpython3.5.dylib
  Referenced from: /Volumes/Scratch/Gentoo/bootstrap64-20160124/tmp/var/tmp/port
age/dev-lang/python-3.5.1/work/x86_64-apple-darwin15/python
  Reason: image not found
./regen: line 3: 90589 Trace/BPT trap: 5       python$EXE ../../Tools/scripts/h2
py.py -i '(u_long)' /usr/include/netinet/in.h
Makefile:620: recipe for target 'platformspecificmods' failed
make: *** [platformspecificmods] Error 1
Comment 4 Fabian Groffen gentoo-dev 2016-01-24 10:48:13 UTC
this sulks
Comment 5 Fabian Groffen gentoo-dev 2016-01-24 13:40:52 UTC
this is fixed and tested on both 10.10 and 10.11, tomorrow will release new snapshot.
Comment 6 * 2016-01-27 07:48:34 UTC
It's fixed! Thanks! It got through stage3 and almost through the emerge -e system.
Comment 7 Michael Haubenwallner gentoo-dev 2016-02-01 17:45:50 UTC
This fix breaks non-darwin, as it drops the $(RUNSHARED) from the ./regen call.
Does it hurt darwin to keep it there?
Comment 8 Fabian Groffen gentoo-dev 2016-02-01 18:52:00 UTC
Yes please try.  It shouldn't matter for as long as RUNSHARED is passed on.  I don't understand yet why this breaks on AIX, as it should just move the library path change to the final invocation (since security on OSX doesn't allow that to be passed onto shell scripts).
Comment 9 Fabian Groffen gentoo-dev 2016-02-02 09:39:49 UTC
*** Bug 573640 has been marked as a duplicate of this bug. ***
Comment 10 Michael Haubenwallner gentoo-dev 2016-02-02 09:42:09 UTC
It broke Linux actually.
It probably wouldn't break if RUNSHARED were moved into
Lib/plat-*/regen, not just
Lib/plat-darwin/regen.
Comment 11 Fabian Groffen gentoo-dev 2016-02-02 09:55:58 UTC
ah, right, yes ofcourse!
Comment 12 Guilherme Amadio gentoo-dev 2016-02-02 11:03:20 UTC
Note: on a boostrap on CentOS 7, I also needed to add

append-ldflags -lcrypt -lnss_nis

to make python 3.5.1, 3.4.3, and 2.7.11 compile.
Comment 13 Fabian Groffen gentoo-dev 2016-02-02 20:07:01 UTC
I reverted the change more or less, only changing regen on Darwin and adding an extra export.

Please confirm this works for you.
Comment 14 Daa Jaa 2016-02-03 13:52:12 UTC
Thanks, the workaround "append-ldflags -lcrypt -lnss_nis" is for the bug https://bugs.gentoo.org/show_bug.cgi?id=572600 !
Comment 15 Guilherme Amadio gentoo-dev 2020-07-28 22:06:32 UTC
Is this bug still relevant? Python 3.5 is not in the main tree anymore.