Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 57244 - New version of libiconv (1.9.1)
Summary: New version of libiconv (1.9.1)
Status: VERIFIED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Spider (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-07-15 17:28 UTC by Gatak
Modified: 2004-07-21 04:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gatak 2004-07-15 17:28:24 UTC
There is a new version of libiconv available at http://www.gnu.org/software/libiconv/



Reproducible: Always
Steps to Reproduce:





Would be nice to see a the new version of libiconv in portage.
Comment 1 Spider (RETIRED) gentoo-dev 2004-07-16 09:38:40 UTC
due to the past issues with this package it is hard masked.  And I'm not convinced there is a good reason for this to be in the tree at all.

So, if this would be good, why?  And can it be guaranteed -not- to break things again?

Comment 2 Gatak 2004-07-16 09:51:01 UTC
Oh I wouldn't know if this would break things. The reason I stumbled onto this package was that libiconv 1.8+ seemed to be needed by idnkit so I looked it up and found a newer version than the 1.7 which was in portage.

You might be right though that it isn't needed and should be banned.
Comment 3 Spider (RETIRED) gentoo-dev 2004-07-17 05:05:22 UTC
well, anything that overwrites glibc's header files is ... Bad.

Comment 4 Gatak 2004-07-17 07:06:38 UTC
Agreed. But then the idnkit package sould be removed or changed so it doesn't need libiconv, as the iconv.h is already installed by glibc?
Comment 5 Spider (RETIRED) gentoo-dev 2004-07-20 13:51:25 UTC
according to the build in my local tree it doesn't depend on libiconv.
Comment 6 Gatak 2004-07-20 13:58:45 UTC
Then I do not know. It did install it for me. Perhaps it was some setting I had or used. I re-emerged glibc and I could install idnkit after that so it seem to be all fine now.

Comment 7 Spider (RETIRED) gentoo-dev 2004-07-21 04:27:08 UTC
I am very curious here, because libiconv is in package.mask and has been so for years, and if somone removes it?   *shrug*

well, glad its resolved.