Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 571888 - >=dev-libs/libfilezilla-0.3.0 keyword request / >=net-ftp/filezilla-3.15.0 rekeyword request
Summary: >=dev-libs/libfilezilla-0.3.0 keyword request / >=net-ftp/filezilla-3.15.0 re...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Keywording (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Security
URL:
Whiteboard:
Keywords: KEYWORDREQ
Depends on: 609246
Blocks: 610554
  Show dependency tree
 
Reported: 2016-01-14 13:48 UTC by Bernard Cafarelli
Modified: 2017-09-16 22:03 UTC (History)
2 users (show)

See Also:
Package list:
=dev-libs/libfilezilla-0.9.1 =net-ftp/filezilla-3.25.2 =dev-libs/pugixml-1.8 ia64 sparc
Runtime testing required: ---
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Cafarelli gentoo-dev 2016-01-14 13:48:54 UTC
This is a new package split from net-ftp/filezilla, and will be a mandatory dependency for it after upcoming version 3.15.0

Target keywords are ideally the same as filezilla:
amd64 arm ia64 ppc sparc x86 amd64-linux ia64-linux x86-linux x86-macos

If you prefer to drop filezilla from your arch/prefix, comment here and I will remove it from KEYWORDS when bumping filezilla

Thanks!
Comment 1 Bernard Cafarelli gentoo-dev 2016-01-14 13:49:56 UTC
And correctly including arches this time
Comment 2 Fabian Groffen gentoo-dev 2016-01-16 12:23:20 UTC
On *-macos the build fails with missing iconv symbols.  It needs to depend on virtual/libiconv and somehow pass -liconv into ldflags on platforms that don't have iconv in libc.  Since I don't know if anyone actually uses this thing, I figure it's best to drop the x86-macos keyword.  I can't test the *-linux keywords, so same thing there, please just drop them.

Thanks!
Comment 3 Bernard Cafarelli gentoo-dev 2016-02-01 12:09:38 UTC
Thanks for the check, I dropped prefix support in filezilla-3.15.0

For the other arches, I dropped the keywords too, please readd them to net-ftp/filezilla-3.15.0 after you keyword the lib (if you want to keep these packages on your arch of course)
Comment 4 Markus Meier gentoo-dev 2016-02-26 17:14:04 UTC
~arm added
Comment 5 Thomas Deutschmann gentoo-dev Security 2017-02-22 14:19:04 UTC
Assigning to security to allow ATs proper prioritizing.
Comment 6 Stabilization helper bot gentoo-dev 2017-02-22 15:00:52 UTC
An automated check of this bug failed - repoman reported dependency errors (17 lines truncated): 

> dependency.bad net-ftp/filezilla/filezilla-3.24.1.ebuild: DEPEND: ~ia64(default/linux/ia64/13.0) ['>=dev-libs/pugixml-1.7']
> dependency.bad net-ftp/filezilla/filezilla-3.24.1.ebuild: RDEPEND: ~ia64(default/linux/ia64/13.0) ['>=dev-libs/pugixml-1.7']
> dependency.bad net-ftp/filezilla/filezilla-3.24.1.ebuild: DEPEND: ~ia64(default/linux/ia64/13.0/desktop) ['>=dev-libs/pugixml-1.7']
Comment 7 Stabilization helper bot gentoo-dev 2017-03-08 11:00:52 UTC
An automated check of this bug failed - repoman reported dependency errors (17 lines truncated): 

> dependency.bad net-ftp/filezilla/filezilla-3.24.1-r1.ebuild: DEPEND: ~ia64(default/linux/ia64/13.0) ['>=dev-libs/pugixml-1.7', '>=net-libs/gnutls-3.4.0']
> dependency.bad net-ftp/filezilla/filezilla-3.24.1-r1.ebuild: RDEPEND: ~ia64(default/linux/ia64/13.0) ['>=dev-libs/pugixml-1.7', '>=net-libs/gnutls-3.4.0']
> dependency.bad net-ftp/filezilla/filezilla-3.24.1-r1.ebuild: DEPEND: ~ia64(default/linux/ia64/13.0/desktop) ['>=dev-libs/pugixml-1.7', '>=net-libs/gnutls-3.4.0']
Comment 8 Thomas Deutschmann gentoo-dev Security 2017-03-08 15:10:02 UTC
ia64, you need to keyword >=gnutls-3.4 and >=pugixml-1.7.
Comment 9 Stabilization helper bot gentoo-dev 2017-03-08 16:00:53 UTC
An automated check of this bug failed - repoman reported dependency errors (7 lines truncated): 

> dependency.bad net-ftp/filezilla/filezilla-3.24.1-r1.ebuild: DEPEND: ~sparc(default/linux/sparc/13.0) ['>=dev-libs/pugixml-1.7']
> dependency.bad net-ftp/filezilla/filezilla-3.24.1-r1.ebuild: RDEPEND: ~sparc(default/linux/sparc/13.0) ['>=dev-libs/pugixml-1.7']
> dependency.bad net-ftp/filezilla/filezilla-3.24.1-r1.ebuild: DEPEND: ~sparc(default/linux/sparc/13.0/desktop) ['>=dev-libs/pugixml-1.7']
Comment 10 Bernard Cafarelli gentoo-dev 2017-03-14 14:00:50 UTC
(In reply to Thomas Deutschmann from comment #8)
> ia64, you need to keyword >=gnutls-3.4 and >=pugixml-1.7.

Same for sparc
Comment 11 Bernard Cafarelli gentoo-dev 2017-06-04 11:18:13 UTC
Note: the last old (and stable) version that had all keywords was removed for security bug #610554
Comment 12 Stabilization helper bot gentoo-dev 2017-06-30 08:00:31 UTC
An automated check of this bug failed - the following atom is unknown:

net-ftp/filezilla-3.24.1-r1

Please verify the atom list.
Comment 13 Sergei Trofimovich gentoo-dev 2017-07-02 14:51:13 UTC
~ia64 keyworded
Comment 15 Sergei Trofimovich gentoo-dev 2017-09-16 22:03:50 UTC
~ppc keyworded

Past arch. Closing.