Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 571532 - dev-libs/efl[egl,opengl] - configure: error: Full OpenGL with EGL is not supported, please add --with-opengl=es to your configure options to switch to EGL + OpenGL ES.
Summary: dev-libs/efl[egl,opengl] - configure: error: Full OpenGL with EGL is not supp...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Joonas Niilola
URL: https://phab.enlightenment.org/T2936#...
Whiteboard:
Keywords:
: 575920 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-01-11 09:18 UTC by Dennis Schridde
Modified: 2018-07-07 14:48 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,18.36 KB, text/plain)
2016-02-27 19:01 UTC, Dennis Schridde
Details
emerge-info.txt (emerge-info.txt,6.59 KB, text/plain)
2016-05-24 12:24 UTC, Toralf Förster
Details
config.log (config.log,181.06 KB, text/plain)
2016-05-24 12:24 UTC, Toralf Förster
Details
dev-libs:efl-1.17.0:20160524-103319.log (dev-libs:efl-1.17.0:20160524-103319.log,17.91 KB, text/plain)
2016-05-24 12:24 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,88.82 KB, text/plain)
2016-05-24 12:24 UTC, Toralf Förster
Details
environment (environment,99.82 KB, text/plain)
2016-05-24 12:24 UTC, Toralf Förster
Details
efl-1.18.4 with USE=opengl set configure failure build log (dev-libs:efl-1.18.4:20170316-043857.log,20.65 KB, text/x-log)
2017-03-16 04:52 UTC, Jocelyn Mayer
Details
efl-1.18.4 with USE=opengl set configure failure config.log (dev-libs:efl-1.18.4:20170316-043857.config.log,230.91 KB, text/x-log)
2017-03-16 04:54 UTC, Jocelyn Mayer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2016-01-11 09:18:22 UTC
Enabling USE=opengl and USE=egl for dev-libs/efl is unsupported by upstream. REQUIRED_USE should reflect that: https://phab.enlightenment.org/T2936#42158

Reproducible: Always
Comment 1 SpanKY gentoo-dev 2016-01-14 00:11:50 UTC
the problem is more that "opengl" is synonymous with "glx" when it's really not -- opengl is the basic API while glx is purely the X11 integration

x11 team: should we try and split apart USE=opengl and USE=glx ?  or other ideas ?
Comment 2 Matt Turner gentoo-dev 2016-01-14 00:25:20 UTC
Sigh. Upstream gives the option of opengl+glx OR gles+egl but doesn't allow opengl+egl... no idea why.

opengl/glx are often conflated, but it doesn't seem like we can do much to separate them in this case.

I think we should probably just get rid of the egl USE flag and have USE=gles enable egl. That way USE=opengl gives desktop GL and GLX, and USE=gles gives ES and EGL.
Comment 3 SpanKY gentoo-dev 2016-01-14 01:06:34 UTC
i'm trying to make sure the UX isn't terrible on our side.  we don't have a USE=glx in general on our side, so do ebuilds tend to use opengl && X to enable glx ?

thus, since the E guys conflate opengl/glx, should we nest USE=opengl under USE=X and make the blocker something like:
    opengl? ( !X? ( !egl ) )
    egl? ( X? ( !opengl ) )
Comment 4 Matt Turner gentoo-dev 2016-01-14 02:00:47 UTC
I think the most common way to enable glx is $(use_enable opengl glx). There appear to be lots of instances of that in the tree.

Nesting opengl under X seems fine here, since it really can only work with glx. Again, I think we should remove the egl USE flag here -- gles requires it, and it's not useful without gles, so there are currently two USE flags (that both have to be set) for a single feature.
Comment 5 Dennis Schridde 2016-02-27 19:01:15 UTC
Created attachment 426788 [details]
build.log

This is a hard error (i.e. build failure) now:
configure: error: Full OpenGL with EGL is not supported, please add --with-opengl=es to your configure options to switch to EGL + OpenGL ES.
Comment 6 SpanKY gentoo-dev 2016-04-05 01:26:17 UTC
*** Bug 575920 has been marked as a duplicate of this bug. ***
Comment 7 Toralf Förster gentoo-dev 2016-05-24 12:24:35 UTC
Created attachment 435214 [details]
emerge-info.txt

confirmed
Comment 8 Toralf Förster gentoo-dev 2016-05-24 12:24:38 UTC
Created attachment 435216 [details]
config.log
Comment 9 Toralf Förster gentoo-dev 2016-05-24 12:24:40 UTC
Created attachment 435218 [details]
dev-libs:efl-1.17.0:20160524-103319.log
Comment 10 Toralf Förster gentoo-dev 2016-05-24 12:24:43 UTC
Created attachment 435220 [details]
emerge-history.txt
Comment 11 Toralf Förster gentoo-dev 2016-05-24 12:24:46 UTC
Created attachment 435222 [details]
environment
Comment 12 Jeroen Roovers (RETIRED) gentoo-dev 2016-07-15 05:52:46 UTC
.
Comment 13 Jocelyn Mayer 2017-03-16 04:52:59 UTC
Created attachment 467188 [details]
efl-1.18.4 with USE=opengl set configure failure build log

this issue still occurs with efl-1.18.4
Comment 14 Jocelyn Mayer 2017-03-16 04:54:33 UTC
Created attachment 467190 [details]
efl-1.18.4 with USE=opengl set configure failure config.log
Comment 15 Matt Turner gentoo-dev 2018-04-16 22:40:00 UTC
Re-cc x11@ if we're needed.
Comment 16 Philippe Trottier 2018-04-17 01:14:43 UTC
It is a rather simple
opengl( !egl )


       if use opengl && use gles ; then
                einfo "You enabled both USE=opengl and USE=gles, but only one can be used;"
                einfo "opengl has been selected for you."
        fi


I guess this is a way to prevent the addition of package specific use flags, maybe add the egl too in that line ? 

What is the modern gentoo way to deal with this issue ? Local use flags or sanity checking of flags like currently ?

If someone gives me a guide line I will tune the ebuild.
Comment 17 Joonas Niilola gentoo-dev 2018-04-17 04:18:57 UTC
(In reply to Philippe Trottier from comment #16)
>        if use opengl && use gles ; then
>                 einfo "You enabled both USE=opengl and USE=gles, but only
> one can be used;"
>                 einfo "opengl has been selected for you."
>         fi
> 
> What is the modern gentoo way to deal with this issue ? Local use flags or
> sanity checking of flags like currently ?
> 
> If someone gives me a guide line I will tune the ebuild.

This sounds like REQUIRED_USE case, 
 REQUIRED_USE="^^ ( gles opengl )"

^^ means they cant be set at the same time, but both can be un-enabled. If you _must_ have either enabled, use ||

You can put the opengl ( !egl ) under required_use as well. 

More in here, 
 https://devmanual.gentoo.org/ebuild-writing/eapi/index.html
 (check under Variables)
Comment 18 Larry the Git Cow gentoo-dev 2018-07-07 14:48:08 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a7fd9de06cc89d685aa149e92e0adb50e48e10f1

commit a7fd9de06cc89d685aa149e92e0adb50e48e10f1
Author:     Joonas Niilola <juippis@gmail.com>
AuthorDate: 2018-07-04 15:43:43 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-07-07 14:15:46 +0000

    dev-libs/efl: bug fix & EAPI-7 bump for 1.20.7
    
    Closes: https://bugs.gentoo.org/571532
    Closes: https://bugs.gentoo.org/658602
    Closes: https://bugs.gentoo.org/651688
    Thanks to David Davidson for fix in #651688.
    
    Package-Manager: Portage[mgorny]-2.3.36.1
    Closes: https://github.com/gentoo/gentoo/pull/9045

 dev-libs/efl/efl-1.20.7-r1.ebuild | 305 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 305 insertions(+)