Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 570874 - >=dev-util/strace-4.11 fails tests execve-v.test, execve.test, readlink.test, umovestr2.test, and utime.test
Summary: >=dev-util/strace-4.11 fails tests execve-v.test, execve.test, readlink.test,...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo's Team for Core System packages
Depends on:
Reported: 2016-01-04 16:11 UTC by tka
Modified: 2017-04-21 08:28 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,137.07 KB, text/plain)
2016-01-04 16:12 UTC, tka
tests/test-suite.log (test-suite.log,32.95 KB, text/plain)
2016-01-04 16:13 UTC, tka
test-suite.log for strace-4.12 (test-suite.log,14.94 KB, text/plain)
2016-06-01 11:59 UTC, tka
test-suite.log for strace-4.13 (test-suite.log,15.67 KB, text/plain)
2016-07-27 10:15 UTC, tka

Note You need to log in before you can comment on or make changes to this bug.
Description tka 2016-01-04 16:11:43 UTC
FAIL: execve.test
FAIL: readlink.test
FAIL: umovestr2.test

Testsuite summary for strace 4.11
# TOTAL: 107
# PASS:  84
# SKIP:  20
# XFAIL: 0
# FAIL:  3
# XPASS: 0
# ERROR: 0
See tests/test-suite.log
Please report to
Makefile:1841: recipe for target 'test-suite.log' failed
make[5]: *** [test-suite.log] Error 1
make[5]: Leaving directory '/var/tmp/portage/dev-util/strace-4.11/work/strace-4.11/tests'
Makefile:1947: recipe for target 'check-TESTS' failed
make[4]: *** [check-TESTS] Error 2
make[4]: Leaving directory '/var/tmp/portage/dev-util/strace-4.11/work/strace-4.11/tests'
Makefile:2013: recipe for target 'check-am' failed
make[3]: *** [check-am] Error 2
make[3]: Leaving directory '/var/tmp/portage/dev-util/strace-4.11/work/strace-4.11/tests'
Makefile:2016: recipe for target 'check' failed
make[2]: *** [check] Error 2
make[2]: Leaving directory '/var/tmp/portage/dev-util/strace-4.11/work/strace-4.11/tests'
Makefile:3876: recipe for target 'check-recursive' failed
make[1]: *** [check-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/dev-util/strace-4.11/work/strace-4.11'
Makefile:4167: recipe for target 'check' failed
make: *** [check] Error 2
 * ERROR: dev-util/strace-4.11::gentoo failed (test phase):
 *   Make check failed. See above for details.
 * Call stack:
 *  , line  133:  Called src_test
 *          environment, line 2244:  Called default
 *, line  769:  Called default_src_test
 *, line  798:  Called __eapi0_src_test
 *, line  760:  Called die
 * The specific snippet of code:
 *   		$emake_cmd ${internal_opts} check || \
 *   			die "Make check failed. See above for details."

Reproducible: Always

# emerge --info '=dev-util/strace-4.11::gentoo'
Portage 2.2.26 (python 3.4.3-final-0, hardened/linux/amd64/no-multilib, gcc-5.3.0, glibc-2.22-r1, 4.3.3 x86_64)
                         System Settings
System uname: Linux-4.3.3-x86_64-Intel-R-_Core-TM-_i7-3720QM_CPU_@_2.60GHz-with-gentoo-2.2
KiB Mem:    16399780 total,  11068316 free
KiB Swap:   17825788 total,  17825788 free
Timestamp of repository gentoo: Mon, 04 Jan 2016 15:30:01 +0000
sh bash 4.3_p42-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p42-r1::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.22.1::gentoo
dev-lang/python:          2.7.11-r1::gentoo, 3.4.3-r7::gentoo
dev-util/cmake:           3.4.1::gentoo
dev-util/pkgconfig:       0.29::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.19.1::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r1::gentoo
sys-devel/automake:       1.14.1-r1::gentoo, 1.15-r1::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.7.4::gentoo, 4.9.3::gentoo, 5.3.0::gentoo
sys-devel/gcc-config:     1.8::gentoo
sys-devel/libtool:        2.4.6-r1::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r1::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000

    location: /var/lib/portage-local/local
    masters: gentoo
    priority: 0

    location: /var/lib/portage-local/testing
    masters: gentoo
    priority: 1

    location: /var/lib/layman/science
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=native -mtune=native -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -mtune=native -O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs cgroup collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox news parallel-fetch preserve-libs protect-owned sandbox sfperms strict test unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 acl acpi alsa amd64 avx berkdb bzip2 cairo caps cdda cddb cdparanoia cli cracklib crypt cups cxx dbus dri dts dvd fam ffmpeg fftw flac fontconfig foomaticdb gdbm gif gimp gmp gnutls gtk hardened iconv icu idn ipv6 jpeg justify lame lcms libnotify lzma mad matroska mmap mmx mmxext modules mp3 mpeg ncurses networkmanager nptl ogg opengl openmp pam pcre pie png policykit ppds readline sasl sdl seccomp session sse sse2 sse3 sse4 sse4_1 sse4_2 ssl ssp ssse3 startup-notification svg tcpd theora threads tiff truetype udev udisks unicode upower vaapi vorbis wayland x264 xattr xcb xml xtpax xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="i965 intel nouveau" XFCE_PLUGINS="power" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

emerge -pqv '=dev-util/strace-4.11::gentoo'
[ebuild     U ] dev-util/strace-4.11 [4.10] USE="-aio -perl -static -unwind"
Comment 1 tka 2016-01-04 16:12:21 UTC
Created attachment 421902 [details]
Comment 2 tka 2016-01-04 16:13:12 UTC
Created attachment 421904 [details]
Comment 3 Nico Rittner 2016-01-15 11:29:23 UTC
- tested with Version 4.11 - same behaviour
Comment 4 tka 2016-06-01 11:59:45 UTC
Created attachment 436012 [details]
test-suite.log for strace-4.12

The tests still fail with version 4.12:

FAIL: execve.test
FAIL: readlink.test
FAIL: umovestr2.test

There are also 2 additional tests that fail in 4.12:

FAIL: execve-v.test
FAIL: utime.test
Comment 5 tka 2016-07-27 10:15:16 UTC
Created attachment 441712 [details]
test-suite.log for strace-4.13

For strace-4.13, the same tests fail.

FAIL: execve-v.test
FAIL: execve.test
FAIL: readlink.test
FAIL: umovestr2.test
FAIL: utime.test
Comment 6 tka 2016-10-05 10:36:07 UTC
Tests still fail for strace-4.14.
Comment 7 eroen 2016-11-25 20:39:14 UTC
This is still present in strace-4.14. Fwiw, these tests pass with FEATURES="-usersandbox".