Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 570672 - sys-apps/portage: Add --autounmask-only parameter
Summary: sys-apps/portage: Add --autounmask-only parameter
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks: autounmask 549914
  Show dependency tree
 
Reported: 2016-01-02 23:00 UTC by Lucian Poston
Modified: 2016-05-10 20:35 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lucian Poston 2016-01-02 23:00:27 UTC
Add --autounmask-only parameter that will display autounmask messages, perform autounmasking (in accordance with the other --autounmask-* parameters), and exit with success (return value 0).

This will make it possible to differentiate cases where emerge exists due to compilation failure and where emerge autounmasks packages.

Reproducible: Always
Comment 1 Lucian Poston 2016-01-02 23:13:47 UTC
Patch posted for review at:

https://archives.gentoo.org/gentoo-portage-dev/message/94219ffc3dbef96eb970a67bb672e6db
Comment 2 Alexander Berntsen (RETIRED) gentoo-dev 2016-01-04 10:42:30 UTC
Fixed in git:

https://gitweb.gentoo.org/proj/portage.git/commit/?id=51f100e42753d6ffd3a24dfcb2ff8af0aa34966e
Comment 3 Zac Medico gentoo-dev 2016-03-14 03:54:04 UTC
Fixed in 2.2.27.