Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 570284 - When building ncurses with tinfo many apps fail to compile with curses USE flag
Summary: When building ncurses with tinfo many apps fail to compile with curses USE flag
Status: RESOLVED DUPLICATE of bug 457530
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-30 17:30 UTC by deference
Modified: 2015-12-30 18:44 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
dhex build log (build-dhex.log,6.10 KB, text/x-log)
2015-12-30 17:30 UTC, deference
Details
emerge --info (emergeinfo-dhex.txt,28.39 KB, text/plain)
2015-12-30 17:30 UTC, deference
Details

Note You need to log in before you can comment on or make changes to this bug.
Description deference 2015-12-30 17:30:17 UTC
Created attachment 421248 [details]
dhex build log

I have a list of apps that fail to compile when using tinfo, some don't even respect LDFLAGS env. I don't think you'd want one bug report per package since the fix is generic, so I figured I'd post them together.
So far I've noticed 58 apps.
I'm including just one build log, --info, and -pqv for good measure.

emerge -pqv dhex
[ebuild   R   ] app-editors/dhex-0.68 


Here is the list of apps:
alienwave
aumix
bastet
braincurses
bwm-ng
bzflag
cdircmp
cdw
centerim
clamav
clockywock
cmatrix
cmus
cone
cvoicecontrol
dhex
dio
dnstop
doomsday
duhdraw
duhdraw
dvorak7min
dvorakng
dvtm
ecasound
emact
fe
frotz
galaxis
gom
gramofile
herrie
matroxset
mcabber
mdcrack
moc
mon-cscope
mp
mp3c
mpfc
mudix
ninvaders
playmidi
predict
qrq
rexima
shed
sl
spectools
stone-soup
tint
touchcal
umix
vcp
xawtv
xawtv
ytree
zangband
Comment 1 deference 2015-12-30 17:30:42 UTC
Created attachment 421250 [details]
emerge --info
Comment 2 Brian Evans Gentoo Infrastructure gentoo-dev 2015-12-30 18:44:00 UTC
Please file individual bugs for those not listed on the tracker.

*** This bug has been marked as a duplicate of bug 457530 ***