Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 569702 - dev-libs/libappindicator-12.10.0-r300: parallel build failure
Summary: dev-libs/libappindicator-12.10.0-r300: parallel build failure
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords: NeedPatch
Depends on:
Blocks: parallel-make
  Show dependency tree
 
Reported: 2015-12-25 11:33 UTC by Xepher
Modified: 2022-05-10 19:48 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log 12.10.0-r301 (dev-libs:libappindicator-12.10.0-r301:20160508-235600.log,19.77 KB, text/plain)
2016-05-09 01:09 UTC, M. B.
Details
build.log 12.10.0-r201 (dev-libs:libappindicator-12.10.0-r201:20160508-235606.log,19.39 KB, text/plain)
2016-05-09 01:10 UTC, M. B.
Details
/libappindicator-12.10.1_p20200706 build failure (file_569702.txt,74 bytes, text/plain)
2021-07-10 18:14 UTC, Joakim Tjernlund
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xepher 2015-12-25 11:33:34 UTC
Multi-job make (-j5) causes race condition, as there's a header file generated during compile, but also required during compile.

Reproducible: Always

Steps to Reproduce:
1. MAKEOPTS="-j50" emerge libappindicator

Actual Results:  
Most likely results (race condition):

/var/tmp/portage/dev-libs/libappindicator-12.10.0-r300/work/libappindicator-12.10.0/src/app-indicator.c:43:41: fatal error: application-service-marshal.h: No such file or directory

Expected Results:  
Successful compile.

Setting MAKEOPTS="-j1" works without issue.
Comment 1 Gilles Dartiguelongue gentoo-dev 2015-12-26 11:09:56 UTC
We try to fix the issue rather than blindly set makeopts to -j1.
Comment 2 Pacho Ramos gentoo-dev 2016-05-07 08:32:57 UTC
Please attach the full build.log too
Comment 3 Xepher 2016-05-08 00:04:57 UTC
Sorry, wasn't suggesting to blindly set it to -j1, just showing how to reproduce. 

As for a build log, I went to try to get one, but I can no longer reproduce the problem myself either. Even set it on a loop to rebuild repeatedly since I suspected it was a race condition, but two hours later, still no failures. I suppose this may as well be closed.
Comment 4 Pacho Ramos gentoo-dev 2016-05-08 09:14:32 UTC
Thanks for feedback
Comment 5 M. B. 2016-05-09 01:09:48 UTC
Created attachment 433696 [details]
build.log 12.10.0-r301

Sorry to spoil the party, but I can reproduce it with 200/300 as well as 201/301.
Comment 6 M. B. 2016-05-09 01:10:56 UTC
Created attachment 433698 [details]
build.log 12.10.0-r201
Comment 7 . 2016-05-16 19:59:55 UTC
(In reply to M. B. from comment #5)
> Created attachment 433696 [details]
> build.log 12.10.0-r301
> 
> Sorry to spoil the party, but I can reproduce it with 200/300 as well as
> 201/301.

Yep, the same here with 12.10.0-r201, because it was now marked **stable** - https://bugs.gentoo.org/show_bug.cgi?id=582324
Comment 8 Larry the Git Cow gentoo-dev 2021-05-26 12:24:00 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a392bc84fc0e36bd78218c3a1c691dd9c856aacc

commit a392bc84fc0e36bd78218c3a1c691dd9c856aacc
Author:     Pacho Ramos <pacho@gentoo.org>
AuthorDate: 2021-05-26 12:23:43 +0000
Commit:     Pacho Ramos <pacho@gentoo.org>
CommitDate: 2021-05-26 12:23:55 +0000

    dev-libs/libappindicator: Bump to latest snapshot used in Ubuntu
    
    Bug: https://bugs.gentoo.org/569702
    Closes: https://bugs.gentoo.org/621452
    Closes: https://bugs.gentoo.org/706084
    Package-Manager: Portage-3.0.18, Repoman-3.0.3
    Signed-off-by: Pacho Ramos <pacho@gentoo.org>

 dev-libs/libappindicator/Manifest                  |  1 +
 .../libappindicator-12.10.1_p20200706.ebuild       | 71 ++++++++++++++++++++++
 2 files changed, 72 insertions(+)
Comment 9 Pacho Ramos gentoo-dev 2021-05-26 12:24:42 UTC
Please retry with latest version... if still valid for you, please report to upstream as, otherwise, I don't think it will be fixed ever

Thanks
Comment 10 Xepher 2021-05-27 05:05:21 UTC
Emerge built it several times in a row, both with -j50 and my default -j16. Can't reproduce the issue. Good enough for me. Only nm-applet and transmission even use this on my system anymore.
Comment 11 Pacho Ramos gentoo-dev 2021-05-30 20:04:29 UTC
thanks for the feedback!
Comment 12 Joakim Tjernlund 2021-07-10 18:14:00 UTC
Created attachment 723172 [details]
/libappindicator-12.10.1_p20200706 build failure

libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I/var/tmp/portage/dev-libs/libappindicator-12.10.1_p20200706/work/src -I.. -pthread -I/usr/include/libdbusmenu-gtk3-0.4 -I/usr/include/libdbusmenu-glib-0.4 -I/usr/include/gtk-3.0 -I/usr/include/at-spi2-atk/2.0 -I/usr/include/at-spi-2.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/gtk-3.0 -I/usr/include/gio-unix-2.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/fribidi -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/uuid -I/usr/include/freetype2 -I/usr/include/harfbuzz -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/libmount -I/usr/include/blkid -I/usr/lib64/libffi/include -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -Wall -Wno-error=deprecated-declarations -DG_LOG_DOMAIN=\"libappindicator\" -O2 -pipe -Wno-error -fno-stack-check -Wno-deprecated-declarations -fdebug-prefix-map=..=/var/tmp/portage/dev-libs/libappindicator-12.10.1_p20200706 -c /var/tmp/portage/dev-libs/libappindicator-12.10.1_p20200706/work/src/app-indicator.c  -fPIC -DPIC -o .libs/libappindicator3_la-app-indicator.o
/var/tmp/portage/dev-libs/libappindicator-12.10.1_p20200706/work/src/app-indicator.c:45:10: fatal error: application-service-marshal.h: No such file or directory
   45 | #include "application-service-marshal.h"
      |          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
compilation terminated.
make[2]: *** [Makefile:788: libappindicator3_la-app-indicator.lo] Error 1
make[1]: *** [Makefile:471: all-recursive] Error 1
make: *** [Makefile:402: all] Error 2
 * ERROR: dev-libs/libappindicator-12.10.1_p20200706::gentoo failed (compile phase):
 *   emake failed
Comment 13 Joakim Tjernlund 2021-07-10 18:16:10 UTC
remerged the pkg and that worked.