Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 568614 - media-libs/libcec fails to build with gcc-5
Summary: media-libs/libcec fails to build with gcc-5
Status: RESOLVED DUPLICATE of bug 550432
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Ian Whyman (thev00d00)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-5
  Show dependency tree
 
Reported: 2015-12-18 10:50 UTC by dawgg
Modified: 2015-12-19 21:06 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dawgg 2015-12-18 10:50:26 UTC
after
revdep-rebuild -pvv --library 'libstdc\+\+\.so\.6' -- --exclude gcc
finished and rebuilt everything libcec still does not compile/install with ebuild with the followong error:
[100%] Linking CXX executable cec-client
cd /var/tmp/portage/dev-libs/libcec-3.0.1/work/libcec-3.0.1_build/src/cec-client && /usr/bin/cmake -E cmake_link_script CMakeFiles/cec-client.dir/link.txt --verbose=1
/usr/bin/x86_64-pc-linux-gnu-g++   -march=native -O2 -pipe  -std=c++11   -Wl,-O1 -Wl,--as-needed CMakeFiles/cec-client.dir/cec-client.cpp.o CMakeFiles/cec-client.dir/curses/CursesControl.cpp.o  -o cec-client-3.0.1 -rdynamic -L/usr/lib64 -lplatform -lpthread -lpthread -ldl -lcurses -lrt 
CMakeFiles/cec-client.dir/cec-client.cpp.o: In function `PrintToStdOut(char const*, ...)':
cec-client.cpp:(.text+0x217): undefined reference to `StringUtils::FormatV[abi:cxx11](char const*, __va_list_tag*)'
CMakeFiles/cec-client.dir/cec-client.cpp.o: In function `CecLogMessage(void*, CEC::cec_log_message)':
cec-client.cpp:(.text+0x4c0): undefined reference to `StringUtils::Format[abi:cxx11](char const*, ...)'
CMakeFiles/cec-client.dir/cec-client.cpp.o: In function `ListDevices(CEC::ICECAdapter*)':
cec-client.cpp:(.text+0x13fe): undefined reference to `StringUtils::Format[abi:cxx11](char const*, ...)'
cec-client.cpp:(.text+0x1582): undefined reference to `StringUtils::Format[abi:cxx11](char const*, ...)'
cec-client.cpp:(.text+0x15c1): undefined reference to `StringUtils::Left(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, unsigned long)'
CMakeFiles/cec-client.dir/cec-client.cpp.o: In function `ProcessCommandSELF(CEC::ICECAdapter*, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >&)':
cec-client.cpp:(.text+0x3b55): undefined reference to `StringUtils::Format[abi:cxx11](char const*, ...)'
CMakeFiles/cec-client.dir/cec-client.cpp.o: In function `ProcessCommandLANG(CEC::ICECAdapter*, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >&)':
cec-client.cpp:(.text+0x526c): undefined reference to `StringUtils::Format[abi:cxx11](char const*, ...)'
CMakeFiles/cec-client.dir/cec-client.cpp.o: In function `ProcessCommandSCAN(CEC::ICECAdapter*, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >&)':
cec-client.cpp:(.text+0x5dd4): undefined reference to `StringUtils::Format[abi:cxx11](char const*, ...)'
cec-client.cpp:(.text+0x5e3c): undefined reference to `StringUtils::Format[abi:cxx11](char const*, ...)'
cec-client.cpp:(.text+0x5e8c): undefined reference to `StringUtils::Format[abi:cxx11](char const*, ...)'
CMakeFiles/cec-client.dir/cec-client.cpp.o:cec-client.cpp:(.text+0x5ee5): more undefined references to `StringUtils::Format[abi:cxx11](char const*, ...)' follow
collect2: error: ld returned 1 exit status
src/cec-client/CMakeFiles/cec-client.dir/build.make:120: recipe for target 'src/cec-client/cec-client-3.0.1' failed
make[2]: *** [src/cec-client/cec-client-3.0.1] Error 1
make[2]: Leaving directory '/var/tmp/portage/dev-libs/libcec-3.0.1/work/libcec-3.0.1_build'
CMakeFiles/Makefile2:85: recipe for target 'src/cec-client/CMakeFiles/cec-client.dir/all' failed
make[1]: *** [src/cec-client/CMakeFiles/cec-client.dir/all] Error 2
make[1]: Leaving directory '/var/tmp/portage/dev-libs/libcec-3.0.1/work/libcec-3.0.1_build'
Makefile:127: recipe for target 'all' failed

i compiled libcec from git://github.com/Pulse-Eight/libcec.git and that worked.
Comment 1 SpanKY gentoo-dev 2015-12-19 21:05:57 UTC
you need to re-emerge dev-libs/libplatform first by hand

*** This bug has been marked as a duplicate of bug 550432 ***