Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 56775 - wget still in emerge-webrsync
Summary: wget still in emerge-webrsync
Status: RESOLVED DUPLICATE of bug 57887
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: PPC All
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-07-12 03:24 UTC by Jochen Maes (RETIRED)
Modified: 2005-07-17 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jochen Maes (RETIRED) gentoo-dev 2004-07-12 03:24:39 UTC
emerge-webrsync on line 63 still uses wget in stead of curl.

Reproducible: Always
Steps to Reproduce:
1.emerge-webrsync
2.
3.

Actual Results:  
wget isn't found

Expected Results:  
use curl
Comment 1 Marius Mauch (RETIRED) gentoo-dev 2004-07-12 03:27:23 UTC
why do you expect it to use curl ?
Comment 2 Jochen Maes (RETIRED) gentoo-dev 2004-07-12 03:29:01 UTC
because on mac os wget isn't installed, and you'd need to use curl. 

this isn't really a thing that portage devs need to change but the osx departement .

i'm working on it, just wanted to let everyone know it is taking care of...

greetings
Comment 3 Pieter Van den Abeele (RETIRED) gentoo-dev 2004-07-12 18:35:16 UTC
Wget is in the system profile for the new installer, meaning wget will now be installed by the time you are able to use emerge-webrsync. This turns this bug into a non-blocking bug I'd like to see the portage team fix for their next release: it should reuse the make.conf or make.default setting for fetching stuff.
Comment 4 Brian Harring gentoo-dev 2004-08-01 05:01:55 UTC
marking this as a dupe of 57887 (patch is there).
I'll be commiting it in the next day or so- need to test it w/ wget prior.
Should remove the need for wget from the profile.

*** This bug has been marked as a duplicate of 57887 ***