Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 566512 - sys-power/suspend-1.0 fails to build with GCC5
Summary: sys-power/suspend-1.0 fails to build with GCC5
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Michael Weber (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on: 567376
Blocks: gcc-5
  Show dependency tree
 
Reported: 2015-11-22 20:32 UTC by Jan Chren (rindeal)
Modified: 2016-11-20 23:49 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,198.68 KB, text/x-log)
2015-12-20 21:13 UTC, Jan Chren (rindeal)
Details
environment (environment,98.21 KB, text/plain)
2015-12-20 21:13 UTC, Jan Chren (rindeal)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Chren (rindeal) 2015-11-22 20:32:44 UTC
solved Debian bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=778159

sys-power/suspend-1.0_p20150810 builds fine (without lzo, otherwise it gives undefined references)
Comment 1 Andrew Savchenko gentoo-dev 2015-12-04 07:45:26 UTC
Hello,

do you have this problem on Gentoo? If yes, please upload build.log and environment files. We have quite a patched version compared to what Debian ships.

I can't reproduce issue with lzo: 1.0_p20150810 builds fine here even with gcc 5.2.
Comment 2 Jan Chren (rindeal) 2015-12-20 21:12:58 UTC
I've tried it today and 1.0_p20150810 builds OK with GCC5.3 even with lzo flag. 1.0 errors persist though.
Comment 3 Jan Chren (rindeal) 2015-12-20 21:13:25 UTC
Created attachment 419944 [details]
build.log
Comment 4 Jan Chren (rindeal) 2015-12-20 21:13:51 UTC
Created attachment 419946 [details]
environment
Comment 5 Andrew Savchenko gentoo-dev 2015-12-20 23:31:15 UTC
1.0 will be removed from the tree as soon as 1.0-p20150810 is stabilized, which is in progress now.
Comment 6 Andreas Sturmlechner gentoo-dev 2016-11-20 23:49:41 UTC
Affected version not in tree anymore, closing this.