Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 564998 - dev-libs/libmemcache-1.4.0_rc2-r1 : memcache.c:2209:43: error: dereferencing pointer to incomplete type
Summary: dev-libs/libmemcache-1.4.0_rc2-r1 : memcache.c:2209:43: error: dereferencing ...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Robin Johnson
URL:
Whiteboard:
Keywords: PMASKED
: 593354 (view as bug list)
Depends on:
Blocks: gcc-6 644262
  Show dependency tree
 
Reported: 2015-11-06 09:31 UTC by Toralf Förster
Modified: 2018-10-08 12:20 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
dev-libs:libmemcache-1.4.0_rc2-r1:20151105-235442.log (dev-libs:libmemcache-1.4.0_rc2-r1:20151105-235442.log,20.99 KB, text/plain)
2015-11-06 09:31 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,566.36 KB, text/plain)
2015-11-06 09:31 UTC, Toralf Förster
Details
environment (environment,101.11 KB, text/plain)
2015-11-06 09:31 UTC, Toralf Förster
Details
emerge-info.txt (emerge-info.txt,6.35 KB, text/plain)
2016-04-22 13:40 UTC, Toralf Förster
Details
dev-libs:libmemcache-1.4.0_rc2-r1:20160422-133822.log (dev-libs:libmemcache-1.4.0_rc2-r1:20160422-133822.log,19.42 KB, text/plain)
2016-04-22 13:40 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,186.65 KB, text/plain)
2016-04-22 13:40 UTC, Toralf Förster
Details
environment (environment,97.88 KB, text/plain)
2016-04-22 13:41 UTC, Toralf Förster
Details
Patch for libmemcached-1.4.0 (libmemcache.patch,626 bytes, patch)
2016-10-21 10:24 UTC, Felix Janda
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2015-11-06 09:31:42 UTC
In file included from memcache.c:60:0:
memcache.c:2082:35: warning: passing argument 6 of ‘mcm_err’ makes pointer from integer without a cast
     MCM_ERR_MSG(MCM_ERR_NET_HOST, gai_strerror(ret));
                                        ^
                                        ../include/memcache.h:1066:89: note: in definition of macro ‘MCM_ERR_MSG’
                                         _code, _msg) mcm_err(ctxt, ERR_FLAG, __FUNCTION__, __LINE__, _code, _msg, (_msg
                                                                                                              ^
                                                                                                              memcache.c:768:1: note: expected ‘const char *’ but argument is of type ‘int’
                                                                                                               mcm_err(const struct memcache_ctxt *ctxt, const u_int32_t flags, const char *fu
                                                                                                                ^
                                                                                                                memcache.c: In function ‘mcm_server_connect’:
                                                                                                                memcache.c:2209:43: error: dereferencing pointer to incomplete type
                                                                                                                   if (ms->hostinfo == NULL || ms->hostinfo->ai_addrlen == 0) {



$ cat ./info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-13.0-unstable_20151021-212800) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------

  Portage 2.2.24 (python 3.4.3-final-0, default/linux/amd64/13.0, gcc-4.9.3, glibc-2.22-r1, 4.1.7-hardened-r1 x86_64)
=================================================================
System uname: Linux-4.1.7-hardened-r1-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16164644 total,   3722220 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Thu, 05 Nov 2015 13:41:55 +0000
sh bash 4.3_p42
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
distcc 3.2rc1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.3_p42::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.22.0::gentoo
dev-lang/python:          2.7.10::gentoo, 3.3.5-r2::gentoo, 3.4.3::gentoo, 3.5.0-r1::gentoo
dev-util/cmake:           3.3.2-r1::gentoo
dev-util/pkgconfig:       0.29::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.18.3::gentoo
sys-apps/sandbox:         2.9::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r1::gentoo
sys-devel/automake:       1.9.6-r4::gentoo, 1.10.3-r1::gentoo, 1.11.6-r1::gentoo, 1.12.6::gentoo, 1.13.4::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.2.4-r1::gentoo, 4.9.3::gentoo
sys-devel/gcc-config:     1.8::gentoo
sys-devel/libtool:        2.4.6-r1::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 1

local
    location: /usr/local/portage
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/stunnel/stunnel.conf /usr/lib64/fax /usr/share/config /usr/share/easy-rsa /usr/share/gnupg/qualified.txt /var/lib/hsqldb /var/spool/fax/etc /var/yp/Makefile"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--deep --color=n --nospinner --tree --quiet-build --accept-properties=-interactive --accept-restrict=-fetch"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="X acl adns amd64 avx berkdb bindist btrfs bzip2 cgi cgoups cli consolekit cracklib crypt cups curl custom-cflags cxx dbus designer dnssec dot dri dvb dvd ffmpeg fortran gdbm git gtk iconv inifile introspection ipv6 javaxml jpeg lapack libkms mbox minizip mmx mmxext modules multilib multimedia ncurses nls nptl opencv opengl openmp openssl pam pax_kernel pcre pcre16 pdo plasma png postgres pyqt4 python qt4 readline sdl seccomp session sockets sse sse2 sse4 sse4_2 ssl system-cairo system-jpeg tcpd threads tk tls unicode uxa v4l2 video widgets x264 xattr xkb zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_GB" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2015-11-06 09:31:45 UTC
Created attachment 416140 [details]
dev-libs:libmemcache-1.4.0_rc2-r1:20151105-235442.log
Comment 2 Toralf Förster gentoo-dev 2015-11-06 09:31:47 UTC
Created attachment 416142 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2015-11-06 09:31:50 UTC
Created attachment 416144 [details]
environment
Comment 4 Kent Fredric (IRC: kent\n) gentoo-dev 2016-03-06 10:05:49 UTC
Somehow my error logs have data in them toralf's lacked. ( I suspect due to ANSI colors doing the wrong thing somewhere:


> memcache.c: In function ‘mcm_server_connect’:
> memcache.c:2209:42: error: dereferencing pointer to incomplete type ‘struct addrinfo’
>    if (ms->hostinfo == NULL || ms->hostinfo->ai_addrlen == 0) {
>                                           ^


> memcache.c: In function ‘mcm_server_resolve’:
> memcache.c:2597:19: error: storage size of ‘hints’ isn’t known
>    struct addrinfo hints, *res;
>                    ^
> memcache.c:2613:24: error: invalid application of ‘sizeof’ to incomplete type ‘struct addrinfo’
>    bzero(&hints, sizeof(struct addrinfo));
>                         ^


HTH.
Comment 5 Toralf Förster gentoo-dev 2016-03-06 10:19:01 UTC
(In reply to Kent Fredric from comment #4)
oops, does the following not what do expect ? :

function stresc() {
  perl -ne 's/\e\[?.*?[\@-~]//g; print'
}


I do use it in htis manner : "stresc < $log > $bak" often
Comment 6 Kent Fredric (IRC: kent\n) gentoo-dev 2016-03-06 10:32:48 UTC
(In reply to Toralf Förster from comment #5)
> (In reply to Kent Fredric from comment #4)
> oops, does the following not what do expect ? :
> 
> function stresc() {
>   perl -ne 's/\e\[?.*?[\@-~]//g; print'
> }
> 
> 
> I do use it in htis manner : "stresc < $log > $bak" often

You probably want


> perl -MTerm::ANSIColor=colorstrip -nle 'print colorstrip($_)'

( Its a much tighter regex internally that only matches numbers and ";" in escape codes )

Running your code locally as follows however gives me the right output, so I'm not sure where/why those values were eaten.

> zcat /var/log/portage/build/dev-libs/libmemcache-1.4.0_rc2-r1\:20160306-102048.log.gz  | perl -ne 's/\e\[?.*?[\@-~]//g; print'

Looking deeper into your log, may actually be having different compiler errors (because I see not all types in error conditions are eaten, only some are) , just they're too similar to tell.
Comment 7 Toralf Förster gentoo-dev 2016-04-22 13:40:52 UTC
Created attachment 431536 [details]
emerge-info.txt

fresh files, maybe containing the needed info ?\n\n ^
memcache.c: In function ‘mcm_server_connect’:
memcache.c:2209:43: error: dereferencing pointer to incomplete type ‘struct addrinfo’
   if (ms->hostinfo == NULL || ms->hostinfo->ai_addrlen == 0) {
                                           ^
In file included from memcache.c:60:0:
Comment 8 Toralf Förster gentoo-dev 2016-04-22 13:40:54 UTC
Created attachment 431538 [details]
dev-libs:libmemcache-1.4.0_rc2-r1:20160422-133822.log
Comment 9 Toralf Förster gentoo-dev 2016-04-22 13:40:57 UTC
Created attachment 431540 [details]
emerge-history.txt
Comment 10 Toralf Förster gentoo-dev 2016-04-22 13:41:00 UTC
Created attachment 431542 [details]
environment
Comment 11 Livid 2016-07-16 22:15:53 UTC
This is a parallel make issue. Building with MAKEOPTS="-j1 -pipe" works.
Comment 12 Livid 2016-07-16 22:17:11 UTC
Correction: well, at least that worked for me.
Comment 13 Toralf Förster gentoo-dev 2016-07-17 07:42:25 UTC
(In reply to Livid from comment #11)
-j1 is hard coded in the tinderbox
Comment 14 Felix Janda 2016-09-10 16:11:50 UTC
My guess is that newer glibc headers do not like memcache.c playing around with glibc internal __USE_POSIX.
Comment 15 Matthew Thode ( prometheanfire ) archtester Gentoo Infrastructure gentoo-dev Security 2016-09-10 16:41:49 UTC
*** Bug 593354 has been marked as a duplicate of this bug. ***
Comment 16 Jeremy Stent 2016-10-21 01:43:34 UTC
I find that adding "#define __USE_XOPEN2K" to the memcache.c file above #include <netdb.h> resolves this build issue.  I do not know what should be passed on the command line to force this.
Comment 17 Felix Janda 2016-10-21 10:24:04 UTC
Created attachment 450882 [details, diff]
Patch for libmemcached-1.4.0

glibc headers need some feature test macros to expose the definition of
struct addrinfo. _XOPEN_SOURCE does not work, but _XOPEN_SOURCE 700
does. So this patch adds the feature test macro, and removes the hackery.
Comment 18 Néstor Amigo Cairo 2016-12-05 17:33:56 UTC
I have the same error.

emerge --info '=dev-libs/libmemcache-1.4.0_rc2-r1::gentoo'
Portage 2.2.28 (python 3.4.3-final-0, default/linux/amd64/13.0/desktop/plasma/systemd, gcc-4.9.3, glibc-2.22-r4, 4.4.6-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.4.6-gentoo-x86_64-Intel-R-_Core-TM-_i5-2520M_CPU_@_2.50GHz-with-gentoo-2.2
KiB Mem:     8059696 total,    263256 free
KiB Swap:   10239996 total,  10102536 free
Timestamp of repository gentoo: Mon, 05 Dec 2016 16:00:01 +0000
sh bash 4.3_p48
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p48::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.22.2::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.3-r1::gentoo
dev-util/cmake:           3.3.1-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.19.1::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r4::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="es_ES.US-ASCII"
LC_ALL="es_ES.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 apm atm audiofile avahi ayatana bash-completion berkdb bluetooth boundschecking branding bzip2 cairo calendar caps cdb cdda cgi cli cracklib crypt css cups curl cxx dbus declarative dga directfb djvu dri dts dv emboss encode exif fam fat fbcon ffmpeg fftw filecaps firefox flac fontconfig foomaticdb fortran gd gdbm geoip ggi gif glamor glut gphoto2 gpm gsl gsm gtk hddtemp iconv icu idn imap imlib inotify ipv6 jack java javafx javascript jbig jit jpeg jpeg2k kde kipi kontact ladspa lame lash lcms ldap libass libcaca libnotify libsamplerate lm_sensors lzma lzo mad matroska memcached memlimit mikmod mime mmap mms mmx mmxext mng modplug modules mp3 mp4 mpeg mpi mplayer mtp multilib musepack musicbrainz ncurses networkmanager nls nocd nptl ogg openal openexr opengl openmp pam pango pch pcmcia pcntl pcre pda pdf phonon php plasma png policykit postscript ppds pulseaudio pyqt4 python qml qt3support qt4 qt5 quicktime raw rdesktop readline recode rss scanner sdl seccomp semantic-desktop session sharedmem shorten sndfile sockets sound sox speex spell sse sse2 ssl startup-notification svg symlink systemd tcpd theora threads tidy tiff timidity truetype udev udisks unicode upnp upower usb v4l vaapi vcd vdpau vnc vorbis wavpack webkit widgets wifi wmf wxwidgets x264 xattr xcb xcomposite xft xinerama xml xosd xpm xscreensaver xv xvid zeroconf zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="synaptics evdev" KERNEL="linux" L10N="es eu fr en" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="es" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 19 Néstor Amigo Cairo 2016-12-05 18:57:29 UTC
I get also the following errors:

memcache.c:2209:43: error: dereferencing pointer to incomplete type
   if (ms->hostinfo == NULL || ms->hostinfo->ai_addrlen == 0) {

memcache.c:2218:57: error: dereferencing pointer to incomplete type
   for (i = 0, res = ms->hostinfo; res != NULL; res = res->ai_next, i++) {

memcache.c:2219:24: error: dereferencing pointer to incomplete type
     ms->fd = socket(res->ai_family, res->ai_socktype, res->ai_protocol);
                        ^
memcache.c:2219:40: error: dereferencing pointer to incomplete type
     ms->fd = socket(res->ai_family, res->ai_socktype, res->ai_protocol);
                                        ^
memcache.c:2219:58: error: dereferencing pointer to incomplete type
     ms->fd = socket(res->ai_family, res->ai_socktype, res->ai_protocol);
                                                          ^
memcache.c:2222:42: error: dereferencing pointer to incomplete type
       if (errno == EPROTONOSUPPORT && res->ai_family == AF_INET6)
                                          ^
memcache.c:2253:30: error: dereferencing pointer to incomplete type
     ret = connect(ms->fd, res->ai_addr, (socklen_t)res->ai_addrlen);
                              ^
memcache.c:2253:55: error: dereferencing pointer to incomplete type
     ret = connect(ms->fd, res->ai_addr, (socklen_t)res->ai_addrlen);
                                                       ^
memcache.c:2291:49: error: dereferencing pointer to incomplete type
    printf("connect(): %d\n", connect(ms->fd, res->ai_addr, (socklen_t)res->ai_addrlen));
                                                 ^
memcache.c:2291:74: error: dereferencing pointer to incomplete type
    printf("connect(): %d\n", connect(ms->fd, res->ai_addr, (socklen_t)res->ai_addrlen));

emcache.c:2597:19: error: storage size of 'hints' isn't known
   struct addrinfo hints, *res;
                   ^
memcache.c:2613:24: error: invalid application of 'sizeof' to incomplete type 'struct addrinfo'
   bzero(&hints, sizeof(struct addrinfo));

memcache.c:2634:50: error: dereferencing pointer to incomplete type
   for (res = ms->hostinfo; res != NULL; res = res->ai_next) {
Comment 20 Larry the Git Cow gentoo-dev 2018-05-10 19:21:16 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=e251f1b03c2ed695b7bf63f7bdf0bf247ed7a5a0

commit e251f1b03c2ed695b7bf63f7bdf0bf247ed7a5a0
Author:     Mikle Kolyada <zlogene@gentoo.org>
AuthorDate: 2018-05-10 19:19:25 +0000
Commit:     Mikle Kolyada <zlogene@gentoo.org>
CommitDate: 2018-05-10 19:21:05 +0000

    dev-libs/libmemcache: Masked for removal
    
    Bug: https://bugs.gentoo.org/644262
    Bug: https://bugs.gentoo.org/564998

 profiles/package.mask | 6 ++++++
 1 file changed, 6 insertions(+)
Comment 21 Virgil Dupras gentoo-dev 2018-10-08 12:20:39 UTC
Removed from the tree in June.