Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 564040 - media-video/ffmpegthumbnailer-2.1.0 fails to build with media-video/libav - error: av_guess_sample_aspect_ratio was not declared in this scope
Summary: media-video/ffmpegthumbnailer-2.1.0 fails to build with media-video/libav - e...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 654354 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-10-25 09:15 UTC by tman
Modified: 2020-04-26 15:23 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/mnt/portage/logs/media-video:ffmpegthumbnailer-2.1.0:20151025-074140.log (media-video:ffmpegthumbnailer-2.1.0:20151025-074140.log,8.46 KB, text/x-log)
2015-10-25 09:16 UTC, tman
Details
trimmed escape sequence free log of the failure (ffmpeg-failure..txt,17.70 KB, text/plain)
2016-01-09 15:39 UTC, Brian Dolbec
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tman 2015-10-25 09:15:27 UTC
[ 60%] Building CXX object CMakeFiles/libffmpegthumbnailer.dir/libffmpegthumbnailer/jpegwriter.cpp.o
[ 70%] Building CXX object CMakeFiles/libffmpegthumbnailer.dir/libffmpegthumbnailer/pngwriter.cpp.o
^[[01m^[[K/var/tmp/portage/media-video/ffmpegthumbnailer-2.1.0/work/ffmpegthumbnailer-2.1.0/libffmpegthumbnailer/moviedecoder.cpp:^[[m^[[K In member function ‘^[[01m^[[Kbool ffmpegthumbnailer::MovieDecoder::decodeVideoPacket()^[[m^[[K’:
^[[01m^[[K/var/tmp/portage/media-video/ffmpegthumbnailer-2.1.0/work/ffmpegthumbnailer-2.1.0/libffmpegthumbnailer/moviedecoder.cpp:280:5:^[[m^[[K ^[[01;35m^[[Kwarning: ^[[m^[[K‘^[[01m^[[Kvoid avcodec_get_frame_defaults(AVFrame*)^[[m^[[K’ is deprecated (declared at ^[[01m^[[K/usr/include/libavcodec/avcodec.h:3205^[[m^[[K) [-Wdeprecated-declarations]
     avcodec_get_frame_defaults(m_pFrame);
^[[01;32m^[[K     ^^[[m^[[K
^[[01m^[[K/var/tmp/portage/media-video/ffmpegthumbnailer-2.1.0/work/ffmpegthumbnailer-2.1.0/libffmpegthumbnailer/moviedecoder.cpp:280:40:^[[m^[[K ^[[01;35m^[[Kwarning: ^[[m^[[K‘^[[01m^[[Kvoid avcodec_get_frame_defaults(AVFrame*)^[[m^[[K’ is deprecated (declared at ^[[01m^[[K/usr/include/libavcodec/avcodec.h:3205^[[m^[[K) [-Wdeprecated-declarations]
     avcodec_get_frame_defaults(m_pFrame);
^[[01;32m^[[K                                        ^^[[m^[[K
^[[01m^[[K/var/tmp/portage/media-video/ffmpegthumbnailer-2.1.0/work/ffmpegthumbnailer-2.1.0/libffmpegthumbnailer/moviedecoder.cpp:^[[m^[[K In member function ‘^[[01m^[[Kvoid ffmpegthumbnailer::MovieDecoder::getScaledVideoFrame(int, bool, ffmpegthumbnailer::VideoFrame&)^[[m^[[K’:
^[[01m^[[K/var/tmp/portage/media-video/ffmpegthumbnailer-2.1.0/work/ffmpegthumbnailer-2.1.0/libffmpegthumbnailer/moviedecoder.cpp:328:9:^[[m^[[K ^[[01;35m^[[Kwarning: ^[[m^[[K‘^[[01m^[[Kint avpicture_deinterlace(AVPicture*, const AVPicture*, AVPixelFormat, int, int)^[[m^[[K’ is deprecated (declared at ^[[01m^[[K/usr/include/libavcodec/avcodec.h:4086^[[m^[[K) [-Wdeprecated-declarations]
         avpicture_deinterlace((AVPicture*) m_pFrame, (AVPicture*) m_pFrame, m_pVideoCodecContext->pix_fmt,
^[[01;32m^[[K         ^^[[m^[[K
^[[01m^[[K/var/tmp/portage/media-video/ffmpegthumbnailer-2.1.0/work/ffmpegthumbnailer-2.1.0/libffmpegthumbnailer/moviedecoder.cpp:329:88:^[[m^[[K ^[[01;35m^[[Kwarning: ^[[m^[[K‘^[[01m^[[Kint avpicture_deinterlace(AVPicture*, const AVPicture*, AVPixelFormat, int, int)^[[m^[[K’ is deprecated (declared at ^[[01m^[[K/usr/include/libavcodec/avcodec.h:4086^[[m^[[K) [-Wdeprecated-declarations]
                               m_pVideoCodecContext->width, m_pVideoCodecContext->height);
^[[01;32m^[[K                                                                                        ^^[[m^[[K
^[[01m^[[K/var/tmp/portage/media-video/ffmpegthumbnailer-2.1.0/work/ffmpegthumbnailer-2.1.0/libffmpegthumbnailer/moviedecoder.cpp:^[[m^[[K In member function ‘^[[01m^[[Kvoid ffmpegthumbnailer::MovieDecoder::calculateDimensions(int, bool, int&, int&)^[[m^[[K’:
^[[01m^[[K/var/tmp/portage/media-video/ffmpegthumbnailer-2.1.0/work/ffmpegthumbnailer-2.1.0/libffmpegthumbnailer/moviedecoder.cpp:405:93:^[[m^[[K ^[[01;31m^[[Kerror: ^[[m^[[K‘^[[01m^[[Kav_guess_sample_aspect_ratio^[[m^[[K’ was not declared in this scope
     AVRational par = av_guess_sample_aspect_ratio(m_pFormatContext, m_pVideoStream, m_pFrame);
^[[01;32m^[[K                                                                                             ^^[[m^[[K
CMakeFiles/libffmpegthumbnailer.dir/build.make:62: recipe for target 'CMakeFiles/libffmpegthumbnailer.dir/libffmpegthumbnailer/moviedecoder.cpp.o' failed
make[2]: *** [CMakeFiles/libffmpegthumbnailer.dir/libffmpegthumbnailer/moviedecoder.cpp.o] Error 1
make[2]: *** Waiting for unfinished jobs....
CMakeFiles/Makefile2:104: recipe for target 'CMakeFiles/libffmpegthumbnailer.dir/all' failed
make[1]: *** [CMakeFiles/libffmpegthumbnailer.dir/all] Error 2
Makefile:149: recipe for target 'all' failed
make: *** [all] Error 2
 * ERROR: media-video/ffmpegthumbnailer-2.1.0::gentoo failed (compile phase):
 *   emake failed
 *


Reproducible: Always




Portage 2.2.23 (python 2.7.10-final-0, default/linux/amd64/13.0/desktop, gcc-4.9.3, glibc-2.22-r1, 4.2.4-gentoo x86_64)
=================================================================
System uname: Linux-4.2.4-gentoo-x86_64-Intel-R-_Core-TM-_i7-3740QM_CPU_@_2.70GHz-with-gentoo-2.2
KiB Mem:    24626508 total,  19562800 free
KiB Swap:   26488828 total,  26488828 free
Timestamp of repository gentoo: Sun, 25 Oct 2015 06:30:01 +0000
Timestamp of repository poly-c: Sat, 24 Oct 2015 07:20:05 +0000
sh bash 4.3_p42
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p42::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.22.0::gentoo
dev-lang/python:          2.7.10::gentoo, 3.4.3::gentoo, 3.5.0-r1::gentoo
dev-util/cmake:           3.3.2-r1::gentoo
dev-util/pkgconfig:       0.29::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.18.3::gentoo
sys-apps/sandbox:         2.9::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r1::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.13.4::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.8::gentoo
sys-devel/libtool:        2.4.6-r1::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.2::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r1::gentoo
Repositories:

gentoo
    location: /mnt/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

bitcoin
    location: /mnt/portage/local/layman/bitcoin
    masters: gentoo
    priority: 1

bumblebee
    location: /mnt/portage/local/layman/bumblebee
    masters: gentoo
    priority: 2

dotnet
    location: /mnt/portage/local/layman/dotnet
    masters: gentoo
    priority: 3

poly-c
    location: /mnt/portage/local/layman/poly-c
    masters: gentoo
    priority: 4

steam-overlay
    location: /mnt/portage/local/layman/steam-overlay
    masters: gentoo
    priority: 5

media-overlay
    location: /mnt/portage/local/layman/media-overlay
    masters: gentoo
    priority: 6

dr
    location: /mnt/portage/local/layman/dr
    masters: gentoo
    priority: 7

brother-overlay
    location: /mnt/portage/local/layman/brother-overlay
    masters: gentoo
    priority: 8

lokal
    location: /mnt/portage/local/local-overlay
    masters: gentoo
    priority: 9

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=corei7 -O2 -pipe"
DISTDIR="/mnt/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="C"
LC_ALL=""
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/mnt/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
Comment 1 tman 2015-10-25 09:16:00 UTC
Created attachment 415424 [details]
/mnt/portage/logs/media-video:ffmpegthumbnailer-2.1.0:20151025-074140.log
Comment 2 Alexis Ballier gentoo-dev 2015-11-01 11:58:41 UTC
what version of ffmpeg or libav do you have installed ?
Comment 3 tman 2015-11-07 21:34:29 UTC
[I] media-video/libav
     Available versions:  9.14(0/9)^d 9.17(0/9)^d (~)10.5(0/10)^td **10.9999(0/10)^td 11.3(0/11)^d (~)11.3-r1(0/11)^d **11.9999(0/11)^d **9999(0/12)^d {X aac alsa altivec amr armv5te armv6 armv6t2 armvfp bs2b +bzip2 cdio cpudetection custom-cflags debug doc +encode faac fdk fontconfig frei0r +gpl gsm +hardcoded-tables ieee1394 jack jpeg2k libressl mp3 neon +network openssl opus oss pic pulseaudio rtmp schroedinger sdl speex ssl static-libs test theora threads tools truetype twolame v4l vaapi vdpau vis vorbis vpx wavpack webp x264 x265 xvid +zlib ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32" CPU_FLAGS_X86="3dnow 3dnowext avx avx2 fma3 fma4 mmx mmxext sse sse2 sse3 sse4_1 sse4_2 ssse3 xop"}
     Installed versions:  11.3-r1^d(16:40:22 19.10.2015)(X aac alsa bzip2 encode faac gpl hardcoded-tables ieee1394 jack jpeg2k mp3 network oss pulseaudio schroedinger sdl ssl theora threads tools truetype vaapi vdpau vorbis wavpack x264 xvid zlib -altivec -amr -armv5te -armv6 -armv6t2 -armvfp -bs2b -cdio -cpudetection -custom-cflags -debug -doc -fdk -fontconfig -frei0r -gsm -libressl -neon -openssl -opus -pic -rtmp -speex -static-libs -test -twolame -v4l -vpx -webp -x265 ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32" CPU_FLAGS_X86="mmx sse sse2 sse3 ssse3 -3dnow -3dnowext -avx -avx2 -fma3 -fma4 -mmxext -sse4_1 -sse4_2 -xop")
     Homepage:            https://libav.org/
     Description:
Comment 4 tman 2015-11-18 08:33:59 UTC
any idea to solve this problem??
Comment 5 Gef 2016-01-02 13:47:56 UTC
Here is upstream bug about compiling against latest ffmpeg:
https://github.com/dirkvdb/ffmpegthumbnailer/issues/124
Comment 6 jospezial 2016-01-03 12:45:36 UTC
https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=45ab11f0ed557d140feae5757b55d532fa47a196

Did that patch not cover this bug for libav too?
With this I can compile against latest ffmpeg git.


=================================================================
                        Package Settings
=================================================================

media-video/ffmpegthumbnailer-2.1.0::gentoo was built with the following:
USE="gtk jpeg png -gnome -libav -test" ABI_X86="64"


media-video/ffmpeg-9999::gentoo was built with the following:
USE="X aac aacplus alsa bluray bzip2 cdio encode faac fontconfig gme gnutls gpl gsm hardcoded-tables iconv jack jpeg2k ladspa libass libressl librtmp libv4l lzma modplug mp3 network openal opengl openh264 postproc pulseaudio rubberband schroedinger sdl speex ssh theora threads truetype twolame v4l vaapi vdpau vorbis vpx wavpack webp x264 x265 xcb xvid zlib zvbi (-altivec) -amr -amrenc (-armv5te) (-armv6) (-armv6t2) (-armvfp) -bs2b -celt -chromaprint -cpudetection -debug -doc -examples -fdk -flite -frei0r -fribidi -gcrypt -gmp -iec61883 -ieee1394 -kvazaar -libcaca -libsoxr (-mipsdspr1) (-mipsdspr2) (-mipsfpu) (-mmal) (-neon) -nvenc -openssl -opus -oss -pic -quvi -samba -snappy -static-libs -test -zimg" ABI_X86="32 64 -x32" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 ssse3 -3dnow -3dnowext -aes -avx -avx2 -fma3 -fma4 -sse4_1 -sse4_2 -xop" FFTOOLS="aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart sidxindex trasher"
Comment 7 Brian Dolbec gentoo-dev 2016-01-09 15:38:06 UTC
Same error for me.  media-video/libav-11.3-r1
Comment 8 Brian Dolbec gentoo-dev 2016-01-09 15:39:43 UTC
Created attachment 422398 [details]
trimmed escape sequence free log of the failure
Comment 9 Gef 2016-01-17 21:20:06 UTC
media-video/libav-9.14 to 11.3-r1 doesn't have any reference to av_guess_sample_aspect_ratio anywhere in the source. This function is defined in ffmpeg, in libavformat/utils.c (and libavformat/avformat.h).

Use of av_guess_sample_aspect_ratio was introduced  in ffmpegthumbnailer in commit fe76d8c2c9a5 "Fix `calculateDimensions` for anamorphic streams" for 2.1.0

[1] https://github.com/dirkvdb/ffmpegthumbnailer/commit/fe76d8c2c9a5feb0673e6c117e946f0d513ad4a1
Comment 10 tman 2016-02-23 20:46:06 UTC
same error in version media-video/ffmpegthumbnailer-2.1.1
Comment 11 tman 2016-08-28 17:33:10 UTC
since 2015 reported and still no fixe. could a developer please help here out?
Comment 12 jospezial 2016-08-28 20:54:46 UTC
https://github.com/dirkvdb/ffmpegthumbnailer/releases
ffmpegthumbnailer-2.1.2 and ffmpegthumbnailer-2.2.0 have been released.

Please bump to the tree and then try again.
Comment 13 Pacho Ramos gentoo-dev 2017-01-11 12:17:37 UTC
this is supposedly fixed in 2.2.0... that is in the tree now
Comment 14 Chí-Thanh Christopher Nguyễn gentoo-dev 2017-06-20 00:49:56 UTC
I still see this build error with ffmpegthumbnailer-2.2.0 and libav-11.8

/var/tmp/portage/media-video/ffmpegthumbnailer-2.2.0/work/ffmpegthumbnailer-2.2.0/libffmpegthumbnailer/moviedecoder.cpp: In member function ‘std::__cxx11::string ffmpegthumbnailer::MovieDecoder::createScaleString(int, bool)’:
/var/tmp/portage/media-video/ffmpegthumbnailer-2.2.0/work/ffmpegthumbnailer-2.2.0/libffmpegthumbnailer/moviedecoder.cpp:238:97: error: ‘av_guess_sample_aspect_ratio’ was not declared in this scope
  par = av_guess_sample_aspect_ratio(m_pFormatContext, m_pVideoStream, m_pFrame);
                                                                               ^
/var/tmp/portage/media-video/ffmpegthumbnailer-2.2.0/work/ffmpegthumbnailer-2.2.0/libffmpegthumbnailer/moviedecoder.cpp: In member function ‘void ffmpegthumbnailer::MovieDecoder::initializeFilterGraph(const AVRational&, int, bool)’:
/var/tmp/portage/media-video/ffmpegthumbnailer-2.2.0/work/ffmpegthumbnailer-2.2.0/libffmpegthumbnailer/moviedecoder.cpp:264:20: error: ‘AVBufferSinkParams’ has not been declared
     auto del = [] (AVBufferSinkParams* p) { av_freep(p); };
                    ^
/var/tmp/portage/media-video/ffmpegthumbnailer-2.2.0/work/ffmpegthumbnailer-2.2.0/libffmpegthumbnailer/moviedecoder.cpp:265:21: error: ‘AVBufferSinkParams’ was not declared in this scope
     std::unique_ptr<AVBufferSinkParams, decltype(del)> buffersinkParams(av_buffe
                     ^
/var/tmp/portage/media-video/ffmpegthumbnailer-2.2.0/work/ffmpegthumbnailer-2.2.0/libffmpegthumbnailer/moviedecoder.cpp:265:54: error: template argument 1 is invalid
     std::unique_ptr<AVBufferSinkParams, decltype(del)> buffersinkParams(av_buffe
                                                      ^
/var/tmp/portage/media-video/ffmpegthumbnailer-2.2.0/work/ffmpegthumbnailer-2.2.0/libffmpegthumbnailer/moviedecoder.cpp:265:100: error: ‘av_buffersink_params_alloc’ was not declared in this scope
 rSinkParams, decltype(del)> buffersinkParams(av_buffersink_params_alloc(), del);
                                                                         ^
/var/tmp/portage/media-video/ffmpegthumbnailer-2.2.0/work/ffmpegthumbnailer-2.2.0/libffmpegthumbnailer/moviedecoder.cpp:265:106: error: expression list treated as compound expression in initializer [-fpermissive]
 rSinkParams, decltype(del)> buffersinkParams(av_buffersink_params_alloc(), del);
                                                                               ^
/var/tmp/portage/media-video/ffmpegthumbnailer-2.2.0/work/ffmpegthumbnailer-2.2.0/libffmpegthumbnailer/moviedecoder.cpp:280:21: error: base operand of ‘->’ is not a pointer
     buffersinkParams->pixel_fmts = pixelFormats;
                     ^
/var/tmp/portage/media-video/ffmpegthumbnailer-2.2.0/work/ffmpegthumbnailer-2.2.0/libffmpegthumbnailer/moviedecoder.cpp:281:140: error: request for member ‘get’ in ‘buffersinkParams’, which is of non-class type ‘int’
 by_name("buffersink"), "thumb_buffersink", nullptr, buffersinkParams.get(), m_pF
                                                                      ^
/var/tmp/portage/media-video/ffmpegthumbnailer-2.2.0/work/ffmpegthumbnailer-2.2.0/libffmpegthumbnailer/moviedecoder.cpp:283:22: error: request for member ‘release’ in ‘buffersinkParams’, which is of non-class type ‘int’
     buffersinkParams.release();
                      ^
Comment 15 David Carlos Manuelda 2017-06-21 05:09:33 UTC
I confirm this one, this is becomming pretty old, any easy fix or patch for this?

Using: media-video/libav-12.1:0/12::gentoo  USE="X aac alsa bzip2 encode faac fontconfig gpl hardcoded-tables mp3 network nvidia opus schroedinger speex ssl theora threads tools truetype vaapi vdpau vorbis vpx webp x264 xvid zlib (-altivec) -amr (-armv5te) (-armv6) (-armv6t2) (-armvfp) -bs2b -cdio -cpudetection -custom-cflags -debug -doc -fdk -frei0r -gsm -ieee1394 -jack -jpeg2k -libressl (-neon) -openssl -oss -pic -pulseaudio -rtmp -sdl -static-libs {-test} -twolame -v4l -wavpack -x265" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="avx avx2 fma3 mmx mmxext sse sse2 sse3 sse4_1 sse4_2 ssse3 -3dnow -3dnowext -fma4 -xop"
Comment 16 Chí-Thanh Christopher Nguyễn gentoo-dev 2017-06-21 09:33:38 UTC
The problems building against libav were introduced in these commits:

https://github.com/dirkvdb/ffmpegthumbnailer/commit/a2a98bc5a5d809105586f3b6f33fa45ba80dc3fa#diff-08f3c799b441618d88382e5894e15181
https://github.com/dirkvdb/ffmpegthumbnailer/commit/fbb0b4ab55c3ee01e8290d9a57ce296d26eb0cc2

libav does not provide the AVBufferSinkParams struct or the av_guess_sample_aspect_ratio function. So I don't see any easy solution except reverting these depending on USE="libav".
Comment 17 Andreas Sturmlechner gentoo-dev 2019-06-12 10:24:56 UTC
*** Bug 654354 has been marked as a duplicate of this bug. ***
Comment 18 Dominique Michel 2019-09-03 08:37:13 UTC
Still not fixed. That's very annoying because I am in the middle of a world update. For that update to work, portage was not able to find a solution with USE="ffmpeg", which imply I shifted to USE="libav" and ffmpegthumbnailer just doesn't compile with it. Which in its turn imply I am stuck.
Comment 19 Dominique Michel 2019-09-03 10:20:48 UTC
(In reply to Chí-Thanh Christopher Nguyễn from comment #16)
> The problems building against libav were introduced in these commits:
> 
> https://github.com/dirkvdb/ffmpegthumbnailer/commit/
> a2a98bc5a5d809105586f3b6f33fa45ba80dc3fa#diff-
> 08f3c799b441618d88382e5894e15181
> https://github.com/dirkvdb/ffmpegthumbnailer/commit/
> fbb0b4ab55c3ee01e8290d9a57ce296d26eb0cc2
> 
> libav does not provide the AVBufferSinkParams struct or the
> av_guess_sample_aspect_ratio function. So I don't see any easy solution
> except reverting these depending on USE="libav".

ffmpeg upstream depend on ffmpeg. That imply the real problem is libav that doesn't provide these struct and function. Do you know if libav upstream is aware of that?
Comment 20 Larry the Git Cow gentoo-dev 2020-04-26 15:23:09 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ae1063b59ef317fdc6dd640b60437f6fb143a2ac

commit ae1063b59ef317fdc6dd640b60437f6fb143a2ac
Author:     Mikle Kolyada <zlogene@gentoo.org>
AuthorDate: 2020-04-26 15:14:48 +0000
Commit:     Mikle Kolyada <zlogene@gentoo.org>
CommitDate: 2020-04-26 15:22:46 +0000

    media-video/libav: remove last-rited pkg
    
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=452482
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=458768
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=470764
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=499256
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=509974
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=519602
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=525070
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=555114
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=564040
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=587054
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=588986
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=701952
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=538790
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=711206
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=489922
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=409957
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=445854
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=474408
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=509294
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=522350
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=546080
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=588482
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=603726
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=694082
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=634102
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=542186
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=635524
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=651218
    Closes: https://bugs.gentoo.org/show_bug.cgi?id=651220
    
    Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>

 media-video/libav/Manifest                    |   3 -
 media-video/libav/files/libav-12.3-x264.patch |  85 -------
 media-video/libav/libav-12.3.ebuild           | 350 --------------------------
 media-video/libav/libav-13_pre20171219.ebuild | 336 -------------------------
 media-video/libav/libav-9999.ebuild           | 339 -------------------------
 media-video/libav/metadata.xml                |  35 ---
 6 files changed, 1148 deletions(-)