Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 563754 - Cannot cross-compile GCC 5.2 for arm or avr
Summary: Cannot cross-compile GCC 5.2 for arm or avr
Status: RESOLVED DUPLICATE of bug 562460
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-22 07:50 UTC by Xavier Miller
Modified: 2015-11-23 10:56 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build logs for cross-armv6j-hardfloat-linux-gnueabi/gcc-5.2.0 (gcc-build-logs.tar.bz2,96.16 KB, application/x-bzip2)
2015-10-22 07:54 UTC, Xavier Miller
Details
build logs for cross-avr/gcc-5.2.0 (gcc-build-logs.tar.bz2,92.49 KB, application/x-bzip2)
2015-10-22 07:56 UTC, Xavier Miller
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xavier Miller gentoo-dev 2015-10-22 07:50:59 UTC
Hello,

I've unmasked gcc 5.2 for all my platforms, and want to cross-emerge gcc-5.2 for arm or avr, ending with the same error:

AVR:
checking for avr-gcc... /var/tmp/portage/cross-avr/gcc-5.2.0/work/build/./gcc/xgcc -B/var/tmp/portage/cross-avr/gcc-5.2.0/work/build/./gcc/ -B/usr/avr/bin/ -B/usr/avr/lib/ -isystem /usr/avr/include -isystem /usr/avr/sys-include
checking for suffix of object files... configure: error: in `/var/tmp/portage/cross-avr/gcc-5.2.0/work/build/avr/libgcc':
configure: error: cannot compute suffix of object files: cannot compile
See `config.log' for more details.
libtool: link: x86_64-gentoo-linux-gnu-g++  -fPIC -DPIC -shared -nostdlib /usr/lib/gcc/x86_64-gentoo-linux-gnu/5.2.0/../../../../lib64/crti.o /usr/lib/gcc/x86_64-gentoo-linux-gnu/5.2.0/crtbeginS.o  .libs/findcomp.o .libs/libcc1.o .libs/names.o .libs/callbacks.o .libs/connection.o .libs/marshall.o   -Wl,--as-needed -L/usr/lib/gcc/x86_64-gentoo-linux-gnu/5.2.0 -L/usr/lib/gcc/x86_64-gentoo-linux-gnu/5.2.0/../../../../lib64 -L/lib/../lib64 -L/usr/lib/../lib64 -L/usr/lib/gcc/x86_64-gentoo-linux-gnu/5.2.0/../../../../x86_64-gentoo-linux-gnu/lib -L/usr/lib/gcc/x86_64-gentoo-linux-gnu/5.2.0/../../.. -lstdc++ -lm -lc -lgcc_s /usr/lib/gcc/x86_64-gentoo-linux-gnu/5.2.0/crtendS.o /usr/lib/gcc/x86_64-gentoo-linux-gnu/5.2.0/../../../../lib64/crtn.o  -static-libstdc++ -static-libgcc -Wl,-O1 -Wl,--sort-common -Wl,--hash-style=gnu ../libiberty/pic/libiberty.a   -Wl,-soname -Wl,libcc1.so.0 -Wl,-retain-symbols-file -Wl,/var/tmp/portage/cross-avr/gcc-5.2.0/work/gcc-5.2.0/libcc1/libcc1.sym -o .libs/libcc1.so.0.0.0
Makefile:10598: recipe for target 'configure-target-libgcc' failed

ARM:
checking for suffix of object files... configure: error: in `/var/tmp/portage/cross-armv6j-hardfloat-linux-gnueabi/gcc-5.2.0/work/build/armv6j-hardfloat-linux-gnueabi/libgcc':
configure: error: cannot compute suffix of object files: cannot compile
See `config.log' for more details.
Makefile:10599: recipe for target 'configure-target-libgcc' failed
make[1]: *** [configure-target-libgcc] Error 1
make[1]: *** Waiting for unfinished jobs....




Reproducible: Always




Portage 2.2.23 (python 2.7.10-final-0, default/linux/amd64/13.0, gcc-5.2.0, glibc-2.22-r1, 4.2.3-gentoo x86_64)
=================================================================
System uname: Linux-4.2.3-gentoo-x86_64-Intel-R-_Core-TM-_i5-4200U_CPU_@_1.60GHz-with-gentoo-2.2
KiB Mem:     8082640 total,   3908224 free
KiB Swap:    2097148 total,   2097148 free
Timestamp of repository gentoo: Wed, 21 Oct 2015 18:00:01 +0000
sh bash 4.3_p42
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
distcc 3.2rc1 x86_64-gentoo-linux-gnu [disabled]
app-shells/bash:          4.3_p42::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.22.0::gentoo
dev-lang/python:          2.7.10::gentoo
dev-util/cmake:           3.3.2-r1::gentoo
dev-util/pkgconfig:       0.29::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.18.3::gentoo
sys-apps/sandbox:         2.9::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r1::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.13.4::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            5.2.0::gentoo
sys-devel/gcc-config:     1.8::gentoo
sys-devel/libtool:        2.4.6-r1::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.2::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: git://anongit.gentoo.org/repo/gentoo.git
    priority: -1000

local
    location: /usr/local/portage/overlay
    masters: gentoo proaudio
    priority: 0

proaudio
    location: /var/lib/layman/proaudio
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="@FREE as-is freedist"
CBUILD="x86_64-gentoo-linux-gnu"
CFLAGS="-O2 -pipe -fomit-frame-pointer -march=native -mtune=native"
CHOST="x86_64-gentoo-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -fomit-frame-pointer -march=native -mtune=native"
DISTDIR="/var/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y --quiet-build=n"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs candy config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/"
LANG="fr_BE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--hash-style=gnu -Wl,--as-needed"
MAKEOPTS="-j7 -l5"
PKGDIR="/var/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="3dnow 3dnowext X a52 aac acpi alsa amd64 apng branding bzip2 cairo cdda cddb cdio cli cracklib crypt cryptsetup cups cxx dbus dlna dri dssi dts dvb dvd exif flac gif gpm gtk gudev iconv jack jpeg lcms libcanberra libnotify libsamplerate mad mmx mmxext mng modules mp3 mpeg multilib natspec ncurses nls nptl ocr ogg opengl openmp osc pam pango pcre pdf png qt4 qt5 readline rubberband sane scanner sdl seccomp session sna sndfile snmp spell sqlite sse sse2 ssl startup-notification svg tcpd threads tiff truetype udev unicode upnp upower usb uxa vorbis wmf x264 xattr xcb xinerama xml xosd xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="ice1712 hda-intel usb-audio virmidi" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" DVB_CARDS="usb-af9015" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="fr fr_BE fr_FR nl nl_BE" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby22" SANE_BACKENDS="hp" USERLAND="GNU" VIDEO_CARDS="intel i965" XFCE_PLUGINS="power brightness trash" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Xavier Miller gentoo-dev 2015-10-22 07:51:23 UTC
crossdev works fine for target i686-gentoo-linux-gnu
Comment 2 Xavier Miller gentoo-dev 2015-10-22 07:54:26 UTC
Created attachment 415142 [details]
build logs for cross-armv6j-hardfloat-linux-gnueabi/gcc-5.2.0
Comment 3 Xavier Miller gentoo-dev 2015-10-22 07:56:00 UTC
Created attachment 415144 [details]
build logs for cross-avr/gcc-5.2.0
Comment 4 Alexander Tsoy 2015-10-22 20:42:55 UTC
Probably a dupe of bug 562460
Comment 5 Xavier Miller gentoo-dev 2015-10-23 07:07:21 UTC
yeah, could be
Comment 6 SpanKY gentoo-dev 2015-11-23 10:56:16 UTC
assuming this is bug 562460.  you should:
- sync
- update binutils-config to latest
- reset the build, e.g. `crossdev -C target`
- try again

if it still fails, re-open with new logs

*** This bug has been marked as a duplicate of bug 562460 ***