Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 56372 - Out of memory while running bogoupgrade
Summary: Out of memory while running bogoupgrade
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Net-Mail Packages
Depends on:
Reported: 2004-07-07 13:48 UTC by Peter Kerwien
Modified: 2004-12-08 00:48 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Peter Kerwien 2004-07-07 13:48:53 UTC
When upgrading from bogofilter to 0.91.1, I tried to convert my spamlist.db and goodlist.db with:

bogoupgrade -d ~/.bogofilter

After a while all memory was consumed and my server became hard to contact. I had to kill the bogoupgrade process.

I don't know how large files bogoupgrade should be able to handle. In my case I have a goodlist.db of approx. 828kB and a spamlist.db of 4MB.

Reproducible: Always
Steps to Reproduce:

Actual Results:  
All physical memory and swap space are consumed by the bogoupgrade process.

I have also tried with bogofilter 0.92.2 but it also "crashed" after a while.

$ emerge info

Portage 2.0.50-r8 (default-x86-1.4, gcc-3.3.3, glibc-, 2.6.7-2)
System uname: 2.6.7-2 i686 Pentium III (Coppermine)
Gentoo Base System version 1.4.16
distcc 2.13 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
Autoconf: sys-devel/autoconf-2.59-r3
Automake: sys-devel/automake-1.8.3
CFLAGS="-march=pentium3 -O2 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.2/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref
/usr/share/config /var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium3 -O2 -pipe -fomit-frame-pointer"
FEATURES="autoaddcvs ccache sandbox"
USE="X apache2 arts avi berkdb cdr crypt cups encode esd foomaticdb gdbm gif gpm
gtk gtk2 imap imlib java jpeg kde libg++ libwww mad mikmod motif mozilla mpeg
mysql ncurses nls oggvorbis opengl oss pam pdflib perl png python qt quicktime
readline samba sdl slang spell ssl svga tcltk tcpd truetype x86 xml2 xmms xv zlib"
Comment 1 Peter Kerwien 2004-07-07 21:53:07 UTC

I have also tried with bogofilter 0.92.2 but it also "crashed" after a while.

Should be:

I have also tried with bogofilter 0.92.1 but it also "crashed" after a while.
Comment 2 Michaela Susan Buesing 2004-11-18 12:56:03 UTC
This bug is a real pain in the ass. 2 GB of physical and 4 GB of swap memory are not enough to convert two files of 7.1 and 34 MB. My well-trained database is rendered unseless. :( Can anybody (the package maintainer?) forwarded this upstream? I use bogofilter version 0.92.8 .
Comment 3 Torsten Veller (RETIRED) gentoo-dev 2004-12-05 03:33:00 UTC
Are you able to verify that your old databases weren't corrupted?

What's the output of "bogofilter -V" before and after upgrading?
Comment 4 Torsten Veller (RETIRED) gentoo-dev 2004-12-05 03:40:15 UTC
Remember: gentoo systems use a renamed db_verify command: db<version>_verify (db4.1_verify)
Comment 5 Peter Kerwien 2004-12-07 22:15:32 UTC
OK, my old database seems to be corrupt:

server1 .bogofilter.copy # db4_verify spamlist.db
db_verify: Out-of-order key, page 719 item 57
db_verify: First item on page 660 sorted greater than parent entry
db_verify: Page 660 linked twice
db_verify: DB->verify: spamlist.db: DB_VERIFY_BAD: Database verification failed

It's ok for me to cancel / close this report because it is rather old. I don't suffer from this anymore since I started on a new fresh database. It might be my corrupted database that caused the problem.
Comment 6 Torsten Veller (RETIRED) gentoo-dev 2004-12-08 00:48:23 UTC
Thanks Peter - great that you were still able to test it after this long time. Sorry for the delay.
I will close this bug-report.

Michaela, if your database were not corrupted, please add a comment.