Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 563540 - app-text/libspectre-0.2.7 with app-text/ghostscript-gpl-9.18 - /usr/include/ghostscript/ierrors.h:22:22: fatal error: gserrors.h: No such file or directory
Summary: app-text/libspectre-0.2.7 with app-text/ghostscript-gpl-9.18 - /usr/include/g...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Printing (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Printing Team
Depends on:
Blocks: 545274
  Show dependency tree
Reported: 2015-10-20 05:06 UTC by iGentoo
Modified: 2016-02-11 23:39 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---

libspectre-0.2.7-build.log (libspectre-0.2.7-build.log,14.68 KB, text/plain)
2015-10-20 05:06 UTC, iGentoo

Note You need to log in before you can comment on or make changes to this bug.
Description iGentoo 2015-10-20 05:06:29 UTC
Created attachment 414950 [details]

libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -I.. -I. -I.. -Wall -Wextra -Wsign-compare -Werror-implicit-function-declaration -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wpacked -Wswitch-enum -Wstrict-aliasing=2 -Winit-self -Wunsafe-loop-optimizations -Wdeclaration-after-statement -Wno-missing-field-initializers -Wno-unused-parameter -Wno-attributes -Wno-long-long -Winline -Wall -march=native -O2 -pipe -frecord-gcc-switches -c spectre-document.c  -fPIC -DPIC -o .libs/libspectre_la-spectre-document.o
/bin/bash ../libtool  --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..    -I.. -I. -I.. -Wall -Wextra -Wsign-compare -Werror-implicit-function-declaration -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wpacked -Wswitch-enum -Wstrict-aliasing=2 -Winit-self -Wunsafe-loop-optimizations -Wdeclaration-after-statement -Wno-missing-field-initializers -Wno-unused-parameter -Wno-attributes -Wno-long-long -Winline -Wall -march=native -O2 -pipe -frecord-gcc-switches -c -o libspectre_la-spectre-gs.lo `test -f 'spectre-gs.c' || echo './'`spectre-gs.c
libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -I.. -I. -I.. -Wall -Wextra -Wsign-compare -Werror-implicit-function-declaration -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wpacked -Wswitch-enum -Wstrict-aliasing=2 -Winit-self -Wunsafe-loop-optimizations -Wdeclaration-after-statement -Wno-missing-field-initializers -Wno-unused-parameter -Wno-attributes -Wno-long-long -Winline -Wall -march=native -O2 -pipe -frecord-gcc-switches -c spectre-gs.c  -fPIC -DPIC -o .libs/libspectre_la-spectre-gs.o
In file included from spectre-gs.c:30:0:
/usr/include/ghostscript/ierrors.h:22:22: fatal error: gserrors.h: No such file or directory
compilation terminated.
Makefile:529: recipe for target 'libspectre_la-spectre-gs.lo' failed
make[2]: *** [libspectre_la-spectre-gs.lo] Error 1

Portage 2.2.23 (python 3.5.0-final-0, default/linux/amd64/13.0, gcc-5.2.0, glibc-2.22-r1, 4.2.3-hardened-r4.x86_64 x86_64)
                         System Settings
System uname: Linux-4.2.3-hardened-r4.x86_64-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9300_@_2.50GHz-with-gentoo-2.2
KiB Mem:     6116272 total,    504912 free
KiB Swap:   18873332 total,  18676556 free
sh dash
ld GNU gold (Gentoo 2.25.1 p1.1 2.25.1) 1.11
ccache version 3.2.4 [disabled]
app-shells/bash:          4.4_beta::gentoo
dev-lang/perl:            5.22.0::gentoo
dev-lang/python:          2.7.10-r2::gentoo, 3.4.3-r2::gentoo, 3.5.0-r1::local-repo
dev-util/ccache:          3.2.4::gentoo
dev-util/cmake:           3.3.2-r1::gentoo
dev-util/pkgconfig:       0.29::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/sandbox:         2.9::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r1::gentoo
sys-devel/automake:       1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            5.2.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r1::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.2::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r1::gentoo

    location: /usr/portage
    sync-type: git
    sync-uri: git://
    priority: -1000
    eclass-overrides: local-repo

    location: /usr/local/portage
    masters: gentoo

Installed sets: @local
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-Wall -march=native -O2 -pipe -frecord-gcc-switches"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-Wall -march=native -O2 -pipe -frecord-gcc-switches"
EMERGE_DEFAULT_OPTS="--color=n --oneshot"
FCFLAGS="-Wall -march=native -O2 -pipe -frecord-gcc-switches"
FEATURES="assume-digests binpkg-logs buildpkg collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync metadata-transfer multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms split-log strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync webrsync-gpg xattr"
FFLAGS="-Wall -march=native -O2 -pipe -frecord-gcc-switches"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="V=1 -j9"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X acl amd64 audit berkdb bzip2 cli cracklib crypt cxx dbus dri egl fortran gdbm iconv icu ipv6 jpeg mmx mmxext modules multilib ncurses nls nptl opengl openmp pam pax_kernel pcre pic png policykit pulseaudio readline seccomp session sse sse2 ssl systemd tcpd unicode vdpau vim-syntax wayland xattr zlib" ABI_X86="64 32 x32" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 sse4_1 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US zh zh_CN" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_4 python3_5" RUBY_TARGETS="ruby22" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

                        Package Settings

app-text/libspectre-0.2.7::gentoo was built with the following:
USE="-debug -doc -static-libs"

app-text/ghostscript-gpl-9.18::gentoo was built with the following:
USE="X cups dbus -djvu -gtk -idn -static-libs" ABI_X86="64" LINGUAS="zh_CN -de -ja -ko -zh_TW"
Comment 1 Felix Janda 2015-10-20 17:36:47 UTC
Looks like an upstream regression in Ghostscript 9.18. As documented in users of the library should
be able to use <ghostscript/ierrors.h>, but that now uses the
Ghostscript-internal "gserrors.h" header (not installed). I cannot find
a corresponding bug at
Comment 2 David Brooke 2015-10-21 12:09:17 UTC
I'm having the same issue during initial install of Gentoo ~amd64.
Comment 3 Greg Turner 2015-10-22 09:48:58 UTC
Also appears to break app-test/dvisvgm-1.10
Comment 4 Matt Hartley 2015-10-22 23:28:12 UTC
this bug does effect app-test/dvigsm-1.10
Comment 5 Justin Lecher (RETIRED) gentoo-dev 2015-10-23 09:15:24 UTC
And even if installed manually I see

spectre-gs.c: In function ‘critic_error_code’:
spectre-gs.c:46:9: error: ‘e_Fatal’ undeclared (first use in this function)
    case e_Fatal:
spectre-gs.c:46:9: note: each undeclared identifier is reported only once for each function it appears in
spectre-gs.c:51:9: error: ‘e_ExecStackUnderflow’ undeclared (first use in this function)
    case e_ExecStackUnderflow:
spectre-gs.c: In function ‘spectre_gs_process’:
spectre-gs.c:112:20: error: ‘e_NeedInput’ undeclared (first use in this function)
   error = error == e_NeedInput ? 0 : error;
Makefile:529: recipe for target 'libspectre_la-spectre-gs.lo' failed
make[2]: *** [libspectre_la-spectre-gs.lo] Error 1
Comment 6 Justin Lecher (RETIRED) gentoo-dev 2015-10-23 09:24:40 UTC
commit 4734becd864d032c88253ea299ad9db99926ea89
Author: Justin Lecher <>
Date:   Fri Oct 23 11:16:31 2015 +0200
    profiles: mask app-text/ghostscript-gpl-9.18 due to breaking changes
    Signed-off-by: Justin Lecher <>
Comment 7 Justin Lecher (RETIRED) gentoo-dev 2015-10-23 10:00:21 UTC
commit 496566c75f483786d581f34196309bc4becb2481
Author: Justin Lecher <>
Date:   Fri Oct 23 11:59:51 2015 +0200
    app-text/ghostscript-gpl: Backport fix for missing header
    Package-Manager: portage-2.2.23
    Signed-off-by: Justin Lecher <>
Comment 8 Justin Lecher (RETIRED) gentoo-dev 2015-10-23 10:00:33 UTC
commit 4734becd864d032c88253ea299ad9db99926ea89
Author: Justin Lecher <>
Date:   Fri Oct 23 11:16:31 2015 +0200
    profiles: mask app-text/ghostscript-gpl-9.18 due to breaking changes
    Signed-off-by: Justin Lecher <>
Comment 9 John Bytheway 2015-10-24 01:23:50 UTC
I have media-gfx/graphviz-2.38.0 failing to build with the same error.
Comment 10 Ryan Hill (RETIRED) gentoo-dev 2015-10-31 06:53:29 UTC
Is there a reason this is still masked?
Comment 11 Jonas Stein gentoo-dev 2016-01-28 22:58:53 UTC
I commented out the rm zlib line in ghostscript-gpl/ghostscript-gpl-9.18.ebuild
and recompiled. This workaround seems to solve the zlib problem. Then I tried to reproduce #563540, but app-text/libspectre-0.2.7 compiled (with warnings, but no errors).
Comment 12 Arfrever Frehtes Taifersar Arahesis 2016-02-11 23:39:40 UTC
app-text/libspectre was fixed in:

commit 8d34151aea08aa04cca35e1f5da59445af0440d0
Author: Lars Wendler <>
Date:   Fri Oct 23 15:25:42 2015 +0200

    app-text/libspectre: >=app-text/ghostscript-gpl-9.18 compile fix
    (bug #563540).