Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 562394 - =media-libs/libass-0.13.0: update blockers as enca USE was dropped
Summary: =media-libs/libass-0.13.0: update blockers as enca USE was dropped
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 565420 568370 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-10-06 12:06 UTC by Coacher
Modified: 2015-12-28 13:53 UTC (History)
16 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Coacher 2015-10-06 12:06:59 UTC
Hello.

media-libs/libass-0.13.0 has dropped 'enca' USE, which is included in deps at least for mplayer-1.2 and mpv-0.11.0.

Please either restore 'enca' USE, or adjust libass deps across the tree accordingly.
Comment 1 jospezial 2015-10-06 19:36:41 UTC
https://github.com/libass/libass/releases/tag/0.13.0

"Drop ENCA support"

Will MPV drop enca too?
Comment 2 Coacher 2015-10-08 10:12:22 UTC
media-video/mplayer-1.2-r1 has libass dependency adjusted wrt this issue.
Comment 3 Coacher 2015-10-09 17:57:15 UTC
There was an attempt to fix media-video/mpv-0.11.0 libass dependency as well [0].
But I believe it went wrong and libass dependency should be adjusted to:

>=media-libs/libass-0.12.1:=[enca(+)?,fontconfig]

Notice use dependency default changed to enca(+). Otherwise it is impossible to install >=media-libs/libass-0.13.0 and >=media-video/mpv-0.11.0[enca] simultaneously.

[0]: https://gitweb.gentoo.org/repo/gentoo.git/commit/media-video/mpv?id=d3a0ebbed071c3ae4fd31cea80f6f028041c7708
Comment 4 Alexandre Rostovtsev (RETIRED) gentoo-dev 2015-10-10 02:38:00 UTC
CC-ing mpv and libass maintainers.

Is libass[enca] really required for mpv[enca]?

Because I don't see any checks for that in mpv-0.11.0 wscript. And building libass with/without enca support doesn't change libass's public headers in any way, so it's not clear why that dependency would be needed by mpv's code.
Comment 5 Coacher 2015-10-11 21:19:42 UTC
(In reply to Coacher from comment #3)
> There was an attempt to fix media-video/mpv-0.11.0 libass dependency as well
> [0].
> But I believe it went wrong and libass dependency should be adjusted to:
> 
> >=media-libs/libass-0.12.1:=[enca(+)?,fontconfig]
> 
> Notice use dependency default changed to enca(+). Otherwise it is impossible
> to install >=media-libs/libass-0.13.0 and >=media-video/mpv-0.11.0[enca]
> simultaneously.
> 
> [0]:
> https://gitweb.gentoo.org/repo/gentoo.git/commit/media-video/
> mpv?id=d3a0ebbed071c3ae4fd31cea80f6f028041c7708

Works fine with this change on my amd64 machine.
Comment 6 Radoslaw Szkodzinski 2015-10-23 02:43:14 UTC
Confirmed with mpv devs (lachs0r) on IRC that mpv does not require libass with enca enabled for its own enca support to work.
Comment 7 Lorenzo Porta (Vindex17) 2015-11-02 10:01:11 UTC
https://github.com/gentoo/gentoo/pull/318
Comment 8 Dennis Schridde 2015-11-11 08:20:13 UTC
*** Bug 565420 has been marked as a duplicate of this bug. ***
Comment 9 jospezial 2015-11-12 18:12:25 UTC
https://github.com/mpv-player/mpv/commit/384b13c5fd3fa87bad4bedbb3db369cdfb05de2b

" demux_libass: remove this demuxer

This loaded external .ass files via libass. libavformat's .ass reader is
now good enough, so use that instead.

Apparently libavformat still doesn't support fonts embedded into text
.ass files, but support for this has been accidentally broken in mpv for
a while anyway. (And only 1 person complained.) "


This commit is not included in mpv 0.13.0 release.
Comment 10 Dennis Schridde 2015-11-23 23:05:58 UTC
(In reply to jospezial from comment #9)
> https://github.com/mpv-player/mpv/commit/
> 384b13c5fd3fa87bad4bedbb3db369cdfb05de2b
> 
> This commit is not included in mpv 0.13.0 release.

Can this commit be backported into media-video/mpv-0.13.0?

See-Also: https://bugs.gentoo.org/show_bug.cgi?id=564656
Comment 11 Coacher 2015-12-22 21:22:03 UTC
*** Bug 568370 has been marked as a duplicate of this bug. ***
Comment 12 Coacher 2015-12-28 13:53:46 UTC
commit 85ad9a8c6518f2db5cbd2d050b3e4052e4254f40
Author: Ilya Tumaykin <itumaykin@gmail.com>
Date:   Tue Dec 22 20:59:38 2015 +0300

    media-video/mpv: adjust required libass USE flags wrt bug 562394

    mpv uses libass to render subtitles and enca to detect subtitle
    encoding. For mpv to support enca, mpv does not need to have
    libass[enca]. This helps to avoid problems with >=libass-0.13.0,
    which dropped 'enca' USE.

    Also enable harfbuzz USE to support subtitles for complex languages.

    See [0] as a reference for both of the above.

    [0]: https://github.com/mpv-player/mpv/blob/master/DOCS/man/options.rst

    Gentoo-Bug: 562394

    Package-Manager: portage-2.2.24


This fix is included in mpv versions 0.11.0-r1, 0.14.0, 9999.

Closing as fixed.