Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 561898 - virtual/libiconv should have static-libs USE flag?
Summary: virtual/libiconv should have static-libs USE flag?
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo non-Linux Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-30 10:42 UTC by Julian Ospald
Modified: 2015-09-30 13:02 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Julian Ospald 2015-09-30 10:42:42 UTC
in order to propagate it to dev-libs/libiconv, no?

I'm not sure what the state of the various libc providers is and if they even consistently provide static libs, but there somehow should be a way to properly do this.
Comment 1 Alexis Ballier gentoo-dev 2015-09-30 13:02:49 UTC
(In reply to Julian Ospald (hasufell) from comment #0)
> in order to propagate it to dev-libs/libiconv, no?

+1

> I'm not sure what the state of the various libc providers is and if they
> even consistently provide static libs, but there somehow should be a way to
> properly do this.

IMHO static-libs on libc, or any @system package, is a worm can: unless you want to kill implicit system deps, you can't [static-libs] usedep on them, so better always install them. Also, this'd prevent 'gcc -static' from working, since '-lc' is implicit and always passed to ld when linking; we also have packages building static binaries (busybox comes to mind) and thus relying on static libc.a.