Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 561720 - net-ftp/atftp: fails with gcc-5: argz.c:44:8: error: redefinition of 'argz_next'
Summary: net-ftp/atftp: fails with gcc-5: argz.c:44:8: error: redefinition of 'argz_next'
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Tobias Klausmann
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-5
  Show dependency tree
 
Reported: 2015-09-28 10:56 UTC by Manfred Knick
Modified: 2016-01-13 23:23 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/tmp/portage/net-ftp/atftp-0.7-r3/temp/build.log (build.log,10.42 KB, text/x-log)
2015-09-28 10:57 UTC, Manfred Knick
Details
emerge --info '=net-ftp/atftp-0.7-r3::gentoo' (ei0,5.82 KB, text/plain)
2015-09-28 10:58 UTC, Manfred Knick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Manfred Knick 2015-09-28 10:56:21 UTC
net-ftp/atftp-0.7-r3
builds with sys-devel/gcc-4.9.3,
but fails with sys-devel/gcc-5.2.0.

Reproducible: Always
Comment 1 Manfred Knick 2015-09-28 10:57:02 UTC
Created attachment 413142 [details]
/var/tmp/portage/net-ftp/atftp-0.7-r3/temp/build.log
Comment 2 Manfred Knick 2015-09-28 10:58:34 UTC
Created attachment 413144 [details]
emerge --info '=net-ftp/atftp-0.7-r3::gentoo'
Comment 3 Manfred Knick 2015-09-28 10:59:05 UTC
emerge -pqv '=net-ftp/atftp-0.7-r3::gentoo'

[ebuild   R   ] net-ftp/atftp-0.7-r3  USE="pcre readline tcpd (-selinux)"
Comment 4 Ted Tanberry 2015-12-06 21:54:50 UTC
--- /usr/portage/net-ftp/atftp/atftp-0.7-r3.ebuild
+++ /usr/portage/net-ftp/atftp/atftp-0.7-r3.ebuild
@@ -43,6 +43,7 @@
 
 src_configure() {
 	append-flags -D_REENTRANT -DRATE_CONTROL
+	append-cflags -std=gnu89
 	econf \
 		$(use_enable tcpd libwrap) \
 		$(use_enable readline libreadline) \
Comment 5 Pacho Ramos gentoo-dev 2015-12-25 11:23:25 UTC
wasn't this caused by missing emerge -e world after gcc5 update?
Comment 6 Kobboi 2015-12-25 11:45:08 UTC
(In reply to Pacho Ramos from comment #5)
> wasn't this caused by missing emerge -e world after gcc5 update?

I don't think so. I have the same problem (gcc5 upgrade Dec 14, every package since then re-emerged, except a list of bugs)

2015-12-13 14:24:04 | net-dialup/rp-l2tp:0
2015-12-09 07:09:54 | net-ftp/atftp:0
2015-12-09 04:43:50 | media-video/aegisub:0
2015-12-09 00:53:45 | app-editors/latexila:0
2015-12-08 10:58:31 | net-wireless/spectools:0
2015-12-08 09:22:23 | media-video/lives:0
2015-12-08 07:30:16 | sys-apps/paludis:0
2015-12-08 05:59:41 | media-video/ushare:0
2015-11-22 23:37:48 | mate-base/mate-applets:0
2015-11-14 17:06:20 | games-emulation/visualboyadvance:0
2015-09-27 19:20:41 | sci-geosciences/qlandkartegt:0
2015-03-16 19:44:15 | mate-extra/mate-system-monitor:0
Comment 7 Manfred Knick 2015-12-25 12:49:39 UTC
(In reply to Pacho Ramos from comment #5)
> wasn't this caused by missing emerge -e world after gcc5 update?

It exactly arouse via "emerge -e world" after gcc5 update.
Comment 8 Ted Tanberry 2015-12-26 08:00:46 UTC
emerge -e world is only required to fix C++ programs, this is a pure C issue. Please apply my patch.
Comment 9 David Seifert gentoo-dev 2016-01-13 23:23:21 UTC
commit be0efa82bf9cf003c7138a8bf89e636e540c4e0b
Author: David Seifert <soap@gentoo.org>
Date:   Thu Jan 14 00:06:49 2016 +0100

    net-ftp/atftp: add -std=gnu89 to CFLAGS to restore pre-GCC5 semantics
    
    Gentoo-Bug: 561720
    Revbump to fix missing ':0=' slot operator on sys-libs/readline.