Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 560650 - x11-drivers/nvidia-drivers - crash with qemu vfio from another card
Summary: x11-drivers/nvidia-drivers - crash with qemu vfio from another card
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Jeroen Roovers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-16 17:07 UTC by zlice
Modified: 2019-12-19 22:58 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zlice 2015-09-16 17:07:01 UTC
built a new machine, been nothing but hell. finally everything 'works' - but nvidia-drivers seem to force a hard shutdown with no warning or log of any sort that i can find

system setup:
evga x99 ftw motherboard
nvidia card (tried a couple, both need the same driver, same age but diff line of card)
new amd card for VM
intel CPU with iommu / vt-d vt-x

corrupted drive a few times - have tried multiple drives to make sure that wasn't it (PCI Ex ssd and sata)

what i have tried:
1. nouveau (incredibly slow start up, doubles time to 'boot' and log in)
   ^does NOT freeze machine
2. patches for newer kernels - need <3.19 for nvidia 340.93
   (see https://forums.gentoo.org/viewtopic-t-1014974.html)
   ^freezes machine still
3. older drives with patches (340.76 does not compile, 304.128 does)
   ^freezes machine still

i'm not sure what's causing it - vfio? qemu? motherboard/bios?

at this point i may have to stick with nouveau

just wanted to put this out there

Reproducible: Always

Steps to Reproduce:
steps:
1. boot
2. run qemu-system-x86_64 ---- vfio link AMD card with romfile
(see https://bbs.archlinux.org/viewtopic.php?id=162768)
3. shutdown VM
4. try to shutdown real machine (or switch to term with CTRL+ALT+#) and it completely freezes the machine - black screen - have to hold power down


Actual Results:  
completey system freeze

Expected Results:  
graceful shutdown
Comment 1 zlice 2019-01-26 20:01:30 UTC
got an email on this. go ahead and close it, haven't even used that machine in a while (it's in storage right now) and i highly doubt it's an issue for most people or going to get fixed