Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 557590 - <www-client/firefox{,-bin}-{38.2,40.0}, <mail-client/thunderbird{,-bin}-38.2: Multiple vulnerabilities {CVE-2015-(4473,4474,4475,4477,4478,4479,4480,4481,4482,4483,4484,4485,4486,4487,4488,4489,4490,4491,4492,4493)}
Summary: <www-client/firefox{,-bin}-{38.2,40.0}, <mail-client/thunderbird{,-bin}-38.2:...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Security
URL: https://www.mozilla.org/en-US/securit...
Whiteboard: A2 [glsa]
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-14 16:09 UTC by Ian Stakenvicius
Modified: 2016-05-31 05:53 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ian Stakenvicius gentoo-dev 2015-08-14 16:09:09 UTC
It's that time again...

MFSA 2015-92 Use-after-free in XMLHttpRequest with shared workers
MFSA 2015-91 Mozilla Content Security Policy allows for asterisk wildcards in violation of CSP specification
MFSA 2015-90 Vulnerabilities found through code inspection
MFSA 2015-89 Buffer overflows on Libvpx when decoding WebM video
MFSA 2015-88 Heap overflow in gdk-pixbuf when scaling bitmap images
MFSA 2015-87 Crash when using shared memory in JavaScript
MFSA 2015-86 Feed protocol with POST bypasses mixed content protections
MFSA 2015-85 Out-of-bounds write with Updater and malicious MAR file
MFSA 2015-84 Arbitrary file overwriting through Mozilla Maintenance Service with hard links
MFSA 2015-83 Overflow issues in libstagefright
MFSA 2015-82 Redefinition of non-configurable JavaScript object properties
MFSA 2015-81 Use-after-free in MediaStream playback
MFSA 2015-80 Out-of-bounds read with malformed MP3 file
MFSA 2015-79 Miscellaneous memory safety hazards (rv:40.0 / rv:38.2)


When mapping CVEs do you care which of the above packages each one pertains to?  firefox usually has more than thunderbird..

Also, apologies for filing this under the wrong product and not having the other various fields properly filled out...  please update for me?
Comment 1 Yury German Gentoo Infrastructure gentoo-dev Security 2015-08-15 16:12:41 UTC
(In reply to Ian Stakenvicius from comment #0)

> When mapping CVEs do you care which of the above packages each one pertains
> to?  firefox usually has more than thunderbird..

As long as we have CVE list it does not matter, will get it now.
Comment 2 Yury German Gentoo Infrastructure gentoo-dev Security 2015-08-15 16:35:49 UTC
Maintainer(s), please advise if you when you are ready for stabilization or call for stabilization yourself.
Comment 3 Christian Tietz 2015-08-19 15:40:33 UTC
ebuilds are in tree for some days but what about stabilization?
Comment 4 Ian Stakenvicius gentoo-dev 2015-08-23 14:45:47 UTC
Apologies - I've been away without internet for the past week, and everyone else on the mozilla team has been busy.  All seems good for stabilization to me though, AT's please proceed:

www-client/firefox-38.2.0: Stable KEYWORDS="amd64 hppa ppc ppc64 x86"

www-client/firefox-bin-38.2.0: Stable KEYWORDS="amd64 x86"

mail-client/thunderbird-38.2.0: Stable KEYWORDS="amd64 ppc ppc64 x86"

mail-client/thunderbird-bin-38.2.0: Stable KEYWORDS="amd64 x86"
Comment 5 Jeroen Roovers gentoo-dev 2015-08-24 04:03:16 UTC
Stable for HPPA PPC64.
Comment 6 Agostino Sarubbo gentoo-dev 2015-08-25 08:32:20 UTC
amd64 stable
Comment 7 Agostino Sarubbo gentoo-dev 2015-08-25 08:33:04 UTC
x86 stable
Comment 8 Agostino Sarubbo gentoo-dev 2015-08-26 07:31:32 UTC
ppc stable.

Maintainer(s), please cleanup.
Security, please add it to the existing request, or file a new one.
Comment 9 GLSAMaker/CVETool Bot gentoo-dev 2015-09-13 13:42:08 UTC
CVE-2015-4493 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-4493):
  Heap-based buffer overflow in the stagefright::ESDS::parseESDescriptor
  function in libstagefright in Mozilla Firefox before 40.0 and Firefox ESR
  38.x before 38.2 allows remote attackers to execute arbitrary code via an
  invalid size field in an esds chunk in MPEG-4 video data.

CVE-2015-4492 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-4492):
  Use-after-free vulnerability in the XMLHttpRequest::Open implementation in
  Mozilla Firefox before 40.0 and Firefox ESR 38.x before 38.2 might allow
  remote attackers to execute arbitrary code via a SharedWorker object that
  makes recursive calls to the open method of an XMLHttpRequest object.

CVE-2015-4491 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-4491):
  Integer overflow in the make_filter_table function in pixops/pixops.c in
  gdk-pixbuf before 2.31.5, as used in Mozilla Firefox before 40.0 and Firefox
  ESR 38.x before 38.2 on Linux, Google Chrome on Linux, and other products,
  allows remote attackers to execute arbitrary code or cause a denial of
  service (heap-based buffer overflow and application crash) via crafted
  bitmap dimensions that are mishandled during scaling.

CVE-2015-4490 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-4490):
  The nsCSPHostSrc::permits function in dom/security/nsCSPUtils.cpp in Mozilla
  Firefox before 40.0 does not implement the Content Security Policy Level 2
  exceptions for the blob, data, and filesystem URL schemes during wildcard
  source-expression matching, which might make it easier for remote attackers
  to conduct cross-site scripting (XSS) attacks by leveraging unexpected
  policy-enforcement behavior.

CVE-2015-4489 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-4489):
  The nsTArray_Impl class in Mozilla Firefox before 40.0, Firefox ESR 38.x
  before 38.2, and Firefox OS before 2.2 might allow remote attackers to cause
  a denial of service (memory corruption) or possibly have unspecified other
  impact by leveraging a self assignment.

CVE-2015-4488 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-4488):
  Use-after-free vulnerability in the StyleAnimationValue class in Mozilla
  Firefox before 40.0, Firefox ESR 38.x before 38.2, and Firefox OS before 2.2
  allows remote attackers to have an unspecified impact by leveraging a
  StyleAnimationValue::operator self assignment.

CVE-2015-4487 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-4487):
  The nsTSubstring::ReplacePrep function in Mozilla Firefox before 40.0,
  Firefox ESR 38.x before 38.2, and Firefox OS before 2.2 might allow remote
  attackers to cause a denial of service (memory corruption) or possibly have
  unspecified other impact via unknown vectors, related to an "overflow."

CVE-2015-4486 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-4486):
  The decrease_ref_count function in libvpx in Mozilla Firefox before 40.0 and
  Firefox ESR 38.x before 38.2 allows remote attackers to execute arbitrary
  code or cause a denial of service (out-of-bounds read) via malformed WebM
  video data.

CVE-2015-4485 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-4485):
  Heap-based buffer overflow in the resize_context_buffers function in libvpx
  in Mozilla Firefox before 40.0 and Firefox ESR 38.x before 38.2 allows
  remote attackers to execute arbitrary code via malformed WebM video data.

CVE-2015-4484 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-4484):
  The js::jit::AssemblerX86Shared::lock_addl function in the JavaScript
  implementation in Mozilla Firefox before 40.0 and Firefox ESR 38.x before
  38.2 allows remote attackers to cause a denial of service (application
  crash) by leveraging the use of shared memory and accessing (1) an Atomics
  object or (2) a SharedArrayBuffer object.

CVE-2015-4483 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-4483):
  Mozilla Firefox before 40.0 allows man-in-the-middle attackers to bypass a
  mixed-content protection mechanism via a feed: URL in a POST request.

CVE-2015-4482 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-4482):
  mar_read.c in the Updater in Mozilla Firefox before 40.0 and Firefox ESR
  38.x before 38.2 allows local users to gain privileges or cause a denial of
  service (out-of-bounds write) via a crafted name of a Mozilla Archive (aka
  MAR) file.

CVE-2015-4481 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-4481):
  Race condition in the Mozilla Maintenance Service in Mozilla Firefox before
  40.0 and Firefox ESR 38.x before 38.2 on Windows allows local users to write
  to arbitrary files and consequently gain privileges via vectors involving a
  hard link to a log file during an update.

CVE-2015-4480 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-4480):
  Integer overflow in the stagefright::SampleTable::isValid function in
  libstagefright in Mozilla Firefox before 40.0 and Firefox ESR 38.x before
  38.2 allows remote attackers to execute arbitrary code via crafted MPEG-4
  video data with H.264 encoding.

CVE-2015-4479 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-4479):
  Multiple integer overflows in libstagefright in Mozilla Firefox before 40.0
  and Firefox ESR 38.x before 38.2 allow remote attackers to execute arbitrary
  code via a crafted saio chunk in MPEG-4 video data.

CVE-2015-4478 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-4478):
  Mozilla Firefox before 40.0 and Firefox ESR 38.x before 38.2 do not impose
  certain ECMAScript 6 requirements on JavaScript object properties, which
  allows remote attackers to bypass the Same Origin Policy via the reviver
  parameter to the JSON.parse method.

CVE-2015-4477 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-4477):
  Use-after-free vulnerability in the MediaStream playback feature in Mozilla
  Firefox before 40.0 allows remote attackers to execute arbitrary code via
  unspecified use of the Web Audio API.

CVE-2015-4475 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-4475):
  The mozilla::AudioSink function in Mozilla Firefox before 40.0 and Firefox
  ESR 38.x before 38.2 mishandles inconsistent sample formats within MP3 audio
  data, which allows remote attackers to execute arbitrary code or cause a
  denial of service (out-of-bounds read) via a malformed file.

CVE-2015-4474 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-4474):
  Multiple unspecified vulnerabilities in the browser engine in Mozilla
  Firefox before 40.0 allow remote attackers to cause a denial of service
  (memory corruption and application crash) or possibly execute arbitrary code
  via unknown vectors.

CVE-2015-4473 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-4473):
  Multiple unspecified vulnerabilities in the browser engine in Mozilla
  Firefox before 40.0 and Firefox ESR 38.x before 38.2 allow remote attackers
  to cause a denial of service (memory corruption and application crash) or
  possibly execute arbitrary code via unknown vectors.
Comment 10 Yury German Gentoo Infrastructure gentoo-dev Security 2015-09-13 13:46:33 UTC
Added to an existing GLSA Request.
Maintainer(s), please drop the vulnerable version(s).
Comment 11 Yury German Gentoo Infrastructure gentoo-dev Security 2015-09-27 03:23:18 UTC
Maintainer(s), Thank you for you for cleanup.
Comment 12 GLSAMaker/CVETool Bot gentoo-dev 2016-05-31 05:53:47 UTC
This issue was resolved and addressed in
 GLSA 201605-06 at https://security.gentoo.org/glsa/201605-06
by GLSA coordinator Yury German (BlueKnight).