Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 556752 - sys-devel/libtool-2.4.6-r1 needs dev-perl/Locale-gettext to build
Summary: sys-devel/libtool-2.4.6-r1 needs dev-perl/Locale-gettext to build
Status: RESOLVED DUPLICATE of bug 592880
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-05 12:57 UTC by comicfans44
Modified: 2016-09-04 16:02 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description comicfans44 2015-08-05 12:57:55 UTC
without dev-perl/Locale-gettext,libtool-2.4.6-r1 can not emerge.


Reproducible: Always

Steps to Reproduce:
1.emerge libtool  without dev-perl/Local-gettext installed

Actual Results:  
CCLD     libltdl/dlopen.la
  CC       libltdl/libltdl_libltdlc_la-lt_dlloader.lo
  CC       libltdl/libltdl_libltdlc_la-lt_error.lo
  CC       libltdl/libltdl_libltdlc_la-ltdl.lo
  CC       libltdl/libltdl_libltdlc_la-slist.lo
  GEN      doc/libtool.1
Can't locate Locale/gettext.pm in @INC (you may need to install the Locale::gettext module) (@INC contains: /etc/perl /usr/local/lib64/perl5/5.22.0/x86_64-linux /usr/local/lib64/perl5/5.22.0 /usr/lib64/perl5/vendor_perl/5.22.0/x86_64-linux /usr/lib64/perl5/vendor_perl/5.22.0 /usr/lib64/perl5/5.22.0/x86_64-linux /usr/lib64/perl5/5.22.0 .) at /usr/bin/help2man line 29.
BEGIN failed--compilation aborted at /usr/bin/help2man line 29.


Expected Results:  
emerge should also install dev-perl/Local-gettext to complete libtool install

emerge  dev-perl/Locale-gettext solved this
Comment 1 comicfans44 2015-08-05 14:48:14 UTC
seems it's caused by perl version upgrade and module not rebuild
Comment 2 Kent Fredric (IRC: kent\n) gentoo-dev 2016-09-04 16:02:45 UTC

*** This bug has been marked as a duplicate of bug 592880 ***