Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 556182 - sys-apps/portage-2.2.20: wrong keywording reason printed
Summary: sys-apps/portage-2.2.20: wrong keywording reason printed
Status: RESOLVED DUPLICATE of bug 419381
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Dependencies (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-28 23:21 UTC by Rafał Mużyło
Modified: 2015-08-07 13:04 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rafał Mużyło 2015-07-28 23:21:37 UTC
First of all, I must stress that I'm mixing.

My accept_keywords list is large, though I'm not sure how large exactly, due to dozens of stale entries (for packages that not only went stable, but even long left the tree).

Anyway, today, at treestamp Tue, 28 Jul 2015 21:15:01 +0000, on two separate setups, I've noted a keywording request at the end of 'emerge -upvD -with-bdeps y @world'.

=dev-libs/openssl-1.0.2d ~x86 (on the other machine ~amd64)

However, the packages packages printed as the reason were bogus - neither had '>=openssl-1.0.2' dep. So, I masked 1.0.2* and added '--autounmask-keep-masks y'.

Only then was the real reason printed - it was www-servers/apache-2.4.12-r1 (one of accept_keywords entries).

Another variant of that bogus boost mask or a new problem ?
Comment 1 Ben Kohler gentoo-dev 2015-07-28 23:29:23 UTC

*** This bug has been marked as a duplicate of bug 419381 ***
Comment 2 Brian Dolbec gentoo-dev 2015-08-07 13:04:40 UTC
app-portage/gentoolkit...

Use the enalyze command to create a new keywords file.

# enalyze rebuild keywords

Diffing the newly generated file with the existing will tell you the stale entries. (provided you sort the existing file first)