Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 55593 - sys-process/vixie-cron: changes to root user's crontab not acknowledged without a restart
Summary: sys-process/vixie-cron: changes to root user's crontab not acknowledged witho...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High minor (vote)
Deadline: 2019-10-11
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords: PMASKED
Depends on:
Blocks:
 
Reported: 2004-06-29 10:02 UTC by Alex
Modified: 2019-10-11 15:07 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2004-06-29 10:02:09 UTC
After switching to xorg-x11 I've had this weird problem with the root crontab and I'm not sure if it's related to xorg or not.

The entries in root's crontab file are not executed although the entries in my normal user account's crontab are executed flawlessly (with corresponding email sent to my system box). I'm running vixie-cron if that makes a difference.

Reproducible: Always
Steps to Reproduce:
1. emerge vixie-cron
2. make an entry in root's crontab and wait for it to be executed
3. notice that it isn't executed both from lack of emails and lack of update to whatever file it was supposed to touch.

Actual Results:  
/home/extra/joseph-a-nagy-jr/cgi-bin/awstats/awstats.pl
--config=joseph-a-nagy-jr.homelinux.org isn't ran

Expected Results:  
The above script should have been executed to update my log file analyzer.

$ emerge info
Portage 2.0.50-r8 (default-x86-2004.0, gcc-3.3.3, glibc-2.3.3.20040420-r0, 2.6.6
                     
)
=================================================================
System uname: 2.6.6 i686 Intel(R) Pentium(R) 4 CPU 2.40GHz
Gentoo Base System version 1.5.1
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5-r1
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-Os -march=pentium3 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.2
                     
/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/
                     
config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/shar
                     
e/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf
                     
/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-Os -march=pentium3 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache sandbox"
GENTOO_MIRRORS="ftp:///ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://128.
                     
213.5.34/gentoo/ http://mirror.datapipe.net/gentoo ftp://mirrors.sec.informatik.
                     
tu-darmstadt.de/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aalib acl acpi aim alsa apache2 apm arts audiofile avi berkdb bidi canna
                      
caps cdr cjk crypt cscope cups directfb divx4linux doc dvd encode esd evo fbcon
                      
fftw flac flash foomaticdb freetds freewnn gb gd gdbm gif gimp gimpprint gnome g
                     
pm gtk gtk2 icq imagemagick imap imlib innodb ipv6 jabber jack java joystick jpe
                     
g kde lcms ldap libg++ libwww mad maildir mailwrapper mbox mikmod mmx mng motif
                      
mozilla mpeg msn mysql nas ncurses nls odbc offensive oggvorbis opengl oscar oss
                     
 pam pdflib perl png postgres python qt quickline quicktime readline realplayer
                      
samba sasl scanner sdl slang slp snmp spell sse ssl svg svga tcltk tcpd tetex th
                     
eora tiff truetype unicode usb vhosts videos x86 xml xml2 xmms xv xvid yahoo zli
                     
b"

awstats was isntalled manually by downloading the files from awstats.sf.net and
extracted into the websites cgi-bin. It is configured correctly as I can
manually run the command without any problems.
Comment 1 Alex 2004-06-30 12:53:53 UTC
Oddly enough the problem seemed to clear itself up. The only thing I did was restart both syslog-ng and vixie-cron. Apparently one or the other wasn't properly started despite having an ok status on boot up.
Comment 2 Alex 2004-06-30 12:54:31 UTC
Closing this because it fixed itself.
Comment 3 Chris Xe 2009-05-29 07:02:59 UTC
I still have this bug. I have found that I have to
`/etc/init.d/vixie-cron restart` to get root's crontab to be looked at.
Comment 4 Kerin Millar 2010-10-22 11:47:16 UTC
> I still have this bug. I have found that I have to
> `/etc/init.d/vixie-cron restart` to get root's crontab to be looked at.

Likewise. I conducted a simple test case using vixie-cron in Debian Etch and it works perfectly without the need for a restart. This is not invalid and, therefore, I am re-opening.
Comment 5 Kerin Millar 2010-10-22 11:58:05 UTC
I checked the logs in Debian and noticed the following after making a modification using "crontab -e" as root:

Oct 22 12:54:39 _________ crontab[27095]: (root) BEGIN EDIT (root)
Oct 22 12:54:58 _________ crontab[27095]: (root) REPLACE (root)
Oct 22 12:54:58 _________ crontab[27095]: (root) END EDIT (root)
Oct 22 12:55:01 _________ /usr/sbin/cron[3790]: (root) RELOAD (crontabs/root)

In Gentoo, the RELOAD action never occurs.
Comment 6 Kerin Millar 2010-10-22 12:05:38 UTC
Sorry for the quick succession of comments. Actually, the RELOAD action does seem to occur but it appears to be quite sporadic in nature. I'm trying to discern a particular pattern and will post back in the event that I am able to do that.
Comment 7 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-10-11 15:07:59 UTC
Package removed.