Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 55540 - xorg.conf in / breaks X when started by gdm
Summary: xorg.conf in / breaks X when started by gdm
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High trivial (vote)
Assignee: Gentoo X packagers
Depends on:
Reported: 2004-06-29 04:55 UTC by Tor Klingberg
Modified: 2005-11-20 11:05 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Tor Klingberg 2004-06-29 04:55:08 UTC
If there happen to exist a file /xorg.conf, then that file will be used instead of /etc/X11/xorg.conf when X is loaded with gdm during init. 

Reproducible: Always
Steps to Reproduce:
1. Make sure you use and gdm
2. echo FOOBAR>/xorg.conf
3. reboot

Actual Results:  
X won't start, complaining about error in xorg.conf

Expected Results:  
Used /etc/X11/xorg.conf, and started properly.

/var/log/Xorg.0.log will say 'Using config file: "//xorg.conf"'

running '/etc/init.d/xdm start' will fail the same way.
running /usr/bin/gdm does does NOT fail.

I also tried creating a trivial /etc/init.d/gdm that did nothing but 
run /usr/bin/gdm. Then running '/etc/init.d/gdm start' worked fine, but adding 
gdm to init (rc-update add gdm default) would still fail just like xdm.

I do not know if this problem also exists with kdm and xdm or if if applies to 

To me, this seems like a bug in the init script system.
Comment 1 Donnie Berkholz (RETIRED) gentoo-dev 2004-06-29 12:22:37 UTC
It'd be appreciated if you would attach fixes for this problem. The likelihood of it actually affecting anyone is quite low, as far as I can see, so this doesn't come in real high on my list of things to devote time to.
Comment 2 Donnie Berkholz (RETIRED) gentoo-dev 2004-09-30 14:11:17 UTC
Go ahead and file a bug at on this. Please stick the link here once you do.

Thanks a lot.
Comment 3 Tor Klingberg 2004-10-01 14:09:13 UTC
Sure, upstream report is here:
Comment 4 Joshua Baergen (RETIRED) gentoo-dev 2005-11-20 11:05:05 UTC
It appears this is being handled at the added URL.