Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 555316 - net-misc/openssh-6.9_p1-r2 with app-admin/denyhosts - ERROR: net-misc/openssh-6.9_p1-r2::gentoo failed (setup phase): USE=tcpd no longer works
Summary: net-misc/openssh-6.9_p1-r2 with app-admin/denyhosts - ERROR: net-misc/openssh...
Status: RESOLVED DUPLICATE of bug 531156
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Christoph Junghans
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-19 07:19 UTC by Jeroen Roovers
Modified: 2015-08-12 23:03 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Roovers gentoo-dev 2015-07-19 07:19:01 UTC
When denyhosts is active and has set up some hosts to deny, then emerging =net-misc/openssh-6.9_p1-r2 will fail in pkg_setup():

 * Package:    net-misc/openssh-6.9_p1-r2
 * Repository: gentoo
 * Maintainer: robbat2@gentoo.org base-system@gentoo.org
 * USE:        X elibc_glibc hpn hppa kernel_linux pam pie sctp ssl test userland_GNU
 * FEATURES:   compressdebug distcc preserve-libs sandbox splitdebug test userpriv usersandbox
 * Sorry, but openssh no longer supports tcp-wrappers, and it seems like
 * you're trying to use it.  Update your /etc/hosts.{allow,deny} please.
 * ERROR: net-misc/openssh-6.9_p1-r2::gentoo failed (setup phase):
 *   USE=tcpd no longer works
 *
 * Call stack:
 *                  ebuild.sh, line  93:  Called pkg_setup
 *   openssh-6.9_p1-r2.ebuild, line  99:  Called die
 * The specific snippet of code:
 *              die "USE=tcpd no longer works"
 *
 * If you need support, post the output of `emerge --info '=net-misc/openssh-6.9_p1-r2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-misc/openssh-6.9_p1-r2::gentoo'`.
 * The complete build log is located at '/keeps/gentoo/emergelogs/karsten/net-misc:openssh-6.9_p1-r2:20150719-071254.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/net-misc/openssh-6.9_p1-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-misc/openssh-6.9_p1-r2/temp/die.env'.
 * Working directory: '/usr/lib/python3.4/site-packages'
 * S: '/var/tmp/portage/net-misc/openssh-6.9_p1-r2/work/openssh-6.9p1'
Comment 1 Christoph Junghans gentoo-dev 2015-07-19 14:11:30 UTC
=app-admin/denyhosts-2.9 can use iptables instead of tcp-wrappers should we just stabilize that one?
Comment 2 MAL 2015-07-27 09:33:57 UTC
Tried =app-admin/denyhosts-2.9 and was unable to get iptables blocking working.

I've switched to fail2ban, which IMO is far superior software and I won't be looking back, however Denyhosts continues with v3 as a fork from Github: https://github.com/denyhosts/
Comment 3 SpanKY gentoo-dev 2015-08-12 07:19:34 UTC

*** This bug has been marked as a duplicate of bug 531156 ***
Comment 4 Christoph Junghans gentoo-dev 2015-08-12 23:03:09 UTC
app-admin/denyhosts-2.9 is becoming stable (bug #556522).