Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 552708 - =dev-util/cmake-3.2.2: cmGeneratorExpressionEvalutionFile.h:39:64: error: 'mode_t' has not been declared
Summary: =dev-util/cmake-3.2.2: cmGeneratorExpressionEvalutionFile.h:39:64: error: 'mo...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: musl-porting
  Show dependency tree
 
Reported: 2015-06-21 08:29 UTC by Felix Janda
Modified: 2015-06-22 21:16 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (build.log,34.63 KB, text/plain)
2015-06-21 08:30 UTC, Felix Janda
Details
Patch from upstream git (cmake-3.2.2-mode_t.patch,959 bytes, patch)
2015-06-21 08:30 UTC, Felix Janda
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Janda 2015-06-21 08:29:41 UTC
Building cmake-3.2.2 fails on the musl profiles because of a missing
include for the mode_t type.

There is an upstream fix, which made it into cmake-3.2.3.


Reproducible: Always
Comment 1 Felix Janda 2015-06-21 08:30:04 UTC
Created attachment 405462 [details]
Build log
Comment 2 Felix Janda 2015-06-21 08:30:41 UTC
Created attachment 405464 [details, diff]
Patch from upstream git
Comment 3 Anthony Basile gentoo-dev 2015-06-22 11:14:46 UTC
(In reply to Felix Janda from comment #0)
> Building cmake-3.2.2 fails on the musl profiles because of a missing
> include for the mode_t type.
> 
> There is an upstream fix, which made it into cmake-3.2.3.
> 
> 
> Reproducible: Always

Nope.  3.2.3 has the same issue:

/var/tmp/portage/dev-util/cmake-3.2.3/work/cmake-3.2.3/Source/cmGeneratorExpressionEvaluationFile.h:39:64: error: ‘mode_t’ has not been declared
               std::map<std::string, std::string> &outputFiles, mode_t perm);
                                                                ^
Makefile:146: recipe for target 'cmGlobalNinjaGenerator.o' failed
gmake: *** [cmGlobalNinjaGenerator.o] Error 1
Comment 4 Anthony Basile gentoo-dev 2015-06-22 15:36:52 UTC
(In reply to Anthony Basile from comment #3)
> (In reply to Felix Janda from comment #0)
> > Building cmake-3.2.2 fails on the musl profiles because of a missing
> > include for the mode_t type.
> > 
> > There is an upstream fix, which made it into cmake-3.2.3.
> > 
> > 
> > Reproducible: Always
> 
> Nope.  3.2.3 has the same issue:
> 

I just check the 3.2.3 tarball directly and it doesn't have this patch.  I can't make sense of upstream's workflow and I don't know if its in the pipe for some future release or what.

Nonetheless, this is a very safe patch to backport.

@maintainers.  Okay to backport to 3.2.3?  Currently 3.2.2 is being stabilized and it will be a while before this patch makes it to a release.
Comment 5 Felix Janda 2015-06-22 17:14:46 UTC
Right, the patch is not in 3.2.3 although it is older than that release.
It will be in cmake-3.3.0, whose second release candidate is already out.
Comment 6 Anthony Basile gentoo-dev 2015-06-22 19:44:05 UTC
(In reply to Felix Janda from comment #5)
> Right, the patch is not in 3.2.3 although it is older than that release.
> It will be in cmake-3.3.0, whose second release candidate is already out.

Okay.  I did see the tags for 3.3.0_rcX.  Still this is a very innocent patch an it applies cleanly to 3.2.3, so it is worth backporting it.
Comment 7 Johannes Huber gentoo-dev 2015-06-22 21:16:26 UTC
Thanks for reporting. This is fixed for 3.2.3 in cvs now. Please sync.

+
+  22 Jun 2015; Johannes Huber <johu@gentoo.org>
+  +files/cmake-3.2.3-musl-missing-include.patch, cmake-3.2.3.ebuild:
+  Add upstream patch to fix build on musl profiles, spotted by Felix Janda
+  <felix.janda@posteo.de>, bug #552708.
+