Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 552194 - app-editors/zile-2.4.11::gentoo failed (compile phase) Can't locate Locale/gettext.pm in @INC
Summary: app-editors/zile-2.4.11::gentoo failed (compile phase) Can't locate Locale/ge...
Status: RESOLVED DUPLICATE of bug 592880
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-15 14:23 UTC by Muelli
Modified: 2016-09-04 16:07 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Muelli 2015-06-15 14:23:58 UTC
arch=athlon64 -fomit-frame-pointer -ggdb -g3 -ggdb -g3 -c -o src/term_redisplay.o src/term_redisplay.c
x86_64-pc-linux-gnu-gcc -std=gnu99 -DHAVE_CONFIG_H -I.  -I./src -I./src -I./lib -I./lib -DPATH_DOCDIR="\"/usr/share/doc/zile-2.4.11\""    -O2 -pipe -march=athlon64 -fomit-frame-pointer -ggdb -g3 -ggdb -g3 -c -o src/term_curses.o src/term_curses.c
x86_64-pc-linux-gnu-gcc -std=gnu99   -O2 -pipe -march=athlon64 -fomit-frame-pointer -ggdb -g3 -ggdb -g3  -Wl,-O1 -Wl,--enable-new-dtags -Wl,--sort-common -Wl,--as-needed -o src/zile src/basic.o src/bind.o src/buffer.o src/eval.o src/file.o src/funcs.o src/help.o src/killring.o src/line.o src/gc_veneer.o src/lisp.o src/macro.o src/redisplay.o src/registers.o src/search.o src/undo.o src/variables.o src/window.o src/memrmem.o src/astr.o src/estr.o src/lists.o src/completion.o src/editfns.o src/getkey.o src/history.o src/keycode.o src/main.o src/marker.o src/minibuf.o src/region.o src/term_minibuf.o src/term_redisplay.o src/term_curses.o  ./lib/libzile.a -lacl   -lncursesw -lgc   
if ( touch doc/zile.1.in.w && rm -f doc/zile.1.in.w; ) >/dev/null 2>&1; then \
  ./build-aux/missing --run /usr/bin/help2man --output=doc/zile.1.in --no-info --name="Zile Is Lossy Emacs" --include ./doc/man-extras ./build-aux/zile-help2man-wrapper; \
fi
Can't locate Locale/gettext.pm in @INC (you may need to install the Locale::gettext module) (@INC contains: /etc/perl /usr/local/lib64/perl5/5.20.1/x86_64-linux-thread-multi /usr/local/lib64/perl5/5.20.1 /usr/lib64/perl5/vendor_perl/5.20.1/x86_64-linux-thread-multi /usr/lib64/perl5/vendor_perl/5.20.1 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl /usr/lib64/perl5/5.20.1/x86_64-linux-thread-multi /usr/lib64/perl5/5.20.1 .) at /usr/bin/help2man line 28.
BEGIN failed--compilation aborted at /usr/bin/help2man line 28.
make[2]: *** [doc/zile.1.in] Error 2
make[2]: Leaving directory `/var/tmp/portage/app-editors/zile-2.4.11/work/zile-2.4.11'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-editors/zile-2.4.11/work/zile-2.4.11'
make: *** [all] Error 2
 * ERROR: app-editors/zile-2.4.11::gentoo failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=app-editors/zile-2.4.11::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-editors/zile-2.4.11::gentoo'`.
 * The complete build log is located at '/var/log/portage/app-editors:zile-2.4.11:20150615-141330.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/app-editors/zile-2.4.11/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-editors/zile-2.4.11/temp/environment'.
 * Working directory: '/var/tmp/portage/app-editors/zile-2.4.11/work/zile-2.4.11'
 * S: '/var/tmp/portage/app-editors/zile-2.4.11/work/zile-2.4.11'



Portage 2.2.14 (python 2.7.9-final-0, hardened/linux/amd64/no-multilib, gcc-4.7.3-hardenednopiessp, glibc-2.19-r1, 3.14.5-hardened-r2 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.14.5-hardened-r2-x86_64-AMD_Athlon-tm-_64_Processor_3800+-with-gentoo-2.2
KiB Mem:     1020056 total,     64576 free
KiB Swap:    2008120 total,   1202452 free
Timestamp of tree: Sat, 13 Jun 2015 01:45:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
ccache version 2.3 [enabled]
app-shells/bash:          4.2_p53
dev-java/java-config:     2.1.11-r3
dev-lang/perl:            5.20.1-r4
dev-lang/python:          2.7.9-r1, 3.3.5-r1, 3.4.1
dev-util/ccache:          2.3::<unknown repository>
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.11
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13::<unknown repository>, 2.69
sys-devel/automake:       1.4_p6::<unknown repository>, 1.5::<unknown repository>, 1.6.3::<unknown repository>, 1.7.9-r1::<unknown repository>, 1.8.5-r3::<unknown repository>, 1.9.6-r2::<unknown repository>, 1.10.3, 1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.7.3-r1, 4.8.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.4
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.18 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo laurentb zugaina stuff xelnor
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=athlon64 -fomit-frame-pointer -ggdb -g3 -ggdb -g3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=athlon64 -fomit-frame-pointer -ggdb -g3"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache clean-logs config-protect-if-modified distlocks ebuild-locks fixlafiles getbinpkg merge-sync news noinfo parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--enable-new-dtags -Wl,--sort-common -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/laurentb /var/lib/layman/zugaina /var/lib/layman/stuff /var/lib/layman/xelnor"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="acl acpi amd amd64 amuled apache2 audiofile auth authdaemond bash-completion bcmath berkdb bittorrent buttons bzip2 bzlib cacheemu calendar ccache cdb cgi chroot clamav cli cpulimit cracklib crypt css ctype curl cvsgraph cxx daemon datadir dedicated detex dhcp dri ecc edl escreen ethereal etwin exif expat extraengine extras fat firefox flood ftp fuse gd gdbm geoip ginac git glibc-omitfp gnutls gpg gpgme gzip hardened hardenedphp hash hbci howl hpn html http httpd hub iconv icq id3 idn imagemagick imap insecure-drivers ipppd ipv6 irc isdn ithreads jabber jasper javascript john jpeg jpeg2k json justify kpathsea lame latex ldap ldap-bind libclamav lua mail maildir maildrop mailwrapper math md5sum memlimit mercurial mhash mime mjpeg mmx mmxext mod mod_irc mod_muc mod_pubsub mode-owner modules moznocompose moznoirc moznomail mozxmlterm mp4 mp4live mpeg2 mpeg4 mplayer mpm-itk msn msnextras multipleip multiuser mysql mysqli ncurses netboot netlink nfs nls nntp no-old-linux nogg nptl ntfs numarray numeric oav offensive on-the-fly-crypt openmp openssl oscar otr pam pam_chroot pax_kernel pcre phar php pie png posix postfix preview-latex python quota quotas rdesktop readline reflection reiserfs remote roundrobin rss sasl screen semanticfix sendfile sensord serial session sftp sftplogging shaper silc simplexml slang smime sms sockets socks5 softquota speex spell spl sql sqlite sqlite3 sse sse2 ssl ssp subversion suhosin svn-mirror svnserve tcpd tetex thumbnail tidy tiff tokenizer tordns transcode transparent-proxy truetype unicode urandom usb user-homedirs utf8 vchroot vda vfat vhosts virtual virus-scan web wmf xattr xchattext xml xsl xtpax xvid yahoo zip zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_balancer proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias cgi" APACHE2_MPMS="itk" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="3dnow 3dnowext mmx mmxext sse sse2 sse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en de en_GB" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python3_4 python3_3 python2_7" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON




# emerge -pqv '=app-editors/zile-2.4.11::gentoo'
!!! PORTAGE_BINHOST unset, but use is requested.
[ebuild  N    ] app-editors/zile-2.4.11  USE="acl {-test}" 

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.
Comment 1 Rafał Mużyło 2015-06-15 16:41:39 UTC
Just a guess, but your error sounds strangely like "I need to run perl-cleaner".
Comment 2 Mike Gilbert gentoo-dev 2015-06-17 02:06:25 UTC
Please re-open this if perl-cleaner does not fix it.
Comment 3 Muelli 2015-06-17 08:46:30 UTC
# perl-cleaner --phall

 * Beginning a clean up of .ph files
 * Excluding files for 5.20.1 and 5.20.1/x86_64-linux-thread-multi from cleaning

 * Locating ph files for removal

 * Updating ph files.
 * Ignore all "No such file..." messages!
Can't open machine/ansi.h: No such file or directory
Can't open sys/_types.h: No such file or directory
Can't open gnu/stubs-32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory



didn't fix anything.
Comment 4 Muelli 2015-06-18 07:39:55 UTC
perl-cleaner --all   seems to have fixed it.  Sorry for the noise.
Comment 5 Kent Fredric (IRC: kent\n) gentoo-dev 2016-09-04 16:07:39 UTC

*** This bug has been marked as a duplicate of bug 592880 ***