Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 55124 - galeon-1.2.15-r1 and epiphany-1.2.6 fail to compile due to compiler flag
Summary: galeon-1.2.15-r1 and epiphany-1.2.6 fail to compile due to compiler flag
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 All
: High minor (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 55125 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-06-25 01:04 UTC by Stelian Ionescu
Modified: 2004-07-05 11:07 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stelian Ionescu 2004-06-25 01:04:55 UTC
If $CXXFLAGS contains -fno-default-inline both galeon-1.3-15-r1 and epiphany-1.2.6 compile well but fail to link. The errors I get are stuff like
../mozilla/.libs/libmozillaembed.a(EventContext.o)(.gnu.linkonce.t._ZNK6nsRect8ContainsERK7nsPoint+0x2b): In function `nsRect::Contains(nsPoint const&) const':
: undefined reference to `nsRect::Contains(int, int) const'
../mozilla/.libs/libmozillaembed.a(MozRegisterComponents.o)(.gnu.linkonce.t._ZN17nsAboutRedirectorC2Ev+0x18): In function
`nsAboutRedirector::nsAboutRedirector[not-in-charge]()':
: undefined reference to `vtable for nsAboutRedirector'
Once I removed -fno-default-inline the builds went well
Comment 1 Mr. Bones. (RETIRED) gentoo-dev 2004-06-25 01:34:53 UTC
*** Bug 55125 has been marked as a duplicate of this bug. ***
Comment 2 foser (RETIRED) gentoo-dev 2004-07-05 11:07:14 UTC
i personally consider -fno-default-inline out of the scope of supported CFLAGS.

Thanks for the notification though...