Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 550840 - =app-text/texlive-2014 =app-text/texlive-core-2014-r4 and =dev-texlive/texlive-*-2014: stable request
Summary: =app-text/texlive-2014 =app-text/texlive-core-2014-r4 and =dev-texlive/texliv...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: TeX project
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 555454 604400
Blocks: 481076 555220
  Show dependency tree
 
Reported: 2015-05-30 21:37 UTC by Jason McGuiness
Modified: 2017-12-20 21:56 UTC (History)
4 users (show)

See Also:
Package list:
=app-text/dvipsk-5.994_p20140525 =app-text/ps2pkm-1.5_p20140525 =app-text/texlive-2014 =app-text/texlive-core-2014-r4 =dev-libs/kpathsea-6.2.0_p20140525 =dev-libs/ptexenc-1.3.2_p20140525-r1 =dev-tex/bibtexu-3.71_p20140525 =dev-texlive/texlive-basic-2014 =dev-texlive/texlive-bibtexextra-2014 =dev-texlive/texlive-context-2014 =dev-texlive/texlive-fontsextra-2014 =dev-texlive/texlive-fontsrecommended-2014 =dev-texlive/texlive-fontutils-2014 =dev-texlive/texlive-formatsextra-2014 =dev-texlive/texlive-games-2014 =dev-texlive/texlive-genericextra-2014 =dev-texlive/texlive-genericrecommended-2014 =dev-texlive/texlive-humanities-2014 =dev-texlive/texlive-langafrican-2014 =dev-texlive/texlive-langarabic-2014 =dev-texlive/texlive-langchinese-2014 =dev-texlive/texlive-langcjk-2014 =dev-texlive/texlive-langcyrillic-2014 =dev-texlive/texlive-langczechslovak-2014 =dev-texlive/texlive-langenglish-2014 =dev-texlive/texlive-langeuropean-2014 =dev-texlive/texlive-langfrench-2014 =dev-texlive/texlive-langgerman-2014 =dev-texlive/texlive-langgreek-2014 =dev-texlive/texlive-langindic-2014 =dev-texlive/texlive-langitalian-2014 =dev-texlive/texlive-langjapanese-2014 =dev-texlive/texlive-langkorean-2014 =dev-texlive/texlive-langother-2014 =dev-texlive/texlive-langpolish-2014 =dev-texlive/texlive-langportuguese-2014 =dev-texlive/texlive-langspanish-2014 =dev-texlive/texlive-latex-2014 =dev-texlive/texlive-latexextra-2014 =dev-texlive/texlive-latexrecommended-2014 =dev-texlive/texlive-luatex-2014 =dev-texlive/texlive-mathextra-2014 =dev-texlive/texlive-metapost-2014 =dev-texlive/texlive-music-2014 =dev-texlive/texlive-omega-2014 =dev-texlive/texlive-pictures-2014 =dev-texlive/texlive-plainextra-2014 =dev-texlive/texlive-pstricks-2014 =dev-texlive/texlive-publishers-2014 =dev-texlive/texlive-science-2014 =dev-texlive/texlive-xetex-2014 =dev-tex/tex4ht-20090611_p1038-r3 =dev-texlive/texlive-langcjk-2014 =dev-libs/kpathsea-6.2.0_p20140525 =app-text/texlive-core-2014-r4 =dev-tex/pgf-3.0.1
Runtime testing required: ---
kensington: sanity-check-


Attachments
list of packages for texlive 2014 (texlive.txt,1.83 KB, text/plain)
2015-07-09 16:20 UTC, Anthony Basile
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jason McGuiness 2015-05-30 21:37:41 UTC
This package is stable on my system, please mark it thus, if appropriate.

Reproducible: Always
Comment 1 Mike Gilbert gentoo-dev 2015-05-30 22:29:38 UTC
Do not copy archs yourself.
Comment 2 Anthony Basile gentoo-dev 2015-07-07 14:07:28 UTC
I've tested the following set on amd64 and ppc.  No regressions found.

@TeX herd.  Are these ready to go.

=app-text/texlive-2014
=app-text/texlive-core-2014-r4
=dev-texlive/texlive-basic-2014
=dev-texlive/texlive-fontsrecommended-2014
=dev-texlive/texlive-fontutils-2014
=dev-texlive/texlive-genericrecommended-2014
=dev-texlive/texlive-langafrican-2014
=dev-texlive/texlive-langarabic-2014
=dev-texlive/texlive-langchinese-2014
=dev-texlive/texlive-langcjk-2014
=dev-texlive/texlive-langcyrillic-2014
=dev-texlive/texlive-langczechslovak-2014
=dev-texlive/texlive-langenglish-2014
=dev-texlive/texlive-langeuropean-2014
=dev-texlive/texlive-langfrench-2014
=dev-texlive/texlive-langgerman-2014
=dev-texlive/texlive-langgreek-2014
=dev-texlive/texlive-langindic-2014
=dev-texlive/texlive-langitalian-2014
=dev-texlive/texlive-langjapanese-2014
=dev-texlive/texlive-langkorean-2014
=dev-texlive/texlive-langother-2014
=dev-texlive/texlive-langpolish-2014
=dev-texlive/texlive-langportuguese-2014
=dev-texlive/texlive-langspanish-2014
=dev-texlive/texlive-latex-2014
=dev-texlive/texlive-latexextra-2014
=dev-texlive/texlive-latexrecommended-2014
=dev-texlive/texlive-pictures-2014
Comment 3 Alexis Ballier gentoo-dev 2015-07-07 20:25:33 UTC
(In reply to Anthony Basile from comment #2)
> I've tested the following set on amd64 and ppc.  No regressions found.
> 
> @TeX herd.  Are these ready to go.

is the list ok for all arches? e.g. I don't see new kpathsea which is certainly needed for tl 2014
Comment 4 Anthony Basile gentoo-dev 2015-07-08 20:42:43 UTC
(In reply to Alexis Ballier from comment #3)
> (In reply to Anthony Basile from comment #2)
> > I've tested the following set on amd64 and ppc.  No regressions found.
> > 
> > @TeX herd.  Are these ready to go.
> 
> is the list ok for all arches? e.g. I don't see new kpathsea which is
> certainly needed for tl 2014

I've only tested on amd64 and x86.  I can test on arm, ppc and ppc64 and will later.  You're right about kpathsea.  I just grepped a list of packages for texlive and missed it.  Let me check on these other arches and get back.
Comment 5 Alexis Ballier gentoo-dev 2015-07-09 08:32:29 UTC
(In reply to Anthony Basile from comment #4)

> I've only tested on amd64 and x86.  I can test on arm, ppc and ppc64 and
> will later.  You're right about kpathsea.  I just grepped a list of packages
> for texlive and missed it.  Let me check on these other arches and get back.

don't do this manually :)

@pacho: I'm pretty sure you or gnome team have some nice scripts to generate such lists for stabilisations; however, I can never remember where it is :( could you please provide the link, or better, the list ?
Comment 6 Anthony Basile gentoo-dev 2015-07-09 11:51:29 UTC
(In reply to Alexis Ballier from comment #5)
> (In reply to Anthony Basile from comment #4)
> 
> > I've only tested on amd64 and x86.  I can test on arm, ppc and ppc64 and
> > will later.  You're right about kpathsea.  I just grepped a list of packages
> > for texlive and missed it.  Let me check on these other arches and get back.
> 
> don't do this manually :)

it wasn't done manually, the list was generated with scripts, but because the output has extra info in it, i just blindly grepped for texlive and missed 5 pkgs when copyng here.  i'll try to catch up with pacho to see if his script produce the same list.
Comment 7 Anthony Basile gentoo-dev 2015-07-09 16:20:44 UTC
Created attachment 406416 [details]
list of packages for texlive 2014

The attached list is the same on alpha, amd64, arm, hppa, ppc, ppc64 and x86.  (It was generated using the gnome script.)

I have tested on amd64, ppc, ppc64 and x86.  I have yet to test on arm.

amd64, ppc and x86 are okay.

ppc64 fails because texlive-core-2014-r4 bundles luajit which does not have ppc64 support.  <= 2013 are okay, but 2014 fails.  I'll open a separate bug.
Comment 8 Andrius Štikonas 2015-07-13 10:26:43 UTC
This stabilization request slightly broken my dependencies. media-sound/lilypond requires both dev-texlive/texlive-metapost-2014 and dev-tex/metapost-1.803 but dev-tex/metapost was not stabilized.
Comment 9 Pacho Ramos gentoo-dev 2015-07-13 18:54:34 UTC
This is our script:
https://cgit.gentoo.org/proj/gnome.git/tree/scripts/gen_archlist.py

It was recently refactored by Gilles but I haven't yet tried it... maybe you could give it a try ;)
https://cgit.gentoo.org/proj/gnome.git/tree/scripts/gen_archlist.py?h=gen_archlist_cleanup
Comment 10 Pacho Ramos gentoo-dev 2015-07-13 18:55:38 UTC
Ah, for using it in cases (like mine) running a stable tree, you will need to, at first, keyword locally the packages that you want to stabilize (in general I have all packages maintained by us added to keywords file ;))
Comment 11 Christian Tietz 2015-07-14 11:22:44 UTC
=app-text/ttf2pk2-2.0_p20140525 is missing too.
Comment 12 Jeroen Roovers (RETIRED) gentoo-dev 2015-07-20 04:44:36 UTC
Maybe add some arch teams?
Comment 13 Anthony Basile gentoo-dev 2015-07-20 12:00:11 UTC
(In reply to Jeroen Roovers from comment #12)
> Maybe add some arch teams?

Its a complex set of packages so I was trying to get the list straight.  Let's see what the arch teams come up with:

KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86"
Comment 14 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2015-07-22 15:09:43 UTC
amd64 was stabilized by ago
Comment 15 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2015-07-22 15:22:15 UTC
x86 was stabilized by me a week ago, too
Comment 16 Anthony Basile gentoo-dev 2015-07-22 19:55:06 UTC
1. I now marked the set stable for ppc.

2.(In reply to Andrius Štikonas from comment #8)
> This stabilization request slightly broken my dependencies.
> media-sound/lilypond requires both dev-texlive/texlive-metapost-2014 and
> dev-tex/metapost-1.803 but dev-tex/metapost was not stabilized.

This makes no sense because no versions of dev-tex/metapost is stable:

Keywords for dev-tex/metapost:
      |                               | u   |  
      | a a   a         n   p     s   | n   |  
      | l m   r h i m m i   p s   p   | u s | r
      | p d a m p a 6 i o p c 3   a x | s l | e
      | h 6 r 6 p 6 8 p s p 6 9 s r 8 | e o | p
      | a 4 m 4 a 4 k s 2 c 4 0 h c 6 | d t | o
------+-------------------------------+-----+-------
1.780 | o ~ o o o o o o o o o o o o o | # 0 | gentoo
1.803 | o ~ o o o o o o o o o o o o o | #   | gentoo
1.902 | o ~ o o o o o o o o o o o o o | o   | gentoo


3. (In reply to Christian Tietz from comment #11)
> =app-text/ttf2pk2-2.0_p20140525 is missing too.

I marked this stable fro amd64, ppc and x86.  It should be added to the above list.
Comment 17 Jeroen Roovers (RETIRED) gentoo-dev 2015-07-23 06:13:33 UTC
(In reply to Anthony Basile from comment #16)
> 3. (In reply to Christian Tietz from comment #11)
> > =app-text/ttf2pk2-2.0_p20140525 is missing too.
> 
> I marked this stable fro amd64, ppc and x86.  It should be added to the
> above list.

No, that's bug #555220.
Comment 18 Andrius Štikonas 2015-07-23 19:20:11 UTC
(In reply to Anthony Basile from comment #16)
> 2.(In reply to Andrius Štikonas from comment #8)
> > This stabilization request slightly broken my dependencies.
> > media-sound/lilypond requires both dev-texlive/texlive-metapost-2014 and
> > dev-tex/metapost-1.803 but dev-tex/metapost was not stabilized.
> 
> This makes no sense because no versions of dev-tex/metapost is stable:
> 
> Keywords for dev-tex/metapost:
>       |                               | u   |  
>       | a a   a         n   p     s   | n   |  
>       | l m   r h i m m i   p s   p   | u s | r
>       | p d a m p a 6 i o p c 3   a x | s l | e
>       | h 6 r 6 p 6 8 p s p 6 9 s r 8 | e o | p
>       | a 4 m 4 a 4 k s 2 c 4 0 h c 6 | d t | o
> ------+-------------------------------+-----+-------
> 1.780 | o ~ o o o o o o o o o o o o o | # 0 | gentoo
> 1.803 | o ~ o o o o o o o o o o o o o | #   | gentoo
> 1.902 | o ~ o o o o o o o o o o o o o | o   | gentoo

Exaclty, no version of metapost is stable. lilypond depends on

        || (
                ( >=dev-texlive/texlive-metapost-2013 >=dev-tex/metapost-1.803 )
                <dev-texlive/texlive-metapost-2013
        )
so it didn't need stable versions of metapost before texlive 2013. But now it wants both texlive-metapost and metapost. Why doesn't this make sense?
Comment 19 Sergey S. Starikoff 2015-08-25 14:34:03 UTC
Please, note that stabilisation of =app-text/texlive-2014 breaks eskdx package in =dev-texlive/texlive-langcyrillic-2014.
Example file and patch see in bug #558682
Comment 20 Markus Meier gentoo-dev 2015-12-03 19:30:33 UTC
at least arm seems to be missing some packages, this is the output when trying to emerge the given list:

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by dev-tex/bibtexu-3.71_p20150521::gentoo
# required by app-text/texlive-core-2014-r4::gentoo
# required by dev-texlive/texlive-langeuropean-2014::gentoo
# required by =dev-texlive/texlive-langeuropean-2014 (argument)
=dev-libs/kpathsea-6.2.1_p20150521 ~arm
# required by app-text/texlive-core-2014-r4::gentoo
# required by dev-texlive/texlive-langeuropean-2014::gentoo
# required by =dev-texlive/texlive-langeuropean-2014 (argument)
=dev-tex/bibtexu-3.71_p20150521 ~arm
# required by app-text/texlive-core-2014-r4::gentoo[cjk]
# required by dev-texlive/texlive-langeuropean-2014::gentoo
# required by =dev-texlive/texlive-langeuropean-2014 (argument)
=dev-libs/ptexenc-1.3.3_p20150521 ~arm
# required by app-text/texlive-core-2014-r4::gentoo
# required by dev-texlive/texlive-langeuropean-2014::gentoo
# required by =dev-texlive/texlive-langeuropean-2014 (argument)
=app-text/ps2pkm-1.7_p20150521 ~arm
# required by app-text/texlive-core-2014-r4::gentoo
# required by dev-texlive/texlive-langeuropean-2014::gentoo
# required by =dev-texlive/texlive-langeuropean-2014 (argument)
=app-text/dvipsk-5.995_p20150521 ~arm

Not sure if these are the correct versions to stabilize...
Comment 21 Alexis Ballier gentoo-dev 2015-12-04 11:27:17 UTC
(In reply to Markus Meier from comment #20)
> at least arm seems to be missing some packages, this is the output when
> trying to emerge the given list:
> 
> The following keyword changes are necessary to proceed:
>  (see "package.accept_keywords" in the portage(5) man page for more details)
> =dev-libs/kpathsea-6.2.1_p20150521 ~arm
> =dev-tex/bibtexu-3.71_p20150521 ~arm
> =dev-libs/ptexenc-1.3.3_p20150521 ~arm
> =app-text/ps2pkm-1.7_p20150521 ~arm
> =app-text/dvipsk-5.995_p20150521 ~arm
> 
> Not sure if these are the correct versions to stabilize...

they're not: portage pulls in latest ~arch; you should use _p20140525 versions

(did I already post that? can't seem to find it now)
Comment 22 Markus Meier gentoo-dev 2015-12-06 20:05:42 UTC
arm stable
Comment 23 Agostino Sarubbo gentoo-dev 2016-12-28 08:38:22 UTC
Dear Maintainer (or who is mainly involved in this stable request),

This is an auto-generated message that will move the current component to the new component Stabilization.
To ensure that the stabilization will proceed correctly, please fill the fields "Atoms to stabilize" and "Runtime testing required" as described here:
https://archives.gentoo.org/gentoo-dev/message/4b2ef0e9aa7588224b8ae799c5fe31fa
Comment 24 Michael Palimaka (kensington) gentoo-dev 2016-12-30 14:57:28 UTC
An automated check of this bug failed - repoman reported dependency errors (278 lines truncated): 

> dependency.bad dev-texlive/texlive-langkorean/texlive-langkorean-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langkorean/texlive-langkorean-2014.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langkorean/texlive-langkorean-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad app-text/dvipsk/dvipsk-5.994_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad app-text/dvipsk/dvipsk-5.994_p20140525.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad app-text/dvipsk/dvipsk-5.994_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad app-text/ps2pkm/ps2pkm-1.5_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad app-text/ps2pkm/ps2pkm-1.5_p20140525.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad app-text/ps2pkm/ps2pkm-1.5_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad dev-texlive/texlive-pictures/texlive-pictures-2014.ebuild: DEPEND: hppa(default/linux/hppa/13.0) ['>=dev-tex/pgf-3.0.1']
> dependency.bad dev-texlive/texlive-pictures/texlive-pictures-2014.ebuild: RDEPEND: hppa(default/linux/hppa/13.0) ['>=dev-tex/pgf-3.0.1']
> dependency.bad dev-texlive/texlive-pictures/texlive-pictures-2014.ebuild: DEPEND: ppc64(default/linux/powerpc/ppc64/13.0/64bit-userland) ['>=dev-tex/pgf-3.0.1']
> dependency.bad dev-texlive/texlive-langjapanese/texlive-langjapanese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langjapanese/texlive-langjapanese-2014.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langjapanese/texlive-langjapanese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langchinese/texlive-langchinese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langchinese/texlive-langchinese-2014.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langchinese/texlive-langchinese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
Comment 25 Michael Palimaka (kensington) gentoo-dev 2016-12-31 14:43:35 UTC
An automated check of this bug failed - repoman reported dependency errors (265 lines truncated): 

> dependency.bad app-text/dvipsk/dvipsk-5.994_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad app-text/dvipsk/dvipsk-5.994_p20140525.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad app-text/dvipsk/dvipsk-5.994_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad dev-texlive/texlive-langjapanese/texlive-langjapanese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langjapanese/texlive-langjapanese-2014.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langjapanese/texlive-langjapanese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad app-text/ps2pkm/ps2pkm-1.5_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad app-text/ps2pkm/ps2pkm-1.5_p20140525.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad app-text/ps2pkm/ps2pkm-1.5_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad dev-texlive/texlive-langkorean/texlive-langkorean-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langkorean/texlive-langkorean-2014.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langkorean/texlive-langkorean-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langchinese/texlive-langchinese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langchinese/texlive-langchinese-2014.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langchinese/texlive-langchinese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
Comment 26 Pacho Ramos gentoo-dev 2016-12-31 15:22:55 UTC
(In reply to Michael Palimaka (kensington) from comment #25)
> An automated check of this bug failed - repoman reported dependency errors
> (265 lines truncated): 
> 
> > dependency.bad app-text/dvipsk/dvipsk-5.994_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> > dependency.bad app-text/dvipsk/dvipsk-5.994_p20140525.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> > dependency.bad app-text/dvipsk/dvipsk-5.994_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> > dependency.bad dev-texlive/texlive-langjapanese/texlive-langjapanese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> > dependency.bad dev-texlive/texlive-langjapanese/texlive-langjapanese-2014.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> > dependency.bad dev-texlive/texlive-langjapanese/texlive-langjapanese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> > dependency.bad app-text/ps2pkm/ps2pkm-1.5_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> > dependency.bad app-text/ps2pkm/ps2pkm-1.5_p20140525.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> > dependency.bad app-text/ps2pkm/ps2pkm-1.5_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> > dependency.bad dev-texlive/texlive-langkorean/texlive-langkorean-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> > dependency.bad dev-texlive/texlive-langkorean/texlive-langkorean-2014.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> > dependency.bad dev-texlive/texlive-langkorean/texlive-langkorean-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> > dependency.bad dev-texlive/texlive-langchinese/texlive-langchinese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> > dependency.bad dev-texlive/texlive-langchinese/texlive-langchinese-2014.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> > dependency.bad dev-texlive/texlive-langchinese/texlive-langchinese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']

All that packages are listed in the atom list :/
Comment 27 Michael Palimaka (kensington) gentoo-dev 2016-12-31 15:35:18 UTC
(In reply to Pacho Ramos from comment #26)
> (In reply to Michael Palimaka (kensington) from comment #25)
> > An automated check of this bug failed - repoman reported dependency errors
> > (265 lines truncated): 
> > 
> > > dependency.bad app-text/dvipsk/dvipsk-5.994_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> > > dependency.bad app-text/dvipsk/dvipsk-5.994_p20140525.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> > > dependency.bad app-text/dvipsk/dvipsk-5.994_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> > > dependency.bad dev-texlive/texlive-langjapanese/texlive-langjapanese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> > > dependency.bad dev-texlive/texlive-langjapanese/texlive-langjapanese-2014.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> > > dependency.bad dev-texlive/texlive-langjapanese/texlive-langjapanese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> > > dependency.bad app-text/ps2pkm/ps2pkm-1.5_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> > > dependency.bad app-text/ps2pkm/ps2pkm-1.5_p20140525.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> > > dependency.bad app-text/ps2pkm/ps2pkm-1.5_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> > > dependency.bad dev-texlive/texlive-langkorean/texlive-langkorean-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> > > dependency.bad dev-texlive/texlive-langkorean/texlive-langkorean-2014.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> > > dependency.bad dev-texlive/texlive-langkorean/texlive-langkorean-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> > > dependency.bad dev-texlive/texlive-langchinese/texlive-langchinese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> > > dependency.bad dev-texlive/texlive-langchinese/texlive-langchinese-2014.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> > > dependency.bad dev-texlive/texlive-langchinese/texlive-langchinese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> 
> All that packages are listed in the atom list :/

repoman is complaining correctly because these packages are hard-masked on ia64:

arch/ia64/package.mask:>=dev-libs/kpathsea-6.1.1_p20130530
arch/ia64/package.mask:>=app-text/texlive-core-2013
Comment 28 Stabilization helper bot gentoo-dev 2017-01-04 07:37:07 UTC
An automated check of this bug failed - repoman reported dependency errors (265 lines truncated): 

> dependency.bad dev-texlive/texlive-langchinese/texlive-langchinese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langchinese/texlive-langchinese-2014.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langchinese/texlive-langchinese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langkorean/texlive-langkorean-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langkorean/texlive-langkorean-2014.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langkorean/texlive-langkorean-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad app-text/ps2pkm/ps2pkm-1.5_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad app-text/ps2pkm/ps2pkm-1.5_p20140525.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad app-text/ps2pkm/ps2pkm-1.5_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad dev-texlive/texlive-langjapanese/texlive-langjapanese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langjapanese/texlive-langjapanese-2014.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langjapanese/texlive-langjapanese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad app-text/dvipsk/dvipsk-5.994_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad app-text/dvipsk/dvipsk-5.994_p20140525.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad app-text/dvipsk/dvipsk-5.994_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
Comment 29 Pacho Ramos gentoo-dev 2017-01-16 09:20:29 UTC
@aballier, could you please take a look on the blocking bugs? Otherwise I doubt the remaining arches will stabilize... ever... 

Or, maybe, if we are on time for stabilizing a new texlive, maybe they could skip this and jump to the new one :/
Comment 30 Alexis Ballier gentoo-dev 2017-01-16 11:00:02 UTC
(In reply to Pacho Ramos from comment #29)
> @aballier, could you please take a look on the blocking bugs? Otherwise I
> doubt the remaining arches will stabilize... ever... 
> 
> Or, maybe, if we are on time for stabilizing a new texlive, maybe they could
> skip this and jump to the new one :/

Bug #554376 should be skipped and the relevant flag masked for tl-core-2015 if it still fails

Bug #604400 is long overdue...
Comment 31 Tobias Klausmann (RETIRED) gentoo-dev 2017-01-16 14:48:34 UTC
(In reply to Alexis Ballier from comment #30)
> (In reply to Pacho Ramos from comment #29)
> > @aballier, could you please take a look on the blocking bugs? Otherwise I
> > doubt the remaining arches will stabilize... ever... 
> > 
> > Or, maybe, if we are on time for stabilizing a new texlive, maybe they could
> > skip this and jump to the new one :/
> 
> Bug #554376 should be skipped and the relevant flag masked for tl-core-2015
> if it still fails

Skipped as in: no -2014 for those archs? Is there a -2015 stable bug we can use in favor of thos one?

> Bug #604400 is long overdue...

I can only speak for alpha, which is not affected by that bug.
Comment 32 Alexis Ballier gentoo-dev 2017-01-16 14:52:23 UTC
(In reply to Tobias Klausmann from comment #31)
> (In reply to Alexis Ballier from comment #30)
> > (In reply to Pacho Ramos from comment #29)
> > > @aballier, could you please take a look on the blocking bugs? Otherwise I
> > > doubt the remaining arches will stabilize... ever... 
> > > 
> > > Or, maybe, if we are on time for stabilizing a new texlive, maybe they could
> > > skip this and jump to the new one :/
> > 
> > Bug #554376 should be skipped and the relevant flag masked for tl-core-2015
> > if it still fails
> 
> Skipped as in: no -2014 for those archs? Is there a -2015 stable bug we can
> use in favor of thos one?

yep

I was planning to use bug #432144 but haven't gotten around to compile a complete list yet (help more than welcome!)
Comment 33 Stabilization helper bot gentoo-dev 2017-01-16 22:09:37 UTC
An automated check of this bug failed - repoman reported dependency errors (265 lines truncated): 

> dependency.bad dev-texlive/texlive-langchinese/texlive-langchinese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langchinese/texlive-langchinese-2014.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langchinese/texlive-langchinese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad app-text/dvipsk/dvipsk-5.994_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad app-text/dvipsk/dvipsk-5.994_p20140525.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad app-text/dvipsk/dvipsk-5.994_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad dev-texlive/texlive-langkorean/texlive-langkorean-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langkorean/texlive-langkorean-2014.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langkorean/texlive-langkorean-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad app-text/ps2pkm/ps2pkm-1.5_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad app-text/ps2pkm/ps2pkm-1.5_p20140525.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad app-text/ps2pkm/ps2pkm-1.5_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad dev-texlive/texlive-langjapanese/texlive-langjapanese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langjapanese/texlive-langjapanese-2014.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langjapanese/texlive-langjapanese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
Comment 34 Tobias Klausmann (RETIRED) gentoo-dev 2017-01-22 08:20:10 UTC
Since Alpha has -2015 stable due to bug 432144, we're going to skip this one.
Comment 35 Stabilization helper bot gentoo-dev 2017-01-22 09:19:00 UTC
An automated check of this bug failed - repoman reported dependency errors (265 lines truncated): 

> dependency.bad dev-texlive/texlive-langchinese/texlive-langchinese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langchinese/texlive-langchinese-2014.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langchinese/texlive-langchinese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad app-text/ps2pkm/ps2pkm-1.5_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad app-text/ps2pkm/ps2pkm-1.5_p20140525.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad app-text/ps2pkm/ps2pkm-1.5_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad dev-texlive/texlive-langjapanese/texlive-langjapanese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langjapanese/texlive-langjapanese-2014.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langjapanese/texlive-langjapanese-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langkorean/texlive-langkorean-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langkorean/texlive-langkorean-2014.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad dev-texlive/texlive-langkorean/texlive-langkorean-2014.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-texlive/texlive-langcjk-2014', '>=app-text/texlive-core-2014']
> dependency.bad app-text/dvipsk/dvipsk-5.994_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad app-text/dvipsk/dvipsk-5.994_p20140525.ebuild: RDEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
> dependency.bad app-text/dvipsk/dvipsk-5.994_p20140525.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-libs/kpathsea-6.2.0']
Comment 36 Pacho Ramos gentoo-dev 2017-01-22 11:12:21 UTC
It will be better to jump to bug 432144 instead of duplicating the work here