Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 550184 - net-im/bitlbee-facebook: Facebook protocol plugin for BitlBee
Summary: net-im/bitlbee-facebook: Facebook protocol plugin for BitlBee
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Alex Xu (Hello71)
URL:
Whiteboard:
Keywords: EBUILD, Inclusion, PATCH
Depends on:
Blocks:
 
Reported: 2015-05-22 18:22 UTC by piotr5
Modified: 2017-11-17 18:47 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
bitlbee-facebook-9999.ebuild (bitlbee-facebook-9999.ebuild,673 bytes, text/plain)
2015-12-04 14:42 UTC, Petr Vaněk
Details
bitlbee-facebook-1.0.0.ebuild (bitlbee-facebook-1.0.0.ebuild,706 bytes, text/plain)
2016-01-18 09:39 UTC, Petr Vaněk
Details
bitlbee-facebook-1.0.0.ebuild (bitlbee-facebook-1.0.0.ebuild,620 bytes, text/plain)
2016-03-06 00:58 UTC, Alex Xu (Hello71)
Details
0003-net-im-bitlbee-facebook-New-ebuild.patch (0003-net-im-bitlbee-facebook-New-ebuild.patch,3.38 KB, patch)
2016-04-23 19:41 UTC, Alex Xu (Hello71)
Details | Diff
net-im-bitlbee-facebook-bump-to-1.4.1.patch (net-im-bitlbee-facebook-bump-to-1.4.1.patch,3.01 KB, patch)
2016-09-18 14:54 UTC, Alex Xu (Hello71)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description piotr5 2015-05-22 18:22:22 UTC
since libpurple doesn't support facebook chat anymore, the only alternative (apart from going to www.messenger.com in your browser) is now bitlbee with custom-built https://github.com/jgeboski/bitlbee-facebook (using the mobile facebook-api) and the stand-alone client https://github.com/Aluxian/Facebook-Messenger-Desktop which is a wrapper for a html-viewer opening that www.messenger.com, packaged up for debian. (something similar to the latter is also available for internet-explorer11 at http://www.neowin.net/forum/topic/1253174-messenger-the-windows-desktop-messenger-client/ where you probably can request the c# sourcecode -- if you want to create your own version or compare sourcecode for checking copyrights.)

Reproducible: Always
Comment 1 Petr Vaněk 2015-12-04 14:42:43 UTC
Created attachment 418562 [details]
bitlbee-facebook-9999.ebuild
Comment 2 Petr Vaněk 2015-12-04 14:48:29 UTC
Bitlbee-facebook does not have an official release yet. I attached an ebuild that builds the plugin from github repository. It works for me with bitlbee-3.4.1 version.
Comment 3 Petr Vaněk 2016-01-18 09:39:57 UTC
Created attachment 423212 [details]
bitlbee-facebook-1.0.0.ebuild

The first release of bitlbee-facebook is out. This is an ebuild for it.
Comment 4 Alex Xu (Hello71) 2016-03-06 00:58:01 UTC
Created attachment 427544 [details]
bitlbee-facebook-1.0.0.ebuild
Comment 5 Alex Xu (Hello71) 2016-03-06 01:00:37 UTC
CCing bitlbee maintainers, are you interested in maintaining this package?

otherwise, I will proxy-maintain it.

also CCing upstream FYI, no action is required (unless you also want to proxy-maintain)
Comment 6 James Geboski (jgeboski) 2016-03-06 02:12:15 UTC
Go for it!
Comment 7 Alex Xu (Hello71) 2016-04-23 19:41:34 UTC
Created attachment 431728 [details, diff]
0003-net-im-bitlbee-facebook-New-ebuild.patch
Comment 8 Alex Xu (Hello71) 2016-09-18 14:54:37 UTC
Created attachment 446426 [details, diff]
net-im-bitlbee-facebook-bump-to-1.4.1.patch

fix upstream metadata, Manifest
Comment 9 Larry the Git Cow gentoo-dev 2017-11-17 18:47:02 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=61413c4e36893de158a1f3e58b606c4ac1032f6d

commit 61413c4e36893de158a1f3e58b606c4ac1032f6d
Author:     Petr Vaněk <arkamar@atlas.cz>
AuthorDate: 2017-11-17 17:06:02 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2017-11-17 18:38:44 +0000

    net-im/bitlbee-facebook: New ebuild
    
    Closes: https://bugs.gentoo.org/550184
    Package-Manager: Portage-2.3.13, Repoman-2.3.3

 net-im/bitlbee-facebook/Manifest                   |  1 +
 .../bitlbee-facebook/bitlbee-facebook-1.1.2.ebuild | 38 ++++++++++++++++++++++
 .../bitlbee-facebook/bitlbee-facebook-9999.ebuild  | 38 ++++++++++++++++++++++
 net-im/bitlbee-facebook/metadata.xml               | 24 ++++++++++++++
 4 files changed, 101 insertions(+)