Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 549766 - app-emulation/virtualbox - gcc version 5.3 found, expected gcc 3.x with x>1 or gcc 4.x with 0<x<10 or gcc 5.2!
Summary: app-emulation/virtualbox - gcc version 5.3 found, expected gcc 3.x with x>1 o...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
: 556140 568492 568574 (view as bug list)
Depends on:
Blocks: gcc-5
  Show dependency tree
 
Reported: 2015-05-17 22:46 UTC by jospezial
Modified: 2016-11-21 00:03 UTC (History)
19 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
disable gcc check (gcc5.patch,328 bytes, patch)
2015-05-29 16:25 UTC, Christoph Junghans
Details | Diff
disable gcc check virtualbox-5.0.2 (gcc5.patch,286 bytes, patch)
2015-08-17 11:32 UTC, jospezial
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description jospezial 2015-05-17 22:46:09 UTC
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/app-emulation/virtualbox-4.3.28/work/VirtualBox-4.3.28 ...
Checking for environment: Determined build machine: linux.amd64, target machine: linux.amd64, OK.
Checking for kBuild: found, OK.
Checking for gcc: 
  ** gcc version 5.1.0 found, expected gcc 3.x with x>1 or gcc 4.x with 0<x<10!
Check /var/tmp/portage/app-emulation/virtualbox-4.3.28/work/VirtualBox-4.3.28/configure.log for details
 * ERROR: app-emulation/virtualbox-4.3.28::gentoo failed (configure phase):
 *   configure failed
 * 
 * Call stack:
 *     ebuild.sh, line  93:  Called src_configure
 *   environment, line 5943:  Called die
 * The specific snippet of code:
 *       ./configure --with-gcc="$(tc-getCC)" --with-g++="$(tc-getCXX)" --disable-kmods --disable-dbus --disable-devmapper ${myconf} || die "configure failed"
 *
Comment 1 jospezial 2015-05-17 23:36:48 UTC
after removing the gcc check in configure I was able to let it compile a lot.
Until this error:

pdflatex: not found
pdflatex: not found
pdflatex: not found
pdflatex: not found
  pdflatex {T}/manual/en_US/UserManual.tex (four passes) -> {T}/manual/en_US/UserManual.pdf 
/usr/bin/kmk_redirect -w+ti /dev/null -C /var/tmp/portage/app-emulation/virtualbox-4.3.28/work/VirtualBox-4.3.28/out/linux.amd64/release/obj/manual/en_US -- pdflatex  -interaction batchmode UserManual.tex
kmk_redirect: error: _execvp(_P_WAIT, "pdflatex", ...) failed: No such file or directory
kmk: *** [/var/tmp/portage/app-emulation/virtualbox-4.3.28/work/VirtualBox-4.3.28/out/linux.amd64/release/obj/manual/en_US/UserManual.pdf] Error 1
Comment 2 jospezial 2015-05-17 23:49:49 UTC
and why does it something with "UserManual" when USE="-doc" ? do we need -handbook or something?

[ebuild     U  ] app-emulation/virtualbox-4.3.28::gentoo [4.3.26::gentoo] USE="additions alsa extensions java opengl pam pulseaudio python qt4 sdk udev vnc -doc -headless -vboxwebsrv" PYTHON_TARGETS="python2_7" 0 KiB
Comment 3 jospezial 2015-05-18 01:29:19 UTC
pdflatex is part of dev-texlive/texlive-latex-2014.
After installing that the error changes:

  INST generate_service_file => {C}/out/linux.amd64/release/bin/helpers/generate_service_file
kmk_builtin_install --hard-link-files-when-possible    -- /var/tmp/portage/app-emulation/virtualbox-4.3.28/work/VirtualBox-4.3.28/out/linux.amd64/release/obj/generate_service_file/generate_service_file /var/tmp/portage/app-emulation/virtualbox-4.3.28/work/VirtualBox-4.3.28/out/linux.amd64/release/bin/helpers/generate_service_file
  pdflatex {T}/manual/en_US/UserManual.tex (four passes) -> {T}/manual/en_US/UserManual.pdf 
/usr/bin/kmk_redirect -w+ti /dev/null -C /var/tmp/portage/app-emulation/virtualbox-4.3.28/work/VirtualBox-4.3.28/out/linux.amd64/release/obj/manual/en_US -- pdflatex -halt-on-error -interaction batchmode UserManual.tex
This is pdfTeX, Version 3.14159265-2.6-1.40.15 (TeX Live 2014) (preloaded format=pdflatex)
 restricted \write18 enabled.
entering extended mode
kmk: *** [/var/tmp/portage/app-emulation/virtualbox-4.3.28/work/VirtualBox-4.3.28/out/linux.amd64/release/obj/manual/en_US/UserManual.pdf] Error 1
Comment 4 jospezial 2015-05-19 20:12:36 UTC
How I got the package merged:
emerge with USE="doc" (fails at virtualbox because of gcc check)
Now we have a ton of depending latex stuff installed.
clear portage temp dir
ebuild unpack
modify Configure to give always success on gcc version.
ebuild merge

The pdflatex bugs only exist if some latex packages are missing.
Is "-doc" broken?


app-emulation/virtualbox-4.3.28::gentoo was built with the following:
USE="additions alsa extensions java opengl pam pulseaudio python qt4 sdk udev vnc -doc -headless -vboxwebsrv" ABI_X86="64" PYTHON_TARGETS="python2_7"
Comment 5 Christoph Junghans gentoo-dev 2015-05-29 16:24:42 UTC
I can confirm the issue and disabling the gcc check helps.
Comment 6 Christoph Junghans gentoo-dev 2015-05-29 16:25:27 UTC
Created attachment 404276 [details, diff]
disable gcc check
Comment 7 Lars Wendler (Polynomial-C) gentoo-dev 2015-07-16 09:25:48 UTC

*** This bug has been marked as a duplicate of bug 555052 ***
Comment 8 Ryan Hill (RETIRED) gentoo-dev 2015-07-29 02:13:00 UTC
*** Bug 556140 has been marked as a duplicate of this bug. ***
Comment 9 jospezial 2015-08-17 10:52:32 UTC
Not fixed in virtualbox-5.0.2 .
Comment 10 jospezial 2015-08-17 11:32:56 UTC
Created attachment 409242 [details, diff]
disable gcc check virtualbox-5.0.2

does the same as the other patch

applies to virtualbox-5.0.2
Comment 11 jospezial 2015-09-08 22:26:59 UTC
(In reply to jospezial from comment #10)
> Created attachment 409242 [details, diff] [details, diff]
> disable gcc check virtualbox-5.0.2
> 
> does the same as the other patch
> 
> applies to virtualbox-5.0.2

And still needed for app-emulation/virtualbox-5.0.4
Comment 12 jospezial 2015-10-03 14:23:10 UTC
fixed in virtualbox-5.0.6
Comment 13 jospezial 2015-12-06 23:40:22 UTC
Bug is back again with gcc-5.3

When will they ever disable that version check?
Comment 14 Zentoo 2015-12-15 19:40:23 UTC
I confirm too that VirtualBox emerge break at gcc check with gcc 5.3:

>>> Emerging (1 of 1) app-emulation/virtualbox-5.0.10::gentoo
 * VirtualBox-5.0.10.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) [ ok ]
 * virtualbox-5.0.2-patches-01.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) [ ok ]
 * You have disabled the "python" USE flag. This will only
 * disable the python bindings being installed.
>>> Unpacking source...
>>> Unpacking VirtualBox-5.0.10.tar.bz2 to /gentoo/tmp/portage/app-emulation/virtualbox-5.0.10/work
>>> Unpacking virtualbox-5.0.2-patches-01.tar.xz to /gentoo/tmp/portage/app-emulation/virtualbox-5.0.10/work
>>> Source unpacked in /gentoo/tmp/portage/app-emulation/virtualbox-5.0.10/work
>>> Preparing source in /gentoo/tmp/portage/app-emulation/virtualbox-5.0.10/work/VirtualBox-5.0.10 ...
 * Applying various patches (bugfixes/updates) ...
 *   001_virtualbox-ose-3.2.8-mesa-check.patch [ ok ]
 *   002_virtualbox-5.0.0_beta3-remove-configure-checks.patch [ ok ]
 *   003_virtualbox-4.0.2-restore_old_machines_dir.patch  [ ok ]
 *   004_virtualbox-4.1.2-vboxpci-build.patch [ ok ]
 *   005_virtualbox-4.2.26-asneeded.patch [ ok ]
 *   006_virtualbox-4.2.18-vboxwebsrv_fix.patch [ ok ]
 *   Skipping 007_virtualbox-4.3.16-gsoap2813.patch due to EPATCH_EXCLUDE ...
 *   008_virtualbox-4.3.14-missing_define.patch [ ok ]
 *   050_virtualbox-5.0.2-nopie.patch [ ok ]
 * Done with patching
>>> Source prepared.
>>> Configuring source in /gentoo/tmp/portage/app-emulation/virtualbox-5.0.10/work/VirtualBox-5.0.10 ...
Checking for environment: Determined build machine: linux.amd64, target machine: linux.amd64, OK.
Checking for kBuild: found, OK.
Checking for gcc: 
  ** gcc version 5.3 found, expected gcc 3.x with x>1 or gcc 4.x with 0<x<10 or gcc 5.2!
Comment 15 Lars Wendler (Polynomial-C) gentoo-dev 2015-12-17 05:20:03 UTC
*** Bug 568492 has been marked as a duplicate of this bug. ***
Comment 16 email200202 2015-12-17 07:54:13 UTC
The problem is still there in app-emulation/virtualbox-5.0.10 on ~amd

Checking for gcc: 
  ** gcc version 5.3 found, expected gcc 3.x with x>1 or gcc 4.x with 0<x<10 or gcc 5.2!
Check /var/tmp/portage/app-emulation/virtualbox-5.0.10/work/VirtualBox-5.0.10/configure.log for details
 * ERROR: app-emulation/virtualbox-5.0.10::gentoo failed (configure phase):
Comment 17 William 2015-12-17 21:25:40 UTC
> The problem is still there in app-emulation/virtualbox-5.0.10 on ~amd

Can confirm, with gcc 5.3.0.
Comment 18 Lars Wendler (Polynomial-C) gentoo-dev 2015-12-17 22:52:58 UTC
*** Bug 568574 has been marked as a duplicate of this bug. ***
Comment 19 Tommy Holmgren 2015-12-18 00:34:15 UTC
Same here, gcc 5.3.0
Comment 20 equeim 2015-12-19 16:36:26 UTC
5.3 compatibility is fixed in 5.0.12
Comment 21 dE 2016-05-22 08:32:03 UTC
Switching to Gcc 4.x will not fix this since 5.x and 4.x C++ ABI is incompatible.
Comment 22 Andreas Sturmlechner gentoo-dev 2016-08-25 22:35:12 UTC
This should be fixed in >=5.0.16-r1 since:

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=f83513963afe06880885c2def91b267ccb6bc4e7
app-emulation/virtualbox: Remove pointless GCC limitations