Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 548312 - sys-apps/memtest86+-5.01 (and earlier) do not compile with gcc-5.1
Summary: sys-apps/memtest86+-5.01 (and earlier) do not compile with gcc-5.1
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords: PATCH
: 607692 (view as bug list)
Depends on:
Blocks: gcc-5
  Show dependency tree
 
Reported: 2015-05-01 10:26 UTC by Martin Väth
Modified: 2017-02-09 15:25 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Add -std=gnu90 to fix compilation with gcc-5 (memtest86+-gcc-5.patch,291 bytes, patch)
2015-05-01 10:26 UTC, Martin Väth
Details | Diff
build log (sys-apps:memtest86+-5.01:20150504-101227.log,9.79 KB, text/plain)
2015-05-04 10:16 UTC, Martin Väth
Details
alternative patch for gcc-5.2.0 (memtest86+-5.01-gcc-5.patch,843 bytes, patch)
2015-07-23 08:20 UTC, Helmut Jarausch
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Väth 2015-05-01 10:26:43 UTC
Created attachment 402378 [details, diff]
Add -std=gnu90 to fix compilation with gcc-5

memtest86+-5.01 relies on C90 behaviour for linking and thus will not link with gcc-5.

Apparently, the code uses also special GNU features, so that -std=gnu90 has to be added to the CFLAGS.

Since the Makefile ignores passed CFLAGS, a patch (appended) is necesary.
Comment 1 Martin Väth 2015-05-04 10:16:52 UTC
Created attachment 402614 [details]
build log
Comment 2 jospezial 2015-07-22 22:00:54 UTC
That patch is still needed for

sys-apps/memtest86+-5.01-r1

with
sys-devel/gcc-5.2.0
Comment 3 Helmut Jarausch 2015-07-23 08:20:03 UTC
Created attachment 407434 [details, diff]
alternative patch for gcc-5.2.0
Comment 4 jospezial 2015-10-25 03:36:53 UTC
(In reply to Helmut Jarausch from comment #3)
> Created attachment 407434 [details, diff] [details, diff]
> alternative patch for gcc-5.2.0

Works with that patch. 

@base-system:
Please add it the patch to the tree!
Comment 5 xpue 2015-11-30 22:40:05 UTC
sys-apps/memtest86 (without plus) fails with same error too.
Comment 6 devsk 2015-12-10 18:54:54 UTC
Can someone please push the fix above into the tree?

This is the third build failure I encountered today, for which the patch is there but not pushed to the tree. Do we have shortage of gentoo devs in certain areas? Just curious. I haven't seen this abandonment of fixes before.
Comment 7 Andrew Savchenko gentoo-dev 2015-12-11 09:49:26 UTC
@base-system, is it OK to apply the first patch (--std=gnu90)?

Looks like the sanest solution, as breakage is caused by default C std switch to gnu11. Works fine for me here.
Comment 8 SpanKY gentoo-dev 2015-12-12 23:25:09 UTC
i've fixed it w/out having to mess with the C standard:
http://gitweb.gentoo.org/repo/gentoo.git/commit/?id=e5b24d52ab056fffa21763d8a8ed09c04f4ce539
Comment 9 SpanKY gentoo-dev 2017-02-09 15:25:18 UTC
*** Bug 607692 has been marked as a duplicate of this bug. ***