Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 548042 - dev-lang/mono failed to build with sys-devel/gcc-5.1
Summary: dev-lang/mono failed to build with sys-devel/gcc-5.1
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: Normal normal with 3 votes (vote)
Assignee: dotnet
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-5
  Show dependency tree
 
Reported: 2015-04-28 16:22 UTC by Vladimir B. Vinogradov
Modified: 2016-09-21 11:02 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log for =dev-lang/mono-3.2.8 (build.log,734.46 KB, text/plain)
2015-04-28 16:22 UTC, Vladimir B. Vinogradov
Details
emerge --info (emerge.info,5.41 KB, text/plain)
2015-04-28 16:23 UTC, Vladimir B. Vinogradov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir B. Vinogradov 2015-04-28 16:22:21 UTC
Created attachment 402182 [details]
build.log for =dev-lang/mono-3.2.8

dev-lang/mono failed to build with gcc-5.1

...libtool: link: x86_64-pc-linux-gnu-gcc -I/var/tmp/portage/dev-lang/mono-3.2.8/work/mono-3.2.8 -I/var/tmp/portage/dev-lang/mono-3.2.8/work/mono-3.2.8/eglib/src -I../../eglib/src -march=native -pipe -O2 -fno-strict-aliasing -fno-strict-aliasing -Wdeclaration-after-statement -Wno-unused-but-set-variable -g -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wno-cast-qual -Wwrite-strings -Wno-switch -Wno-switch-enum -Wno-unused-value -Werror-implicit-function-declaration -Wl,-version-script=/var/tmp/portage/dev-lang/mono-3.2.8/work/mono-3.2.8/mono/mini/ldscript.mono -Wl,-O1 -o mono-boehm mono_boehm-main.o -Wl,--export-dynamic  -Wl,--as-needed ./.libs/libmini-static.a ../../mono/metadata/.libs/libmonoruntime-static.a ../../mono/io-layer/.libs/libwapi.a ../../mono/utils/.libs/libmonoutils.a -L../../eglib/src ../../libgc/.libs/libmonogc-static.a /var/tmp/portage/dev-lang/mono-3.2.8/work/mono-3.2.8_build/eglib/src/.libs/libeglib.a -lm -lrt -ldl -lpthread
./.libs/libmini-static.a(libmini_static_la-mini.o): In function `mono_get_jit_tls_offset':
/var/tmp/portage/dev-lang/mono-3.2.8/work/mono-3.2.8/mono/mini/mini.c:2623: undefined reference to `mono_jit_tls'
/var/tmp/portage/dev-lang/mono-3.2.8/work/mono-3.2.8/mono/mini/mini.c:2623: undefined reference to `mono_jit_tls'
collect2: error: ld returned 1 exit status
Makefile:1226: recipe for target 'mono-boehm' failed
make[4]: *** [mono-boehm] Error 1
make[4]: *** Waiting for unfinished jobs....
./.libs/libmini-static.a(libmini_static_la-mini.o): In function `mono_get_jit_tls_offset':
/var/tmp/portage/dev-lang/mono-3.2.8/work/mono-3.2.8/mono/mini/mini.c:2623: undefined reference to `mono_jit_tls'
/var/tmp/portage/dev-lang/mono-3.2.8/work/mono-3.2.8/mono/mini/mini.c:2623: undefined reference to `mono_jit_tls'
../../mono/metadata/.libs/libmonoruntimesgen-static.a(libmonoruntimesgen_static_la-sgen-alloc.o): In function `create_allocator':
/var/tmp/portage/dev-lang/mono-3.2.8/work/mono-3.2.8/mono/metadata/sgen-alloc.c:704: undefined reference to `tlab_next_addr'
collect2: error: ld returned 1 exit status
Makefile:1229: recipe for target 'mono-sgen' failed
make[4]: *** [mono-sgen] Error 1
make[4]: Leaving directory '/var/tmp/portage/dev-lang/mono-3.2.8/work/mono-3.2.8_build/mono/mini'
Makefile:1068: recipe for target 'all' failed
make[3]: *** [all] Error 2
make[3]: Leaving directory '/var/tmp/portage/dev-lang/mono-3.2.8/work/mono-3.2.8_build/mono/mini'
Makefile:374: recipe for target 'all-recursive' failed
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory '/var/tmp/portage/dev-lang/mono-3.2.8/work/mono-3.2.8_build/mono'
Makefile:453: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/dev-lang/mono-3.2.8/work/mono-3.2.8_build'
Makefile:380: recipe for target 'all' failed
make: *** [all] Error 2
emake failed
 * ERROR: dev-lang/mono-3.2.8::gentoo failed (compile phase):
 *   emake failed
 * 
 * Call stack:
 *     ebuild.sh, line   93:  Called src_compile
 *   environment, line 3971:  Called nonfatal 'autotools-utils_src_compile'
 *   environment, line  105:  Called autotools-utils_src_compile
 *   environment, line  734:  Called die
 * The specific snippet of code:
 *       emake "$@" || die 'emake failed';
 * 
 * If you need support, post the output of `emerge --info '=dev-lang/mono-3.2.8::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-lang/mono-3.2.8::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-lang/mono-3.2.8/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-lang/mono-3.2.8/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-lang/mono-3.2.8/work/mono-3.2.8_build'
 * S: '/var/tmp/portage/dev-lang/mono-3.2.8/work/mono-3.2.8'

**********
Comment 1 Vladimir B. Vinogradov 2015-04-28 16:23:49 UTC
Created attachment 402184 [details]
emerge --info
Comment 2 octoploid 2015-04-30 18:17:11 UTC
It's a Mono bug: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=65953
Comment 3 Steffen Hau 2015-05-05 11:48:20 UTC
As far as I've seen, Mono 4.0.1 is not affected by this error.
Comment 4 Vladimir B. Vinogradov 2015-05-05 12:03:15 UTC
(In reply to Steffen Hau from comment #3)
> As far as I've seen, Mono 4.0.1 is not affected by this error.

= dev-lang/mono-3.2.8 - is the latest version in portage tree.
Comment 5 Steffen Hau 2015-05-05 13:32:21 UTC
I know, there is also a bump request out there #522836. I just wanted to see, if the issue is still present in the current upstream stable release.
Comment 6 Vladimir B. Vinogradov 2015-05-05 15:21:19 UTC
(In reply to Steffen Hau from comment #5)
> I know, there is also a bump request out there #522836. I just wanted to
> see, if the issue is still present in the current upstream stable release.

I confirm successful build of =dev-lang/mono-4.0.1 with gcc-5.1
I obtained ebuild from dotnet overlay.
Comment 7 Tom Li 2015-07-28 15:33:51 UTC
dev-lang/mono-3.12.1 doesn't build either.
Comment 8 Tom Li 2015-07-28 15:34:32 UTC
There is a simple patch from the Mono upstream which fixes the issue:

https://github.com/mono/mono/commit/16ee0252305fbd4f40ea39c3c4421dc7f103f8a0

I can build Mono without problem with GCC 5.2.
Comment 9 Tom Li 2015-07-28 16:04:30 UTC
The above patch was included into mono-4.0.0, and it can be used for earlier versions.
Comment 10 Andrius Štikonas 2016-09-13 15:24:44 UTC
Well, newer mono version is now stable. This bug can probably be closed.
Comment 11 Pacho Ramos gentoo-dev 2016-09-21 11:02:52 UTC
4.4.1.0 is being stabilized