Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 547900 - <app-office/libreoffice-4.4.2: Out of bounds write in HWP file filter (CVE-2015-1774)
Summary: <app-office/libreoffice-4.4.2: Out of bounds write in HWP file filter (CVE-20...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Security
URL: http://www.libreoffice.org/about-us/s...
Whiteboard: B2 [glsa]
Keywords:
: 550114 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-04-27 12:49 UTC by Agostino Sarubbo
Modified: 2016-03-09 18:11 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2015-04-27 12:49:24 UTC
From ${URL} :

Title: CVE-2015-1774 Out of bounds write in HWP file filter

Announced: April  27, 2015

Fixed in: LibreOffice 4.3.7/4.4.2

Description:

Certain crafted HWP documents can allow attackers to cause a denial of service or possibly the execution of arbitrary code by writing past the end of buffers.


All users are recommended to upgrade to LibreOffice 4.3.7 or 4.4.2.


@maintainer(s): after the bump, in case we need to stabilize the package, please let us know if it is ready for the stabilization or not.
Comment 1 Pacho Ramos gentoo-dev 2015-05-22 10:54:57 UTC
*** Bug 550114 has been marked as a duplicate of this bug. ***
Comment 2 Andreas K. Hüttel gentoo-dev 2015-05-22 23:31:14 UTC
Let's
1) go for 4.4.3.2 immediately
2) sync this with the icu-55.1 stabilization 
   (libreoffice-bin generation, just think of the climate...)

In preparation.
Comment 3 Andreas K. Hüttel gentoo-dev 2015-05-24 16:43:25 UTC
Arches please TEST (especially the binpkg) and stabilize, target "amd64 x86"

=app-office/libreoffice-4.4.3.2
=app-office/libreoffice-l10n-4.4.3.2
=app-office/libreoffice-bin-4.4.3.2
=app-office/libreoffice-bin-debug-4.4.3.2
=dev-util/mdds-0.12.0
=dev-libs/libixion-0.9.0
=dev-libs/liborcus-0.7.1
=dev-libs/icu-55.1

(for icu see also bug 546156 for the remaining arches)
Comment 4 Agostino Sarubbo gentoo-dev 2015-05-27 10:58:19 UTC
amd64 stable
Comment 5 Agostino Sarubbo gentoo-dev 2015-05-27 10:59:04 UTC
x86 stable.

Maintainer(s), please cleanup.
Security, please add it to the existing request, or file a new one.
Comment 6 Andreas K. Hüttel gentoo-dev 2015-05-29 20:26:19 UTC
All vulnerable versions removed. Office out.
Comment 7 GLSAMaker/CVETool Bot gentoo-dev 2015-06-15 00:13:12 UTC
CVE-2015-1774 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-1774):
  The HWP filter in LibreOffice before 4.3.7 and 4.4.x before 4.4.2 and Apache
  OpenOffice before 4.1.2 allows remote attackers to cause a denial of service
  (crash) or possibly execute arbitrary code via a crafted HWP document, which
  triggers an out-of-bounds write.
Comment 8 Yury German Gentoo Infrastructure gentoo-dev Security 2015-06-15 01:40:27 UTC
Arches and Maintainer(s), Thank you for your work.

Added to an existing GLSA Request.
Comment 9 GLSAMaker/CVETool Bot gentoo-dev 2016-03-09 18:11:10 UTC
This issue was resolved and addressed in
 GLSA 201603-05 at https://security.gentoo.org/glsa/201603-05
by GLSA coordinator Kristian Fiskerstrand (K_F).