Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 547566 - dev-libs/glib: fails at src_prepare hardened armv7 with gcc-4.8
Summary: dev-libs/glib: fails at src_prepare hardened armv7 with gcc-4.8
Status: RESOLVED DUPLICATE of bug 518598
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] baselayout (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-24 10:48 UTC by BRULE Herman
Modified: 2015-05-02 10:28 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,2.11 KB, text/x-log)
2015-04-24 10:48 UTC, BRULE Herman
Details
emerge info (info.txt,2.91 KB, text/plain)
2015-04-24 10:49 UTC, BRULE Herman
Details
emerge -pqv (emergepvq.txt,160 bytes, text/plain)
2015-04-24 11:00 UTC, BRULE Herman
Details
munin file into folder (munin.log,15.06 KB, text/x-log)
2015-04-26 22:50 UTC, BRULE Herman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description BRULE Herman 2015-04-24 10:48:56 UTC
Created attachment 401902 [details]
build.log

>>> Emerging (1 of 1) dev-libs/glib-2.40.2::gentoo
openpty failed: 'out of pty devices'
 * glib-2.40.2.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                                                                                              [ ok ]
 * pkg-config-0.28.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                                                                                          [ ok ]
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found sources for kernel version:
 *     3.18.9-hardened
 * Checking for suitable kernel configuration options...                                                                                                                                                                                                                [ ok ]
>>> Unpacking source...
>>> Unpacking glib-2.40.2.tar.xz to /var/tmp/portage/dev-libs/glib-2.40.2/work
>>> Unpacking pkg-config-0.28.tar.gz to /var/tmp/portage/dev-libs/glib-2.40.2/work
>>> Source unpacked in /var/tmp/portage/dev-libs/glib-2.40.2/work
>>> Preparing source in /var/tmp/portage/dev-libs/glib-2.40.2/work/glib-2.40.2 ...
mv: cannot stat '/var/tmp/portage/dev-libs/glib-2.40.2/work/pkg-config-*/pkg.m4': No such file or directory
 * ERROR: dev-libs/glib-2.40.2::gentoo failed (prepare phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line  93:  Called src_prepare
 *   environment, line 5934:  Called die
 * The specific snippet of code:
 *       mv -f "${WORKDIR}"/pkg-config-*/pkg.m4 "${S}"/m4macros/ || die;
 * 
 * If you need support, post the output of `emerge --info '=dev-libs/glib-2.40.2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-libs/glib-2.40.2::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-libs/glib-2.40.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-libs/glib-2.40.2/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-libs/glib-2.40.2/work/glib-2.40.2'
 * S: '/var/tmp/portage/dev-libs/glib-2.40.2/work/glib-2.40.2'
Comment 1 BRULE Herman 2015-04-24 10:49:22 UTC
Created attachment 401904 [details]
emerge info
Comment 2 BRULE Herman 2015-04-24 11:00:44 UTC
Created attachment 401906 [details]
emerge -pqv
Comment 3 Felix Janda 2015-04-26 14:05:52 UTC
What output do you get when running

sudo ls -l /var/tmp/portage/dev-libs/glib-2.40.2/work
sudo ls /var/tmp/portage/dev-libs/glib-2.40.2/work/pkg-config-0.28/pkg.m4

after a build failure?
Comment 4 BRULE Herman 2015-04-26 22:50:33 UTC
Created attachment 402082 [details]
munin file into folder
Comment 5 BRULE Herman 2015-04-26 22:50:47 UTC
Done
Comment 6 Alexander Tsoy 2015-04-28 15:55:56 UTC
Duplicate of bug 518598 ?
Comment 7 BRULE Herman 2015-04-28 16:15:24 UTC
hard to say
Comment 8 Felix Janda 2015-04-28 17:55:36 UTC
I'm pretty sure it's the same bug.
Comment 9 Gilles Dartiguelongue gentoo-dev 2015-05-02 10:27:06 UTC
Most likely a duplicate indeed.

*** This bug has been marked as a duplicate of bug 518598 ***