Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 54743 - gnustep-base/gnustep-base-1.9.2 (New and Updated package).
Summary: gnustep-base/gnustep-base-1.9.2 (New and Updated package).
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High enhancement (vote)
Assignee: Gnustep herd
URL:
Whiteboard:
Keywords:
Depends on: 54741 54930
Blocks: 54740 54747
  Show dependency tree
 
Reported: 2004-06-22 07:40 UTC by Armando Di Cianno (RETIRED)
Modified: 2004-09-23 20:30 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
This is the main ebuild for the software package. (gnustep-base-1.9.2.ebuild,2.28 KB, text/plain)
2004-06-22 07:41 UTC, Armando Di Cianno (RETIRED)
Details
This is a user support script for the package, to ease setup. (config-gnustep-base.sh,449 bytes, application/octet-stream)
2004-06-22 07:42 UTC, Armando Di Cianno (RETIRED)
Details
Patch the main ebuild of the package to support libffi or ffcall, not just ffcall. (gnustep-base-1.9.2.ebuild-support-libffi.patch,684 bytes, patch)
2004-06-23 14:05 UTC, Armando Di Cianno (RETIRED)
Details | Diff
Newest ebuild (not a patch, sorry) (gnustep-base-1.9.2.ebuild,2.50 KB, text/plain)
2004-06-27 13:29 UTC, Armando Di Cianno (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Armando Di Cianno (RETIRED) gentoo-dev 2004-06-22 07:40:19 UTC
Please find attached the main ebuild package, as well as a script to ease user setup of the gnustep-base package.

The GNUstep base package offers an object oriented framework to create non-grpahical applications.

See bug 54740 for suggestions about ebuild placement in portage.

For now, this ebuild must depend on gnustep-make: see bug 54741
Comment 1 Armando Di Cianno (RETIRED) gentoo-dev 2004-06-22 07:41:25 UTC
Created attachment 33831 [details]
This is the main ebuild for the software package.
Comment 2 Armando Di Cianno (RETIRED) gentoo-dev 2004-06-22 07:42:20 UTC
Created attachment 33832 [details]
This is a user support script for the package, to ease setup.
Comment 3 Armando Di Cianno (RETIRED) gentoo-dev 2004-06-22 07:44:27 UTC
misnamed the bug
Comment 4 Armando Di Cianno (RETIRED) gentoo-dev 2004-06-23 14:05:13 UTC
Created attachment 33982 [details, diff]
Patch the main ebuild of the package to support libffi or ffcall, not just ffcall.
Comment 5 Armando Di Cianno (RETIRED) gentoo-dev 2004-06-23 14:06:17 UTC
Comment on attachment 33982 [details, diff]
Patch the main ebuild of the package to support libffi or ffcall, not just ffcall.

support libffi or ffcall, not just ffcall.
Comment 6 Armando Di Cianno (RETIRED) gentoo-dev 2004-06-23 14:08:50 UTC
You're gonna need dev-libs/libffi-2.0_beta to use libffi support.

Supposedly ffcall uses mprotect which pax doesn't like.

check bug 52505 for a little more info
Comment 7 Armando Di Cianno (RETIRED) gentoo-dev 2004-06-27 13:29:14 UTC
Created attachment 34296 [details]
Newest ebuild (not a patch, sorry)

Newest ebuild takes care of some userpriv/usersandbox FEATURES issues.
Comment 8 Armando Di Cianno (RETIRED) gentoo-dev 2004-09-23 20:30:38 UTC
newer package available