Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 547264 - sys-apps/iproute2: please install ss in /bin/
Summary: sys-apps/iproute2: please install ss in /bin/
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-21 07:28 UTC by Vadim A. Misbakh-Soloviov (mva)
Modified: 2022-05-28 06:59 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vadim A. Misbakh-Soloviov (mva) gentoo-dev 2015-04-21 07:28:19 UTC
Hi. This bug is something like #330115 . It also can be used by regular users, and it is also installed in /bin in Debian (as reported by my buddies) and, probably, RH-based distros. And it's analog (netstat in that case) is already installing in /bin.

Reproducible: Always
Comment 1 William Hubbs gentoo-dev 2015-05-01 16:43:57 UTC
I'm wondering if we should just move all of iproute2 to /bin since the
bin/sbin split is becoming so much less significant these days?
Comment 2 Vadim A. Misbakh-Soloviov (mva) gentoo-dev 2016-10-15 07:22:41 UTC
1) ping?
2) @WilliamH, sure, why not?
Comment 3 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2017-11-30 00:42:15 UTC
williamh: ping on this.

potential plan:
- move to /bin
- put symlinks in /sbin for 6 months?
Comment 4 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2017-11-30 00:58:29 UTC
There are NO uses of any of the following binaries with a path in the portage tree directly:

arpd
ctstat
devlink
genl
ifcfg
ifstat**
lnstat
nstat
rdma
routef
routel
rtacct
rtmon
rtpr
rtstat
tipc

I have not finished checking:
ss
tc
bridge

Interesting cases: 
- ifstat already can be ambiguous with net-analyzer/ifstat

That means any remaining use would be inside packages themselves.
Comment 5 Vadim A. Misbakh-Soloviov (mva) gentoo-dev 2020-12-11 05:56:01 UTC
ping?
Comment 6 Vadim A. Misbakh-Soloviov (mva) gentoo-dev 2022-05-03 16:59:33 UTC
ping?
Comment 7 Larry the Git Cow gentoo-dev 2022-05-28 02:52:28 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=5ccf7bd5334ae6f3d5577b638ef793a295d4e0f0

commit 5ccf7bd5334ae6f3d5577b638ef793a295d4e0f0
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2022-05-28 02:38:50 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2022-05-28 02:52:20 +0000

    sys-apps/iproute2: add 5.18.0
    
    Moves /sbin/ss -> /bin/ss with a compatibility symlink in /sbin.
    
    Closes: https://bugs.gentoo.org/547264
    Signed-off-by: Sam James <sam@gentoo.org>

 sys-apps/iproute2/Manifest               |   1 +
 sys-apps/iproute2/iproute2-5.18.0.ebuild | 174 +++++++++++++++++++++++++++++++
 sys-apps/iproute2/iproute2-9999.ebuild   |  36 ++++---
 3 files changed, 195 insertions(+), 16 deletions(-)