Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 546744 - x11-base/xorg-server-1.17.1-r1 fail to build with gcc5
Summary: x11-base/xorg-server-1.17.1-r1 fail to build with gcc5
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL: http://cgit.freedesktop.org/xorg/xser...
Whiteboard:
Keywords: PATCH
: 548274 553100 (view as bug list)
Depends on:
Blocks: gcc-5
  Show dependency tree
 
Reported: 2015-04-16 08:46 UTC by Cănărău Constantin
Modified: 2015-07-11 09:03 UTC (History)
12 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch from Fedora which fix issue (gcc50.patch,684 bytes, patch)
2015-04-16 08:47 UTC, Cănărău Constantin
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Cănărău Constantin 2015-04-16 08:46:14 UTC
x11-base/xorg-server-1.17.1-r1 does not build with gcc5

Reproducible: Always
Comment 1 Cănărău Constantin 2015-04-16 08:47:17 UTC
Created attachment 401326 [details, diff]
Patch from Fedora which fix issue
Comment 2 Rafał Mużyło 2015-04-16 09:13:09 UTC
There's a slightly different patch on master:
http://cgit.freedesktop.org/xorg/xserver/commit/?id=21b896939c5bb242f3aacc37baf12379e43254b6
Comment 3 Martin Väth 2015-05-01 13:17:17 UTC
*** Bug 548274 has been marked as a duplicate of this bug. ***
Comment 4 Mark Wright gentoo-dev 2015-05-01 14:23:28 UTC
Thanks to Cănărău Constantin for reporting and the patch from Fedora, and
Rafał Mużyło for the patch from upstream.  With the patch from upstream applied
in x11-base/xorg-server-1.17.1-r1 it builds fine with gcc 5.1.0.
Comment 5 Joe Kappus 2015-05-05 05:40:54 UTC
That patch works but you still need to build without graphite optimization or a fail will occur.
Comment 6 Aric Belsito 2015-05-07 19:17:55 UTC
(In reply to Joe Kappus from comment #5)
> That patch works but you still need to build without graphite optimization
> or a fail will occur.

I only get the build failure with graphite loop optimizations if I use the "-flto" or "-O3" flags.

My flags for building xorg-server right now are "-march=native -pipe -O2 -fgraphite-identity -floop-interchange -floop-strip-mine -floop-block", which work.
Comment 7 aditya3098 2015-05-19 04:20:46 UTC
I can confirm this patch works flawlessly
Comment 8 Christoph Junghans gentoo-dev 2015-05-29 16:16:16 UTC
I can confirm the issue and the solution of it by the patch.
Comment 9 Michael Weber (RETIRED) gentoo-dev 2015-06-21 22:21:31 UTC
Please add it to tree, confirmed++
Comment 10 Chí-Thanh Christopher Nguyễn gentoo-dev 2015-06-24 09:15:49 UTC
*** Bug 553100 has been marked as a duplicate of this bug. ***
Comment 11 Ryan Hill (RETIRED) gentoo-dev 2015-07-11 09:03:07 UTC
Fixed in 1.17.2.