Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 54575 - failed to compile libmpeg2-0.4.0b (ld error with "-lartsc")
Summary: failed to compile libmpeg2-0.4.0b (ld error with "-lartsc")
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-06-20 16:40 UTC by Matthias F. Brandstetter
Modified: 2004-10-04 08:37 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias F. Brandstetter gentoo-dev 2004-06-20 16:40:53 UTC
When trying to merge libmpeg2-0.4.0b I get the following error during
compilation:

--<snip>--
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.3/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lartsc
collect2: ld returned 1 exit status
make[1]: *** [mpeg2dec] Error 1
make[1]: Leaving directory `/var/tmp/portage/libmpeg2-0.4.0b/work/mpeg2dec-0.4.0/src'
make: *** [all-recursive] Error 1
--</snip>--

I have the following ld versions:

--<snip>--
[ 01:38 haim@itchy ~ ] qpkg -f -v /usr/bin/ld
dev-lang/nasm-0.98.34 *
sys-devel/bin86-0.16.10 *
sys-devel/binutils-2.14.90.0.8-r1 *
sys-libs/glibc-2.3.3_pre20040207 *
--</snip>--

Any ideas?
Greetings, Matthias

Reproducible: Always
Steps to Reproduce:
$ emerge libmpeg2
Comment 1 Mr. Bones. (RETIRED) gentoo-dev 2004-06-21 01:21:42 UTC
reopen with the output from emerge --info please.
Comment 2 Matthias F. Brandstetter gentoo-dev 2004-06-21 03:51:02 UTC
[ 12:49 haim@itchy ~ ] emerge --info
Portage 2.0.50 (default-x86-1.4, gcc-3.3.3, glibc-2.3.3_pre20040207-r0, 2.4.20-gentoo-r5)
=================================================================
System uname: 2.4.20-gentoo-r5 i686 AMD Athlon(tm) XP 2100+
cat: /etc/gentoo-release: No such file or directory
Autoconf: sys-devel/autoconf-2.58
Automake: sys-devel/automake-1.8.3
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE=""
ARCH="x86"
AUTOCLEAN="yes"
BASH_ENV="/etc/portage/bashrc"
CC="gcc"
CFLAGS="-O2 -march=athlon-xp -pipe -w"
CHOST="i686-pc-linux-gnu"
CLASSPATH="."
CLEAN_DELAY="5"
COLORTERM=""
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb:/usr/kde/3.2/share/config:/usr/share/config /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CRYSTAL="/opt/crystal"
CVS_RSH="ssh"
CXXFLAGS="-O2 -march=athlon-xp -pipe -w"
DISPLAY=":0.0"
DISTDIR="/usr/portage/distfiles"
EDITOR="/usr/bin/vim"
FEATURES="autoaddcvs ccache sandbox"
FETCHCOMMAND="/usr/bin/wget -t 5 --passive-ftp -P ${DISTDIR} ${URI}"
GDK_USE_XFT="1"
GENTOO_MIRRORS="http://gentoo.inode.at/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://mirrors.sec.informatik.tu-darmstadt.de/gentoo http://ftp.uni-erlangen.de/pub/mirrors/gentoo"
GPG_AGENT_INFO="/tmp/gpg-9wcAR8/S.gpg-agent:8663:1"
GRP_STAGE23_USE="ipv6 pam tcpd readline nls ssl gpm perl python berkdb acl ncurses"
GS_LIB="/home/haim/.fonts"
GTK2_RC_FILES="/etc/gtk-2.0/gtkrc:/home/haim/.gtkrc-2.0:/home/haim/.kde3.2/share/config/gtkrc"
GTK_RC_FILES="/etc/gtk/gtkrc:/home/haim/.gtkrc:/home/haim/.kde3.2/share/config/gtkrc"
G_BROKEN_FILENAMES="1"
HOME="/home/haim"
HOSTNAME="itchy"
INFODIR="/usr/share/info:/usr/X11R6/info"
INFOPATH="/usr/share/gcc-data/i686-pc-linux-gnu/3.3/info"
INPUTRC="/etc/inputrc"
JAVAC="/opt/blackdown-jdk-1.4.1/bin/javac"
JAVA_HOME="/opt/blackdown-jdk-1.4.1"
JDK_HOME="/opt/blackdown-jdk-1.4.1"
KDEDIR="/usr/kde/3.2"
KDEDIRS="/usr"
KDE_FULL_SESSION="true"
KDE_MULTIHEAD="false"
KONSOLE_DCOP="DCOPRef(konsole-5317,konsole)"
KONSOLE_DCOP_SESSION="DCOPRef(konsole-5317,session-1)"
LD_LIBRARY_PATH=":/usr/lib/wine/lib:/usr/lib/wine/lib"
LESSOPEN="|lesspipe.sh %s"
LOGNAME="haim"
LS_COLORS="no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.deb=01;31:*.rpm=01;31:*.jpg=01;35:*.gif=01;35:*.bmp=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.png=01;35:*.mpg=01;35:*.avi=01;35:*.fli=01;35:*.gl=01;35:*.dl=01;35:"
MAIL="/var/mail/haim"
MAKEOPTS="-j2"
MANPATH="/usr/share/man:/usr/local/share/man:/usr/share/gcc-data/i686-pc-linux-gnu/3.3/man:/usr/X11R6/man:/opt/blackdown-jdk-1.4.1/man:/usr/qt/3/man:/usr/qt/3/doc/man:/opt/vmware/man"
NOCOLOR="false"
PAGER="/usr/bin/most"
PATH="/bin:/usr/bin:/sbin:/usr/sbin:/usr/X11R6/bin:/usr/kde/3.2/bin:/usr/games/bin:/usr/bin/wrappers:/opt/blackdown-jdk-1.4.1_beta/bin"
PKGDIR="/usr/portage/packages"
PORTAGE_BINHOST_CHUNKSIZE="3000"
PORTAGE_CACHEDIR="/var/cache/edb/dep/"
PORTAGE_CALLER="emerge"
PORTAGE_GID="250"
PORTAGE_MASTER_PID="5349"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PRELINK_PATH=""
PRELINK_PATH_MASK=""
PS1="\[\033[00m\][ \[\033[01;37m\]$(/bin/date +%H:%M) \[\033[01;32m\]\u@\h \[\033[01;34m\]$(ps1dir $PWD) \[\033[00m\]] "
PWD="/home/haim"
QMAKESPEC="linux-g++"
QTDIR="/usr/qt/3"
RESUMECOMMAND="/usr/bin/wget -c -t 5 --passive-ftp -P ${DISTDIR} ${URI}"
RPMDIR="/usr/portage/rpm"
RSYNC_RETRIES="3"
RSYNC_TIMEOUT="180"
SESSION_MANAGER="local/itchy:/tmp/.ICE-unix/8753"
SGML_CATALOG_FILES="/etc/sgml/sgml-ent.cat:/etc/sgml/sgml-docbook.cat:/etc/sgml/openjade-1.3.1.cat:/etc/sgml/sgml-docbook-3.1.cat:/etc/sgml/sgml-lite.cat:/etc/sgml/dsssl-docbook-stylesheets.cat"
SHELL="/bin/bash"
SHLVL="5"
STDCXX_INCDIR="g++-v3"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
TERM="xterm"
TMAKEPATH="/usr/lib/tmake/linux-g++"
USE="3dnow X aalib arts avi cdr crypt cups dga doc encode esd fastcgi foomaticdb gdbm gif gtk2 guile java jpeg kde kerberos libg++ libwww mad maildir md5sum motif mpeg mysql ncurses offensive opengl pam pdflib perl png python qt quicktime readline samba sdl slang sse ssl svga tcpd truetype usb videos x86 xine xml xml2 xmms xv zlib"
USER="haim"
USERLAND="GNU"
USE_EXPAND="VIDEO_CARDS INPUT_DEVICES LINGUAS"
WINDOWID="56623109"
XARGS="xargs -r"
XAUTHORITY="/home/haim/.Xauthority"
XINITRC="/etc/X11/xinit/xinitrc"
_="/usr/bin/emerge"
Comment 3 Seemant Kulleen (RETIRED) gentoo-dev 2004-06-21 12:29:21 UTC
On a tangential note, that we have 4 packages providing the /usr/bin/ld binary needs to be fixed -- cc'ing toolchain people here for that.
Comment 4 Martin Schlemmer (RETIRED) gentoo-dev 2004-06-21 12:40:18 UTC
I do not use qpkg, but either it is broken, or not correctly used:

---
nosferatu root # epm -qf /usr/bin/ld
binutils-2.15.91.0.1-r2
nosferatu root # epm -qG nasm bin86 binutils glibc
dev-lang/nasm-0.98.38
sys-devel/bin86-0.16.13
sys-devel/binutils-2.15.91.0.1-r2
sys-libs/glibc-2.3.4.20040619
nosferatu root #
---
Comment 5 solar (RETIRED) gentoo-dev 2004-06-21 12:48:46 UTC
qpkg output is indeed incorrect.

epm -q -l nasm | grep /usr/bin/ld
/usr/bin/ldrdf

epm -q -l bin86 | grep /usr/bin/ld
/usr/bin/ld86

epm -q -l glibc | grep /usr/bin/ld
/usr/bin/ldd
/usr/bin/lddlibc4

Not a toolchain bug.
Comment 6 SpanKY gentoo-dev 2004-06-23 17:38:43 UTC
the qpkg has already been filed ... it just matches a little too much atm
Comment 7 Matthias F. Brandstetter gentoo-dev 2004-06-24 00:59:27 UTC
Hi guys, I still have the problem with libmpeg2 compilation. Since I use arts,
I searched for file libartsc.so (found under /usr/lib), did a "ldconfig" as
root, but still have the same error.

Any ideas? If no one of you have any ideas, where could I look for further
help?
Comment 8 Patrick Kursawe (RETIRED) gentoo-dev 2004-10-01 04:48:54 UTC
I think libartsc should be installed below /usr/kde/.... Could you please check to which package it belongs using qpkg -f /usr/lib/libartsc.so?
Comment 9 Matthias F. Brandstetter gentoo-dev 2004-10-04 07:52:34 UTC
qpkg -f /usr/lib/libartsc.so gives me no output at all :(
Comment 10 Patrick Kursawe (RETIRED) gentoo-dev 2004-10-04 08:04:46 UTC
Looks like your libartsc.so doesn't come from any package portage knows about. Tried to compile it by hand or to install some dpkg/rpm?
I have this library in /usr/kde/(version number)/lib

Trying to link with orphaned/broken/non-existant libs can cause all kinds of headache. Please move the libartsc from /usr/lib out of the way and try again.
Comment 11 Matthias F. Brandstetter gentoo-dev 2004-10-04 08:37:46 UTC
that was it, thx alot!