Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 545740 - net-print/cups-2.0.2-r1 stable request
Summary: net-print/cups-2.0.2-r1 stable request
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Printing Team
URL: http://www.cups.org/str.php?L4539
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks:
 
Reported: 2015-04-06 14:47 UTC by Henning Schild
Modified: 2015-07-06 07:15 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Henning Schild 2015-04-06 14:47:21 UTC
The client.conf parser in cups-2.0.1 is broken, as a result network printing wont work unless running a cupsd on the clients as well.
It is likely that all possible options from the local client.conf are affected by the broken parser as well. I have just seen it for the "ServerName" option.

Reproducible: Always

Steps to Reproduce:
1. emerge net-print/cups-2.0.1-r1
2. mkdir ~/.cups && echo "ServerName www.gentoo.org" > ~/.cups/client.conf
3. lpstat -a
Actual Results:  
The lpstat will "work" for your local cupsd. The client.conf is ignored.

Expected Results:  
lpstat should fail since www.gentoo.org can not be used as print server. The config file should be read correctly.

The bug is fixed upstream (http://www.cups.org/str.php?L4539)
Comment 1 Pacho Ramos gentoo-dev 2015-04-10 13:53:30 UTC
It is also broken for systemd... please stabilize latest available version

Thanks
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2015-04-18 04:10:32 UTC
Stable for HPPA.
Comment 3 Agostino Sarubbo gentoo-dev 2015-04-19 08:57:48 UTC
amd64 stable
Comment 4 Agostino Sarubbo gentoo-dev 2015-04-19 09:59:17 UTC
x86 stable
Comment 5 Pacho Ramos gentoo-dev 2015-04-26 17:11:14 UTC
ppc stable
Comment 6 Agostino Sarubbo gentoo-dev 2015-04-28 09:51:29 UTC
sparc stable
Comment 7 Jeroen Roovers (RETIRED) gentoo-dev 2015-05-05 07:50:15 UTC
Stable for PPC64.
Comment 8 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2015-05-30 20:57:10 UTC
arm stable
Comment 9 Agostino Sarubbo gentoo-dev 2015-07-03 10:10:56 UTC
alpha stable
Comment 10 Matthias Maier gentoo-dev 2015-07-06 07:15:12 UTC
Superseded for ia64 by bug 551846.